libqxt-core0_0.6.2-1+b1_amd64.deb


Advertisement

Description

libqxt-core0 - extensions to Qt core classes (LibQxt)

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libqxt-core0
Package version: 0.6.2
Package release: 1+b1
Package architecture: amd64
Package type: deb
Installed size: 639 B
Download size: 162.26 KB
Official Mirror: ftp.br.debian.org
LibQxt is an extension library for the Qt application framework. LibQxt provides a suite of cross-platform utility classes to add functionality not readily available in Qt. The QxtCore module extends QtCore and contains core non-GUI functionality.

Alternatives

    Download

    Source package: libqxt

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libqxt-core0 deb package:
      # sudo apt-get install libqxt-core0

    Files

    • /usr/lib/x86_64-linux-gnu/libQxtCore.so.0
    • /usr/lib/x86_64-linux-gnu/libQxtCore.so.0.6
    • /usr/lib/x86_64-linux-gnu/libQxtCore.so.0.6.2
    • /usr/share/doc/libqxt-core0/changelog.Debian.amd64.gz
    • /usr/share/doc/libqxt-core0/changelog.Debian.gz
    • /usr/share/doc/libqxt-core0/changelog.gz
    • /usr/share/doc/libqxt-core0/copyright
    • /usr/share/lintian/overrides/libqxt-core0

    Changelog

    2013-12-04 - Thomas Pierson <contact@thomaspierson.fr> libqxt (0.6.2-1) unstable; urgency=low * New upstream release. * Update the debian/watch file. Thanks to Bart Martens. * Remove deprecated DM-Upload-Allowed field in debian/control file. * Bump Standards-Version to 3.9.4. * Refresh patch: fix-forbidden-rpath-build-config.patch.

    2012-09-19 - Thomas Pierson <contact@thomaspierson.fr> libqxt (0.6.1-7) unstable; urgency=low * Add a patch to fix the configure script which does not take care of build flags environment variables. Thanks to Lenz McKAY. (Closes: #686878) * Export of default dpkg build flags in debian/rules.

    2012-05-04 - Thomas Pierson <contact@thomaspierson.fr> libqxt (0.6.1-6) unstable; urgency=low * Apply changes for Qt 4.8 Multiarch transition (Closes: #671661) : - Expect qt plugins in multiarch location. - Add a patch to use system qdoc3. * Switch package to multiarch : - Set "Pre-Depends: ${misc:Pre-Depends}" to shared libraries packages in debian/control. - Set "Multi-Arch: same" to shared libraries packages in debian/control. - Set Build-depend on debhelper >= 8.1.3 in debian/control. - Set Build-depend on libqt4-dev >= 4:4.8.0 in debian/control. - Set debian/compat to 8 - Replace occurrences of "/usr/lib/" in debian/*.install files with "/usr/lib/*/". - Replace occurrences of "/usr/lib" in debian/rules with "/usr/lib/$(DEB_HOST_MULTIARCH)". * Remove symbols files because it is too hard to maintain for this library. * Update package repository URLs. * Add DM-Upload-Allowed field in debian/control. * Update maintainer email address. * Bumped Standards-Version to 3.9.3, no changes needed.

    2011-11-30 - Thomas PIERSON <web.pierson@gmail.com> libqxt (0.6.1-5) unstable; urgency=low * Fix missing makespecs files. (Closes: #647617) * Fix symbols files for some architectures.

    2011-09-27 - Thomas PIERSON <web.pierson@gmail.com> libqxt (0.6.1-4) unstable; urgency=low * Decrease the symbols check level to avoid build failures and get full logs. * Fix lintian warnings in copyright file.

    2011-09-15 - Thomas PIERSON <web.pierson@gmail.com> libqxt (0.6.1-3) unstable; urgency=low * Apply patches on all symbols files to fix build troubles on many architectures. (Closes: #641777)

    2011-08-17 - Thomas PIERSON <web.pierson@gmail.com> libqxt (0.6.1-2) unstable; urgency=low [ Lisandro Damián Nicanor Pérez Meyer ] * Remove duplicates "Section" fileds in debian/control. * Do not add quilt as a B-D, sourve version 3.0 (quilt) already manages patches. * Do not call quilt_unpatch. It's not necessary. * Add symbols files using pkg-kde-tools. * Build-Depend on pkg-kde-tools in order to use pkgkde-symbolshelper. [ Thomas Pierson ] * Update Vcs-git URL. * Remove useless variable "${shlibs:Depends}" for libqxt-dev package in debian/control. * Update Standards-Version in debian/control.

    2010-12-14 - Thomas PIERSON <web.pierson@gmail.com> libqxt (0.6.1-1) unstable; urgency=low * Initial release. Thanks to Jérémy Bobbio for his sponsoring work. Thanks to Bruno Bigras for his patches. Thanks to J-P Nurmi for his initial work on a Debian package of libqxt. (Closes: #603701)

    Advertisement
    Advertisement