libquvi7_0.4.1-3_amd64.deb


Advertisement

Description

libquvi7 - library for parsing video download links (runtime libraries)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libquvi7
Package version 0.4.1
Package release 3
Package architecture amd64
Package type deb
Installed size 54 B
Download size 20.00 KB
Official Mirror ftp.br.debian.org
Library to parse Adobe flash video download links. It supports Youtube
and other similar video websites. It provides access to functionality and
data through an API, and does not enable or require the use of the
flash technology.

Alternatives

Package Version Architecture Repository
libquvi7_0.4.1-3_i386.deb 0.4.1 i386 Debian Main
libquvi7 - - -

Requires

Name Value
dpkg >= 1.15.6
libc6 >= 2.14
libcurl3-gnutls >= 7.16.2
liblua5.2-0 -
libquvi-scripts -
multiarch-support -

Download

Type URL
Binary Package libquvi7_0.4.1-3_amd64.deb
Source Package libquvi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libquvi7 deb package:
    # sudo apt-get install libquvi7

Files

Path
/usr/lib/x86_64-linux-gnu/libquvi.so.7
/usr/lib/x86_64-linux-gnu/libquvi.so.7.0.1
/usr/share/doc/libquvi7/changelog.Debian.gz
/usr/share/doc/libquvi7/changelog.gz
/usr/share/doc/libquvi7/copyright

Changelog

2015-01-04 - Ansgar Burchardt <ansgar@debian.org>
libquvi (0.4.1-3) unstable; urgency=medium
* Do not look for Lua helper scripts below current directory.
(Closes: #774555)
+ new patch: lua-scripts-below-cwd.patch
2014-05-22 - Andreas Henriksson <andreas@fatal.se>
libquvi (0.4.1-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Add build-dependency on pkg-config (Closes: #747798)
* Switch build-dependency from liblua5.1-0-dev to liblua5.2-dev
* Add debian/patches/lua52.patch
- make configure.ac check for lua5.2.pc
* Add Breaks: mpv (<< 0.3.10-2~) which uses both libquvi and lua5.1
- Alessandro Ghedini (ghedo@) will take care of fixing mpv
2013-10-09 - Ansgar Burchardt <ansgar@debian.org>
libquvi (0.4.1-2) unstable; urgency=low
* Use dh-autoreconf. This also updates config.{guess,sub} at build time.
Closes: #725832
* Apply upstream configure.ac changes for recent autotools.
+ new patch: configure.ac-add-missing-AM-macros.patch
* Bumped Standards-Version to 3.9.4 (no changes).
* debian/watch: Also look for bzip2 and xz compressed tarballs.
* debian/watch: Follow 0.4.x for now.
* debian/watch: Add pgpsigurlmangle option to verify upstream signature.
The PGP key used is the one from the last releases. It was not verified
further.
2012-04-25 - Ansgar Burchardt <ansgar@debian.org>
libquvi (0.4.1-1) unstable; urgency=low
* New upstream release.
* Drop dirname_from@Base from symbols file.
2012-03-03 - Ansgar Burchardt <ansgar@debian.org>
libquvi (0.4.0-2) unstable; urgency=low
* Upload to unstable.
* Add myself to Uploaders.
* Bump Standards-Version to 3.9.3.
+ Use copyright format 1.0 (no changes besides updated Format field).
2011-10-23 - Alejandro Garrido Mota <garridomota@gmail.com>
libquvi (0.4.0-1) experimental; urgency=low
[ Alejandro Garrido Mota ]
* New upstream release.
+ Supports YouTube again. (Closes: #636591)
+ Support for more YouTube URLs. (Closes: #615805)
* Lua scripts moved to libquvi-scripts. (Closes: #614384)
* Add multiarch support.
* d/control:
- Remove quvi package because upstream author split the project
- Add libquvi-scripts to (Build-)Depends.
- Add Vcs-* fields.
* d/copyright:
- Remove "share/*" entries.
- Change Format URL and Source URL.
- Adapt fields to properly revision.
* Rename and update symbol file from libquvi0.symbols to libquvi7.symbols.
* Rename libquvi0.install to libquvi7.install.
* Remove quvi.install
* Add lintian-override in source/lintian-overrides
* d/rules:
- Remove "--enable-nsfw" and add "--with-examples" argument
- Remove override_dh_auto_clean block
- Remove override_dh_auto_test: NO_INTERNET var is not used anymore.
* Change Architecture for libquvi-doc to all
* d/control: Add Vcs-* fields.
* d/watch: use of (\d.*) instead of (.*).
[ Ansgar Burchardt ]
* Build and install library documentation.
+ debian/control: Add build-dep on naturaldocs.
* No longer include Makefile.* as examples in libquvi-doc.
* Use xz compression for source and binary packages.
* debian/control: Remove soname from libquvi-dev's description.
2011-04-25 - Alejandro Garrido Mota <garridomota@gmail.com>
libquvi (0.2.15-1) unstable; urgency=low
* New upstream release (Closes: #622253). 
* Update d/watch to sf.net
* Update homepage field to quvi.sourceforge.net (Closes: #615554) 
* d/rules: Add dh_auto_test before NO_INTERNET=1 in override_dh_auto_test 
* Update Standards-Version field to 3.9.2 
* Add symbol (d/libquvi0.symbols) file.
2010-12-15 - Alejandro Garrido Mota <garridomota@gmail.com>
libquvi (0.2.11-1) unstable; urgency=low
* New upstream release (Closes: #607122, #606716).
* d/control: Remove PCRE dependency and replace "libcurl4-dev" by 
"libcurl4-gnutls-dev | libcurl4-dev"
* d/copyright: Update package license to LGPLv2.1+ and change lib/strepl.c
entry to "PD" (public domain). 
* d/rules: Add override_dh_installchangelogs to install NEWS file

See Also

Package Description
libqwt-dev_6.0.0-1.2_amd64.deb Qt widgets library for technical applications (development)
libqwt-doc_6.0.0-1.2_all.deb Qt widgets library for technical applications (documentation)
libqwt5-doc_5.2.3-1_all.deb Qt widgets library for technical applications (documentation)
libqwt5-qt4-dev_5.2.3-1_amd64.deb Qt4 widgets library for technical applications (development)
libqwt5-qt4_5.2.3-1_amd64.deb Qt4 widgets library for technical applications (runtime)
libqwt6_6.0.0-1.2_amd64.deb Qt widgets library for technical applications (runtime)
libqwtplot3d-doc_0.2.7+svn191-7_all.deb 3D plotting library based on Qt/OpenGL (documentation)
libqwtplot3d-qt4-0_0.2.7+svn191-7_amd64.deb 3D plotting library based on Qt4/OpenGL (runtime)
libqwtplot3d-qt4-dev_0.2.7+svn191-7_amd64.deb 3D plotting library based on Qt4/OpenGL (development)
libqxmlrpc-dev_0.0.svn6-2_amd64.deb full Qt4 based implementation of XML-RPC protocol. (headers)
libqxmlrpc-doc_0.0.svn6-2_all.deb full Qt4 based implementation of XML-RPC protocol. (headers)
libqxmlrpc1_0.0.svn6-2_amd64.deb full Qt4 based implementation of XML-RPC protocol
libqxmpp-dev_0.8.0-1_amd64.deb Development files for the QXmpp library
libqxmpp-doc_0.8.0-1_all.deb Documentation for the QXmpp library
libqxmpp0_0.8.0-1_amd64.deb QXmpp library for XMPP client and server applications
Advertisement
Advertisement