libquota-perl_1.7.1+dfsg-1+deb8u1_amd64.deb


Advertisement

Description

libquota-perl - Perl interface to file system quotas

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libquota-perl
Package version 1.7.1+dfsg
Package release 1+deb8u1
Package architecture amd64
Package type deb
Installed size 84 B
Download size 42.79 KB
Official Mirror ftp.br.debian.org
Quota is a Perl module that provides access to filesystem quota information.
This module uses the quotactl() or ioctl() system calls to set or query quota
information on the local host. It also supports remotely submitting queries
via RPC to a remote host.

Alternatives

Package Version Architecture Repository
libquota-perl_1.7.1+dfsg-1+deb8u1_i386.deb 1.7.1+dfsg i386 Debian Main
libquota-perl - - -

Requires

Name Value
libc6 >= 2.4
perl >= 5.20.2-3+deb8u5
perlapi-5.20.2 -

Download

Type URL
Binary Package libquota-perl_1.7.1+dfsg-1+deb8u1_amd64.deb
Source Package libquota-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libquota-perl deb package:
    # sudo apt-get install libquota-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Quota.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Quota/Quota.so
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Quota/autosplit.ix
/usr/share/doc/libquota-perl/changelog.Debian.gz
/usr/share/doc/libquota-perl/changelog.gz
/usr/share/doc/libquota-perl/copyright
/usr/share/doc/libquota-perl/examples/README
/usr/share/doc/libquota-perl/examples/mount-list-qcarg.pl
/usr/share/doc/libquota-perl/examples/mount-list.pl
/usr/share/doc/libquota-perl/examples/report-quota
/usr/share/doc/libquota-perl/examples/test-64bit.pl
/usr/share/doc/libquota-perl/examples/test-group.pl
/usr/share/doc/libquota-perl/examples/aix_jfs2_class/jfs2class.pm
/usr/share/doc/libquota-perl/examples/aix_jfs2_class/jfs2class.xs.gz
/usr/share/doc/libquota-perl/examples/aix_jfs2_class/test_jfs2.pl
/usr/share/doc/libquota-perl/examples/quotadm/README
/usr/share/doc/libquota-perl/examples/quotadm/quotadm.gz
/usr/share/doc/libquota-perl/examples/quotadm/quotawarn.msg
/usr/share/doc/libquota-perl/examples/quotamgmt/Author
/usr/share/doc/libquota-perl/examples/quotamgmt/config
/usr/share/doc/libquota-perl/examples/quotamgmt/quotamgmt
/usr/share/man/man3/Quota.3pm.gz

Changelog

2016-06-12 - Salvatore Bonaccorso <carnil@debian.org>
libquota-perl (1.7.1+dfsg-1+deb8u1) jessie; urgency=medium
* Team upload.
* Adapt platform detection to work as well under Linux 4.x
(Closes: #787463, #827101)
2013-10-23 - Salvatore Bonaccorso <carnil@debian.org>
libquota-perl (1.7.1+dfsg-1) unstable; urgency=low
* Team upload.
* Imported Upstream version 1.7.1+dfsg
2013-09-22 - Salvatore Bonaccorso <carnil@debian.org>
libquota-perl (1.7.0+dfsg-1) unstable; urgency=low
* Team upload.
[ Salvatore Bonaccorso ]
* Imported Upstream version 1.6.7+dfsg
* Refresh 02_gnu_hurd.patch.
Update for changes in Makefile.PL
* Drop add-support-for-Linux-3.x.patch patch.
Patch is applied upstream.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Update debian/repack.stub.
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Salvatore Bonaccorso ]
* Add copyright and license information for debian/repack.stub file
* Imported Upstream version 1.7.0+dfsg
* Update copyright years for upstream files
* Update copyright years for debian/* packaging files
* Bump Debhelper compat level to 9.
Adjust versioned Build-Depends on debhelper to (>= 9.20120312) to
include all hardening build-flags in ld line.
* Bump Standards-Version to 3.9.4
2011-11-03 - Salvatore Bonaccorso <carnil@debian.org>
libquota-perl (1.6.6+dfsg-2) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Add add-support-for-Linux-3.x.patch.
Add support to detect Linux 3.x via uname -rs which is used in
Makefile.PL to detect the operating system on which the build is run.
The Makefile.PL detected only Linux 2.x kernels, causing FTBFS with
recent kernels of version 3.x. (Closes: #646695)
* Remove 01_Makefile.PL-remove-unneeded-objects.patch.
According to upstream this issue should be resolved since version 1.5.1
of libquota-perl.
* Bump Debhelper compat level to 8.
Update versioned Build-Depends on debhelper to (>= 8).
* Update copyright for debian/* packaging
2011-06-12 - Nicholas Bamber <nicholas@periapt.co.uk>
libquota-perl (1.6.6+dfsg-1) unstable; urgency=low
* New upstream release
* Raised standards version to 3.9.2
2011-01-06 - Nicholas Bamber <nicholas@periapt.co.uk>
libquota-perl (1.6.5+dfsg-1) unstable; urgency=low
[ Nicholas Bamber ]
* Added myself to Uploaders
* New upstream release
* Refresh debian/source/format
* Upped standards version to 3.9.1
* Removed explicit references to quilt
* Refresh patches and forward where necessary
* Refreshed copyright
* Corrected license stanza on afsquota.c to 'Artistic or GPL-2+'
and removed X-Comment
Explanation: Between 1995-2001 this module was in the public domain.
Since then it has been published under either the Artistic license or
the GPL version 2. By version 1.60 (Oct 2007) the copyright situation
had been largely resolved, except for the file afsquota.c. As documented
in the RT ticket #28599, the maintainer clarified that the file
was no longer in the public domain. However this was not correctly
reflected in the Debian copyright file. This version attempts to 
accurately reflect the status quo.
2010-01-17 - Jonathan Yu <jawnsy@cpan.org>
libquota-perl (1.6.4+dfsg-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Add myself to Uploaders and Copyright
* Standards-Version 3.8.3 (drop perl version dep)
* Rewrite control description
* Add override to fix shebangs
* Update copyright to new DEP5 format
* Refresh copyright info from changelog trailers
[ Ryan Niebur ]
* Update ryan52's email address

See Also

Package Description
libqupzilla-dev_1.6.6-2_amd64.deb development files for qupzilla's shared library
libqupzilla1_1.6.6-2_amd64.deb shared library and header files for qupzilla
libquvi-dev_0.4.1-3_amd64.deb library for parsing video download links (development package)
libquvi-doc_0.4.1-3_all.deb library for parsing video download links (documentation package)
libquvi-scripts_0.4.21-2_all.deb library for parsing video download links (Lua scripts)
libquvi7_0.4.1-3_amd64.deb library for parsing video download links (runtime libraries)
libqwt-dev_6.0.0-1.2_amd64.deb Qt widgets library for technical applications (development)
libqwt-doc_6.0.0-1.2_all.deb Qt widgets library for technical applications (documentation)
libqwt5-doc_5.2.3-1_all.deb Qt widgets library for technical applications (documentation)
libqwt5-qt4-dev_5.2.3-1_amd64.deb Qt4 widgets library for technical applications (development)
libqwt5-qt4_5.2.3-1_amd64.deb Qt4 widgets library for technical applications (runtime)
libqwt6_6.0.0-1.2_amd64.deb Qt widgets library for technical applications (runtime)
libqwtplot3d-doc_0.2.7+svn191-7_all.deb 3D plotting library based on Qt/OpenGL (documentation)
libqwtplot3d-qt4-0_0.2.7+svn191-7_amd64.deb 3D plotting library based on Qt4/OpenGL (runtime)
libqwtplot3d-qt4-dev_0.2.7+svn191-7_amd64.deb 3D plotting library based on Qt4/OpenGL (development)
Advertisement
Advertisement