libquickfix14_1.13.3+dfsg-9_amd64.deb


Advertisement

Description

libquickfix14 - FIX protocol library - runtime files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libquickfix14
Package version 1.13.3+dfsg
Package release 9
Package architecture amd64
Package type deb
Installed size 1.16 KB
Download size 357.83 KB
Official Mirror ftp.br.debian.org
The Financial Information eXchange (FIX) Protocol is a message standard
developed to facilitate the electronic exchange of information related to
securities transactions. It is intended for use between trading partners
wishing to automate communications.
This package includes the quickfix runtime files.

Alternatives

Package Version Architecture Repository
libquickfix14_1.13.3+dfsg-9_i386.deb 1.13.3+dfsg i386 Debian Main
libquickfix14 - - -

Requires

Name Value
libc6 >= 2.15
libgcc1 >= 1:4.1.1
libmysqlclient18 >= 5.5.24+dfsg-1
libpq5 -
libstdc++6 >= 4.9
libxml2 >= 2.7.4

Download

Type URL
Binary Package libquickfix14_1.13.3+dfsg-9_amd64.deb
Source Package quickfix

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libquickfix14 deb package:
    # sudo apt-get install libquickfix14

Files

Path
/usr/lib/libquickfix.so.14
/usr/lib/libquickfix.so.14.0.0
/usr/share/doc/libquickfix14/NEWS.gz
/usr/share/doc/libquickfix14/changelog.Debian.gz
/usr/share/doc/libquickfix14/copyright

Changelog

2014-06-19 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-9) unstable; urgency=low
* Fix FTBFS on hurd-i386; thanks to Pino Toscano for the patch
(Closes: #745943)
* Fix incorrect manual copying of config.{sub,guess}; thanks to Logan
Rosen for the patch (Closes: #745156)
* Update Vcs-* fields to point to GitHub
2014-03-31 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-8) unstable; urgency=low
* Standardize patch names and number patches
* Fix FTBFS: explicitly use -pthread when building on kfreebsd-*
2014-03-04 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-7) unstable; urgency=low
* Drop Ruby and Python bindings (Closes: #735438, #717412, #739779)
* Update to Standards-Version 3.9.5 (no changes)
2013-07-20 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-6) unstable; urgency=low
* Ensure `xargs` doesn't call `chmod` if nothing is found (Closes: #717199)
* Document how to regenerate SWIG-generated files
2013-07-10 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-5) unstable; urgency=low
* Add Vcs-* fields to debian/control
* Update to Standards-Version 3.9.4 (no changes)
* Build with hardening options, adjust flags, and fix binary-indep target
* Patches to correct format string insecurity, as well replace deprecated
calls (Closes: 676083)
* Rename binary package libquickfix-ruby1.8 to ruby-quickfix, also remove
binary support for Ruby 1.8 and add binary support for Ruby 1.9
2012-01-03 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-4) unstable; urgency=low
* Change Build-Depends to use default Python version (Closes: #653798)
2011-11-26 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-3) unstable; urgency=low
* Apply test_runner_bad_virtual_method_arg.patch from unittest++ source,
since quickfix embeds its own copy of UnitTest++ (Closes: #648257)
2011-10-10 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-2) unstable; urgency=low
* Only apply -msse3 optimization when it will work, thanks to Nobuhiro
Iwamatsu for the patch (Closes: #644450)
2011-09-20 - Roberto C. Sanchez <roberto@connexer.com>
quickfix (1.13.3+dfsg-1) unstable; urgency=low
* Initial release (Closes: #642268)

See Also

Package Description
libquicktime-dev_1.2.4-7+deb8u1_amd64.deb library for reading and writing Quicktime files (development)
libquicktime-doc_1.2.4-7+deb8u1_all.deb library for reading and writing Quicktime files (documentation)
libquicktime2_1.2.4-7+deb8u1_amd64.deb library for reading and writing Quicktime files
libquorum-dev_1.4.6-1.1_amd64.deb Standards-based cluster framework, Quorum devel files
libquorum4_1.4.6-1.1_amd64.deb Standards-based cluster framework, Quorum library
libquota-perl_1.7.1+dfsg-1+deb8u1_amd64.deb Perl interface to file system quotas
libqupzilla-dev_1.6.6-2_amd64.deb development files for qupzilla's shared library
libqupzilla1_1.6.6-2_amd64.deb shared library and header files for qupzilla
libquvi-dev_0.4.1-3_amd64.deb library for parsing video download links (development package)
libquvi-doc_0.4.1-3_all.deb library for parsing video download links (documentation package)
libquvi-scripts_0.4.21-2_all.deb library for parsing video download links (Lua scripts)
libquvi7_0.4.1-3_amd64.deb library for parsing video download links (runtime libraries)
libqwt-dev_6.0.0-1.2_amd64.deb Qt widgets library for technical applications (development)
libqwt-doc_6.0.0-1.2_all.deb Qt widgets library for technical applications (documentation)
libqwt5-doc_5.2.3-1_all.deb Qt widgets library for technical applications (documentation)
Advertisement
Advertisement