libqt4pas5_2.5-12_amd64.deb


Advertisement

Description

libqt4pas5 - Qt4 interface bindings for Pascal

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libqt4pas5
Package version 2.5
Package release 12
Package architecture amd64
Package type deb
Installed size 2.56 KB
Download size 448.46 KB
Official Mirror ftp.br.debian.org
Provides interface for Pascal applications
to the Qt4 C++ libraries.
This binding does not cover the whole Qt4 framework, it
just contains all classes needed to use Qt as a widgetset.

Alternatives

Package Version Architecture Repository
libqt4pas5_2.5-12_i386.deb 2.5 i386 Debian Main
libqt4pas5 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libqt4-network >= 4:4.5.3
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.6.1
libqtwebkit4 >= 2.1.0~2011week13
libstdc++6 >= 4.1.1
multiarch-support -

Download

Type URL
Binary Package libqt4pas5_2.5-12_amd64.deb
Source Package libqt4pas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt4pas5 deb package:
    # sudo apt-get install libqt4pas5

Files

Path
/usr/lib/x86_64-linux-gnu/libQt4Pas.so.5
/usr/lib/x86_64-linux-gnu/libQt4Pas.so.5.2
/usr/lib/x86_64-linux-gnu/libQt4Pas.so.5.2.5
/usr/share/doc/libqt4pas5/changelog.Debian.gz
/usr/share/doc/libqt4pas5/copyright

Changelog

2014-08-12 - Matthias Klumpp <mak@debian.org>
libqt4pas (2.5-12) unstable; urgency=medium
* Update symbols file
2014-07-22 - Matthias Klumpp <mak@debian.org>
libqt4pas (2.5-11) unstable; urgency=medium
* Update symbols file for ppc64 (Closes: #743761)
* Update symbols file for mips64(el) (Closes: #729766)
* Build-depend on fpc: According to upstream, libqt4pas
can and should not be used as generic C Qt wrapper.
(It therefore makes sense to only have it available on
architectures where a Pascal compiler is present)
* Bump standards version: No change needed
2013-06-24 - Matthias Klumpp <mak@debian.org>
libqt4pas (2.5-10) unstable; urgency=low
* Use pkgkde_symbolshelper dh addon
* Updated symbols file
2013-06-23 - Matthias Klumpp <mak@debian.org>
libqt4pas (2.5-9) unstable; urgency=low
* Fix Git browser URL
* Adjust symbols file on amd64 (Closes: #713348)
2013-06-13 - Matthias Klumpp <mak@debian.org>
libqt4pas (2.5-8) unstable; urgency=low
* Use Git to maintain the package
* Fix debian/rules for qmake changes
* Fix FTBFS on powerpcspe (Closes: #693687)
* Fix FTBFS with GCC-4.8 (Closes: #701309)
2012-07-09 - Matthias Klumpp <matthias@tenstral.net>
libqt4pas (2.5-7) unstable; urgency=low
* Update symbols file again, looks like pkgkde-symbolshelper
did not work properly the first time. (Closes: #680440)
2012-06-26 - Matthias Klumpp <matthias@tenstral.net>
libqt4pas (2.5-6) unstable; urgency=low
* Fix FTBFS on hurd-i386
2012-06-05 - Matthias Klumpp <matthias@tenstral.net>
libqt4pas (2.5-5) unstable; urgency=low
* Updated symbols file for kfreebsd-amd64
2012-05-25 - Matthias Klumpp <matthias@tenstral.net>
libqt4pas (2.5-4) unstable; urgency=low
* Updated symbols-file for all architectures
* Adjusted debian/watch file to new layout
2012-05-23 - Matthias Klumpp <matthias@tenstral.net>
libqt4pas (2.5-3) unstable; urgency=low
* Fix issues with the symbols-file on some archs (again)

See Also

Package Description
libqt5bluetooth5_5.3.2-2_amd64.deb Qt Connectivity Bluetooth module
libqt5clucene5_5.3.2-3_amd64.deb Qt 5 CLucene module
libqt5concurrent5_5.3.2+dfsg-4+deb8u2_amd64.deb Qt 5 concurrent module
libqt5core5a_5.3.2+dfsg-4+deb8u2_amd64.deb Qt 5 core module
libqt5dbus5_5.3.2+dfsg-4+deb8u2_amd64.deb Qt 5 D-Bus module
libqt5declarative5_5.3.2-3_amd64.deb Qt Quick 1 module for Qt 5
libqt5designer5_5.3.2-3_amd64.deb Qt 5 designer module
libqt5designercomponents5_5.3.2-3_amd64.deb Qt 5 Designer components module
libqt5gui5_5.3.2+dfsg-4+deb8u2_amd64.deb Qt 5 GUI module
libqt5help5_5.3.2-3_amd64.deb Qt 5 help module
libqt5keychain0_0.4.0-1_amd64.deb Qt API to store passwords (QT5 version)
libqt5multimedia5-plugins_5.3.2-5_amd64.deb Qt 5 Multimedia module plugins
libqt5multimedia5_5.3.2-5_amd64.deb Qt 5 Multimedia module
libqt5multimediaquick-p5_5.3.2-5_amd64.deb Qt 5 Multimedia Quick module
libqt5multimediawidgets5_5.3.2-5_amd64.deb Qt 5 Multimedia Widgets module
Advertisement
Advertisement