libpuzzle-dev_0.9-6+b1_amd64.deb


Advertisement

Description

libpuzzle-dev - quick similar image finder - development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpuzzle-dev
Package version 0.9
Package release 6+b1
Package architecture amd64
Package type deb
Installed size 44 B
Download size 21.33 KB
Official Mirror ftp.br.debian.org
The Puzzle library is designed to quickly find visually similar images
(GIF, PNG, JPG), even if they have been resized, recompressed,
recolored or slightly modified.
This package contains the development files.

Alternatives

Package Version Architecture Repository
libpuzzle-dev_0.9-6+b1_i386.deb 0.9 i386 Debian Main
libpuzzle-dev - - -

Requires

Name Value
libpuzzle1 = 0.9-6+b1

Download

Type URL
Binary Package libpuzzle-dev_0.9-6+b1_amd64.deb
Source Package libpuzzle

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpuzzle-dev deb package:
    # sudo apt-get install libpuzzle-dev

Files

Path
/usr/include/puzzle.h
/usr/lib/x86_64-linux-gnu/libpuzzle.a
/usr/lib/x86_64-linux-gnu/libpuzzle.so
/usr/share/doc/libpuzzle-dev/AUTHORS
/usr/share/doc/libpuzzle-dev/README.gz
/usr/share/doc/libpuzzle-dev/THANKS
/usr/share/doc/libpuzzle-dev/changelog.Debian.amd64.gz
/usr/share/doc/libpuzzle-dev/changelog.Debian.gz
/usr/share/doc/libpuzzle-dev/copyright
/usr/share/man/man3/libpuzzle.3.gz
/usr/share/man/man3/puzzle_set.3.gz

Changelog

2014-03-21 - Emmanuel Bouthenot <kolter@debian.org>
libpuzzle (0.9-6) unstable; urgency=medium
* Add a patch to force linking against libm (Closes: #734564)
* Use dh-autoreconf instead of autotools-dev to fix FTBFS on
ppc64el. Thanks to Logan Rosen <logan@ubuntu.com> for the patches.
* Bump Standards-Version to 3.9.5
* Tiny updates in debian/copyright
* Fix Vcs-Browser field
* Add symbols file for libpuzzle1
2012-05-06 - Emmanuel Bouthenot <kolter@debian.org>
libpuzzle (0.9-5) unstable; urgency=low
* Taking over the maintenance of libpuzzle: add myself to Uploaders
(Closes: #651426)
* Bump Standards-Version to 3.9.3
* Switch source format to '3.0 (quilt)'
* Switch build system to full debhelper 9 (bye bye CDBS)
* Add a patch to cleanly build the PHP module separately
* Add Multi-Arch support
* Fix typo in libpuzzle manpage
* Fix various pod errors in manpages pod files
* Switch debian/copyright to DEP5 format
* Update Vcs-* fields
* Use php5{en,dis}mod for conffile handling (Closes: #667769)
2010-01-28 - Cyril Brulebois <kibi@debian.org>
libpuzzle (0.9-4) unstable; urgency=high
* Fix missing dependency on phpapi-* for libpuzzle-php, thanks to
Raphael Geissert (Closes: #566289):
- Add ${php:Depends} to its Depends.
- Use $(php-config5 --phpapi) to define this variable in the
associated substvars file.
* Set urgency to “high” accordingly.
2010-01-03 - Cyril Brulebois <kibi@debian.org>
libpuzzle (0.9-3) unstable; urgency=low
* Fix comment in debian/libpuzzle.ini as requested by Thijs Kinkhorst
since the previous style generates warnings with PHP 5.3: Replace
leading “#” with “;”, which is said to work with all current PHP
versions.
* Add ${misc:Depends} to libpuzzle-dev.
2008-04-26 - Cyril Brulebois <kibi@debian.org>
libpuzzle (0.9-2) unstable; urgency=low
* Pass “LDFLAGS=""” to the PHP extension's ./configure script. Since
dpkg-buildpackage now exports LDFLAGS, an FTBFS is triggered because
of “-Wl,-z,defs” (which was previously only used for the shared
library, as intended); and since “-Wl,--as-needed” isn't sufficient to
get rid of extra linking for that extension anyway, passing an empty
LDFLAGS variable for that part of the build (Closes: #475984).
* Move the maintainership to pkg-phototools as originally planned
(thanks to to Emmanuel Bouthenot who proposed that package):
- Set Maintainer to pkg-phototools.
- Set Uploaders to myself, and update the mail address.
- Add Vcs-Browser and Vcs-Git.
2008-03-17 - Cyril Brulebois <cyril.brulebois@enst-bretagne.fr>
libpuzzle (0.9-1) unstable; urgency=low
* Initial release (Closes: #445180).

See Also

Package Description
libpuzzle-php_0.9-6+b1_amd64.deb quick similar image finder - PHP bindings
libpuzzle1_0.9-6+b1_amd64.deb quick similar image finder - shared library
libpvm3_3.4.5-12.6_amd64.deb Parallel Virtual Machine - shared libraries
libpwiz-dev_3.0.6585-2_amd64.deb library to perform proteomics data analyses (devel files)
libpwiz-doc_3.0.6585-2_all.deb set of programs to perform proteomics data analyses (doc)
libpwiz-tools_3.0.6585-2_amd64.deb ProteoWizard command line tools
libpwiz3_3.0.6585-2_amd64.deb library to perform proteomics data analyses (runtime)
libpwquality-common_1.2.3-1_all.deb library for password quality checking and generation (data files)
libpwquality-dev_1.2.3-1_amd64.deb Password quality checking and generation (development files)
libpwquality-tools_1.2.3-1_amd64.deb tools for password quality checking and generation
libpwquality1_1.2.3-1_amd64.deb library for password quality checking and generation
libpxp-ocaml-dev_1.2.4-1+b1_amd64.deb OCaml library that implements an XML-1.0 validating parser
libpycaml-ocaml-dev_0.82-14+b3_amd64.deb OCaml bindings to embed Python interpreter (development files)
libpycaml-ocaml_0.82-14+b3_amd64.deb OCaml bindings to embed Python interpreter (runtime)
libpynac-dev_0.3.2+dfsg-1_amd64.deb Engine for symbolic geometric calculus for Python (development files)
Advertisement
Advertisement