libpqxx-dev_4.0.1+dfsg-3_amd64.deb


Advertisement

Description

libpqxx-dev - C++ library to connect to PostgreSQL (development files)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpqxx-dev
Package version 4.0.1+dfsg
Package release 3
Package architecture amd64
Package type deb
Installed size 1.39 KB
Download size 377.21 KB
Official Mirror ftp.br.debian.org
C++ library to enable user programs to communicate with
the PostgreSQL database back-end.
This package contains header files for linking against libpqxx. Obsoletes
the libpqpp-dev package.

Alternatives

Package Version Architecture Repository
libpqxx-dev_4.0.1+dfsg-3_i386.deb 4.0.1+dfsg i386 Debian Main
libpqxx-dev - - -

Requires

Name Value
libpq-dev >= 8.0.3-1
libpqxx-4.0 = 4.0.1+dfsg-3
pkg-config -

Conflicts

Name Value
libpqxx4-dev -

Replaces

Name Value
libpqxx3-dev << 4
libpqxx4-dev -

Download

Type URL
Binary Package libpqxx-dev_4.0.1+dfsg-3_amd64.deb
Source Package libpqxx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpqxx-dev deb package:
    # sudo apt-get install libpqxx-dev

Files

Path
/usr/include/pqxx/basic_connection
/usr/include/pqxx/basic_connection.hxx
/usr/include/pqxx/binarystring
/usr/include/pqxx/binarystring.hxx
/usr/include/pqxx/compiler-internal-post.hxx
/usr/include/pqxx/compiler-internal-pre.hxx
/usr/include/pqxx/compiler-public.hxx
/usr/include/pqxx/config-public-compiler.h
/usr/include/pqxx/connection
/usr/include/pqxx/connection.hxx
/usr/include/pqxx/connection_base
/usr/include/pqxx/connection_base.hxx
/usr/include/pqxx/connectionpolicy
/usr/include/pqxx/connectionpolicy.hxx
/usr/include/pqxx/cursor
/usr/include/pqxx/cursor.hxx
/usr/include/pqxx/dbtransaction
/usr/include/pqxx/dbtransaction.hxx
/usr/include/pqxx/errorhandler
/usr/include/pqxx/errorhandler.hxx
/usr/include/pqxx/except
/usr/include/pqxx/except.hxx
/usr/include/pqxx/field
/usr/include/pqxx/field.hxx
/usr/include/pqxx/isolation
/usr/include/pqxx/isolation.hxx
/usr/include/pqxx/largeobject
/usr/include/pqxx/largeobject.hxx
/usr/include/pqxx/nontransaction
/usr/include/pqxx/nontransaction.hxx
/usr/include/pqxx/notification
/usr/include/pqxx/notification.hxx
/usr/include/pqxx/notify-listen
/usr/include/pqxx/notify-listen.hxx
/usr/include/pqxx/performance.hxx
/usr/include/pqxx/pipeline
/usr/include/pqxx/pipeline.hxx
/usr/include/pqxx/pqxx
/usr/include/pqxx/prepared_statement
/usr/include/pqxx/prepared_statement.hxx
/usr/include/pqxx/result
/usr/include/pqxx/result.hxx
/usr/include/pqxx/robusttransaction
/usr/include/pqxx/robusttransaction.hxx
/usr/include/pqxx/strconv
/usr/include/pqxx/strconv.hxx
/usr/include/pqxx/subtransaction
/usr/include/pqxx/subtransaction.hxx
/usr/include/pqxx/tablereader
/usr/include/pqxx/tablereader.hxx
/usr/include/pqxx/tablestream
/usr/include/pqxx/tablestream.hxx
/usr/include/pqxx/tablewriter
/usr/include/pqxx/tablewriter.hxx
/usr/include/pqxx/transaction
/usr/include/pqxx/transaction.hxx
/usr/include/pqxx/transaction_base
/usr/include/pqxx/transaction_base.hxx
/usr/include/pqxx/transactor
/usr/include/pqxx/transactor.hxx
/usr/include/pqxx/trigger
/usr/include/pqxx/trigger.hxx
/usr/include/pqxx/tuple
/usr/include/pqxx/tuple.hxx
/usr/include/pqxx/util
/usr/include/pqxx/util.hxx
/usr/include/pqxx/version
/usr/include/pqxx/version.hxx
/usr/include/pqxx/internal/callgate.hxx
/usr/include/pqxx/internal/libpq-forward.hxx
/usr/include/pqxx/internal/result_data.hxx
/usr/include/pqxx/internal/statement_parameters.hxx
/usr/include/pqxx/internal/gates/connection-dbtransaction.hxx
/usr/include/pqxx/internal/gates/connection-errorhandler.hxx
/usr/include/pqxx/internal/gates/connection-largeobject.hxx
/usr/include/pqxx/internal/gates/connection-notification_receiver.hxx
/usr/include/pqxx/internal/gates/connection-parameterized_invocation.hxx
/usr/include/pqxx/internal/gates/connection-pipeline.hxx
/usr/include/pqxx/internal/gates/connection-prepare-invocation.hxx
/usr/include/pqxx/internal/gates/connection-reactivation_avoidance_exemption.hxx
/usr/include/pqxx/internal/gates/connection-sql_cursor.hxx
/usr/include/pqxx/internal/gates/connection-transaction.hxx
/usr/include/pqxx/internal/gates/errorhandler-connection.hxx
/usr/include/pqxx/internal/gates/icursor_iterator-icursorstream.hxx
/usr/include/pqxx/internal/gates/icursorstream-icursor_iterator.hxx
/usr/include/pqxx/internal/gates/result-connection.hxx
/usr/include/pqxx/internal/gates/result-creation.hxx
/usr/include/pqxx/internal/gates/result-sql_cursor.hxx
/usr/include/pqxx/internal/gates/transaction-subtransaction.hxx
/usr/include/pqxx/internal/gates/transaction-tablereader.hxx
/usr/include/pqxx/internal/gates/transaction-tablewriter.hxx
/usr/include/pqxx/internal/gates/transaction-transactionfocus.hxx
/usr/lib/x86_64-linux-gnu/libpqxx.a
/usr/lib/x86_64-linux-gnu/libpqxx.la
/usr/lib/x86_64-linux-gnu/libpqxx.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libpqxx.pc
/usr/share/doc/libpqxx-dev/NEWS.gz
/usr/share/doc/libpqxx-dev/README-UPGRADE.gz
/usr/share/doc/libpqxx-dev/README.Debian
/usr/share/doc/libpqxx-dev/README.gz
/usr/share/doc/libpqxx-dev/changelog.Debian.gz
/usr/share/doc/libpqxx-dev/changelog.gz
/usr/share/doc/libpqxx-dev/copyright

Changelog

2014-01-19 - Marcin Kulisz (kuLa) <debian@kulisz.net>
libpqxx (4.0.1+dfsg-3) unstable; urgency=low
* Removing all minified js files, changing debian version into dfsg
(Closes: #729785)
* Adding missing credits in d/copyright
* Removing unsed d/libpqxx-doc.postinst
* Switching autotools-dev to dh-autoreconf (Closes: 735954), thx to Logan
Rosen for the patch
* Closing (LP: #370913)
* Added source.lintian-overrides
* Bumping up standars version to 3.9.5
2013-11-14 - Marcin Kulisz (kuLa) <debian@kulisz.net>
libpqxx (4.0.1-2) unstable; urgency=low
* Created dummy transition package for libpqxx3-dev
* Removing lintian overrides, not in use anymore
* Dropped the soversion from the -doc and -dbg package too.
2013-10-30 - Marcin Kulisz (kuLa) <debian@kulisz.net>
libpqxx (4.0.1-1) unstable; urgency=low
* New upstream
- Improvements for clang compilation
- Fixes for BSD compilation
- Compatibility for OS X
- Bug fixes
* Added python as a build dep for autogenerating configs (regarding upstream
changes)
* Added lintian override for symlink in libpqxx-4.0 package for libpqxx.so ->
libpqxx-4.0.so
* Fixing autotools bug (Closes: #727432)
* Added build dep on autotools-dev
* Fixed vcs urls
* Standards-version bump to 3.9.4
2012-06-14 - Marcin Kulisz (kuLa) <debian@kulisz.net>
libpqxx (4.0-2) unstable; urgency=low
* Upload to unstable
* Added README.source describing workflaw for working with this package
2012-05-10 - Marcin Kulisz (kuLa) <debian@kulisz.net>
libpqxx (4.0-1) experimental; urgency=low
[ Marcin Kulisz]
* New upstream, slightly changed API
* d/control:
- renaming packages to libpqxx-4.0 and libpqxx4 (changed ABI)
* removing useless quilt patches
* d/copyright bump to DEP5
* Closing (LP: 842873)
* Implementing propper URL for Copyright format 1.0 (DEP-5)
* Closing (Closes: #672021) as not applicable for v4.0
* Standards version bump to 3.9.3
[ Matthijs Möhlmann ]
* Debhelper level 9, adjust the control file.
* Fix the install files and update to multiarch.
2011-11-28 - Marcin Kulisz (kuLa) <debian@kulisz.net>
libpqxx3 (3.1-1) unstable; urgency=low
[ Marcin Kulisz ]
* Adopting package (Closes: #618703)
* d/rules total rewrite
* adding symbols file
* fixing all lintian issues
[ Matthijs Möhlmann ]
* New upstream version (Closes: #622728)
* Update copyright file and include BSD license.
* Switch to dpkg-source 3.0 (quilt) format
* Empty the dependency_lib line in the .la file. (Closes: #622480)
* Use debhelper 8
2011-05-03 - Eugene V. Lyubimkin <jackyf@debian.org>
libpqxx3 (3.0.2-2) unstable; urgency=low
* Orphaned the package.
* debian/control:
- Added quilt to Build-Depends.
- Bumped Standards-Version to 3.9.2, no changes needed.
* debian/rules:
- Use quilt.
* debian/patches:
- New patch 100-fix-g++4.6-compilation.patch (provided by
Matthias Klose <doko@ubuntu.com>). (Closes: #624876)
* debian/README.source:
- Added with standard instructions how to use quilt.
2009-09-28 - Eugene V. Lyubimkin <jackyf@debian.org>
libpqxx3 (3.0.2-1) unstable; urgency=low
* New upstream bugfix-only release.
* debian/control:
- Bumped Standards-Version to 3.8.3, no changes needed.
- Added {misc:Depends} to dependencies of binary packages.
- Updated my mail address.
* debian/libpqxx3-doc.install:
- Added test headers to allow compiling examples. (Closes: 539814)
2009-03-19 - Eugene V. Lyubimkin <jackyf.devel@gmail.com>
libpqxx3 (3.0.0-3) unstable; urgency=medium
* debian/control:
- Make libpqxx3-dev also replace the libpqxx-dev to easy upgrade path.
(Closes: #520171)
- Make libpqxx3-doc conflict with and replace libpqxx-doc. Fixes a RC bug,
so urgency is set to medium. (Closes: #520169)
- Binary package 'libpqxx-3.0-dbg' is now in 'debug' section.
- Removed duplicated 'Section' tag for 'libpqxx-3.0', as suggested by
lintian.
- Bump 'Standards-Version' to 3.8.1, no changes needed.

See Also

Package Description
libpqxx-doc_4.0.1+dfsg-3_all.deb C++ library to connect to PostgreSQL (documentation)
libpqxx3-dev_4.0.1+dfsg-3_all.deb Transitional dummy package for libpqxx-dev
libpracticalxml-java_1.1.17-1_all.deb practical XML handling routines
libpragmatic-perl_1.7-2_all.deb Adds pragmata to Exporter
libpreferencepanes-dev_1.2.0-2_amd64.deb GNUstep preferences library - development files
libpreferencepanes1_1.2.0-2_amd64.deb GNUstep preferences library - runtime library
libprefork-perl_1.04-2_all.deb Module loading for forking or non-forking processes in Perl
libprelude-dev_1.0.0-11.4_amd64.deb Security Information Management System [ Development files ]
libprelude-perl_1.0.0-11.4_amd64.deb Security Information Management System [ Base library ]
libprelude2_1.0.0-11.4_amd64.deb Security Information Management System [ Base library ]
libpreludedb-dev_1.0.0-2.3_amd64.deb Security Information Management System [ Development files ]
libpreludedb-perl_1.0.0-2.3_amd64.deb Security Information Management System [ Base library ]
libpreludedb0_1.0.0-2.3_amd64.deb Security Information Management System [ Base library ]
libpresage-data_0.9-1_all.deb intelligent predictive text entry platform (data files)
libpresage-dev_0.9-1_amd64.deb intelligent predictive text entry platform (development files)
Advertisement
Advertisement