libpolyclipping-dev_6.1.3a-2_amd64.deb


Advertisement

Description

libpolyclipping-dev - polygon clipping, polygon offsetting and polyline offsetting library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpolyclipping-dev
Package version 6.1.3a
Package release 2
Package architecture amd64
Package type deb
Installed size 62 B
Download size 8.00 KB
Official Mirror ftp.br.debian.org
The Clipper library performs polygon clipping, polygon offsetting and polyline
offsetting. All four boolean clipping operations are supported - intersection,
union, difference and exclusive-or. Also, there are no restrictions on the
types of polygons that can be clipped - they can have holes, be
self-intersecting, have coincident edges etc.
These are the files needed for compiling programs with libpolyclipping.

Alternatives

Package Version Architecture Repository
libpolyclipping-dev_6.1.3a-2_i386.deb 6.1.3a i386 Debian Main
libpolyclipping-dev - - -

Requires

Name Value
libpolyclipping16 = 6.1.3a-2

Download

Type URL
Binary Package libpolyclipping-dev_6.1.3a-2_amd64.deb
Source Package libpolyclipping

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpolyclipping-dev deb package:
    # sudo apt-get install libpolyclipping-dev

Files

Path
/usr/include/polyclipping/clipper.hpp
/usr/lib/libpolyclipping.so
/usr/share/doc/libpolyclipping-dev/changelog.Debian.gz
/usr/share/doc/libpolyclipping-dev/copyright
/usr/share/pkgconfig/polyclipping.pc

Changelog

2014-02-04 - Bas Wijnen <wijnen@debian.org>
libpolyclipping (6.1.3a-2) unstable; urgency=medium
* Actually change maintainer to 3-D printer team.
2014-01-24 - Bas Wijnen <wijnen@debian.org>
libpolyclipping (6.1.3a-1) unstable; urgency=medium
* New upstream release.
* Change maintainer to 3-D printer team, add myself as uploader.
* Updated standards version to 3.9.5.  (No changes needed.)
2013-11-09 - Bas Wijnen <wijnen@debian.org>
libpolyclipping (6.0.0-2) unstable; urgency=low
* Fix pkgconfig include path.
2013-11-09 - Bas Wijnen <wijnen@debian.org>
libpolyclipping (6.0.0-1) unstable; urgency=low
* Initial Release. (Closes: #728542)
* Add pkgconfig file.

See Also

Package Description
libpolyclipping16_6.1.3a-2_amd64.deb polygon clipping, polygon offsetting and polyline offsetting library
libpolyglot-maven-java-doc_0.8~tobrien+git20120905-3_all.deb modules to enable Maven usage in others JVM languages - docs
libpolyglot-maven-java_0.8~tobrien+git20120905-3_all.deb modules to enable Maven usage in others JVM languages
libpolylib64-8_5.22.5-3+dfsg_amd64.deb Polyhedral library - long int version
libpolylib64-dev_5.22.5-3+dfsg_amd64.deb Development files for the long int version of PolyLib
libpolyml-dev_5.2.1-1.1_amd64.deb development files for Poly/ML, a compiler for the Standard ML
libpolyml1_5.2.1-1.1_amd64.deb runtime files for Poly/ML, a compiler for the Standard ML
libpolyorb3-dev_2.11~20140418-3_amd64.deb Multiple-personality middleware for Ada (development)
libpolyorb4_2.11~20140418-3_amd64.deb Multiple-personality middleware for Ada
libpomegranate-clojure_0.2.0-1_all.deb dependency resolution and repository handling library for Clojure
libpomp-dev_1.1+dfsg-3_amd64.deb OpenMP Pragma And Region Instrumentor - development files
libpomp0_1.1+dfsg-3_amd64.deb OpenMP Pragma And Region Instrumentor - shared library
libpomp2-dev_1.0.7+dfsg-5_amd64.deb OpenMP Pragma And Region Instrumentor - development files
libpomp2-doc_1.0.7+dfsg-5_all.deb OpenMP Pragma And Region Instrumentor - documentation
libpoppler-cil-dev_0.0.3-2_all.deb PDF rendering library -- CLI development files
Advertisement
Advertisement