libpoe-api-peek-perl_2.2000-1_all.deb


Advertisement

Description

libpoe-api-peek-perl - module to peek into the internals of a running POE environment

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpoe-api-peek-perl
Package version 2.2000
Package release 1
Package architecture all
Package type deb
Installed size 79 B
Download size 16.77 KB
Official Mirror ftp.br.debian.org
POE::API::Peek extends the POE::Kernel interface to provide clean access to
Kernel internals in a cross-version compatible manner. Other calculated data
is also available.

Alternatives

Package Version Architecture Repository
libpoe-api-peek-perl_2.2000-1_all.deb 2.2000 all Debian Main
libpoe-api-peek-perl - - -

Requires

Name Value
libdevel-size-perl -
libpoe-perl >= 2:1.3110
perl -

Download

Type URL
Binary Package libpoe-api-peek-perl_2.2000-1_all.deb
Source Package libpoe-api-peek-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpoe-api-peek-perl deb package:
    # sudo apt-get install libpoe-api-peek-perl

Files

Path
/usr/share/doc/libpoe-api-peek-perl/changelog.Debian.gz
/usr/share/doc/libpoe-api-peek-perl/changelog.gz
/usr/share/doc/libpoe-api-peek-perl/copyright
/usr/share/man/man3/POE::API::Peek.3pm.gz
/usr/share/perl5/POE/API/Peek.pm

Changelog

2012-01-12 - gregor herrmann <gregoa@debian.org>
libpoe-api-peek-perl (2.2000-1) unstable; urgency=low
* New upstream release:
- Work around session_pid_count() not working in 1.350 of POE
Closes: #652777
* Update years of packaging and upstream copyright.
* Remove lintian override (there is an upstream changelog now).
2011-08-20 - Ansgar Burchardt <ansgar@debian.org>
libpoe-api-peek-perl (2.1900-1) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* New upstream release.
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
2011-05-30 - gregor herrmann <gregoa@debian.org>
libpoe-api-peek-perl (2.1700-1) unstable; urgency=low
* New upstream release (closes: #627285).
* debian/copyright: update years of upstream and packaging copyright.
* Bumpd (build) dependency on libpoe-perl.
* Set Standards-Version to 3.9.2 (no changes).
* Bump debhelper compatibility level to 8.
2010-10-05 - Nicholas Bamber <nicholas@periapt.co.uk>
libpoe-api-peek-perl (2.1600-1) unstable; urgency=low
[ Ryan Niebur ]
* Update jawnsy's email address
[ gregor herrmann ]
* debian/watch: adjust uversionmangle to newer uscan/PET.
[ Nicholas Bamber ]
* Added myself to Uploaders
* Upped standards to 3.9.1
* Upped dependency on POE to 2:1.2930 (Closes: #593014)
* New upstream release
* Added debian/source/format 
* Added override to record the non-existence of an upstream changelog
* Refreshed copyright
* debian/rules: replaced with tiny 3-line variant
* Removed empty patches directory
2009-05-01 - gregor herrmann <gregoa@debian.org>
libpoe-api-peek-perl (1.3400-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release.
[ gregor herrmann ]
* debian/control:
- switch Vcs-Browser field to ViewSVN
- add ${misc:Depends} to Depends: field
- set Standards-Version to 3.8.1 (no changes)
- add /me to Uploaders
- make short description a noun phrase
- add libtest-distribution-perl to Build-Depends-Indep, enables an 
additional test
* debian/copyright: update formatting, update years of copyright for inc/,
update list of copyright holders for debian/.
2008-11-01 - Jose Luis Rivas <ghostbar38@gmail.com>
libpoe-api-peek-perl (1.3200-1) unstable; urgency=low
[ Jose Luis Rivas ]
* New upstream release.
* debian/control:
+ Bumped to 3.8.0 Standards-Version (no changes needed).
+ debhelper is now >= 7
* debian/rules:
+ Updated to debhelper v7.
* debian/compat:
+ Upgraded to 7.
* Refreshed debian/copyright.
* Deleted CDBS from Build-Depends.
[ gregor herrmann ]
* debian/copyright:
- add Upstream-Name field
- add additional copyright holder
- add stand-alone License: stanzas
* debian/control:
- mention module name in long description
- make runtime dependency on libpoe-perl versioned, too
2008-05-19 - Martín Ferrari <tincho@debian.org>
libpoe-api-peek-perl (1.3000-1) unstable; urgency=low
* New upstream release.
* debian/watch: mangle upstream different length version numbers.
* debian/control:
- updated POE dependency to 1.0001; removed libtest-distribution-perl as
it's unused.
- updated my email address.
* debian/copyright: added new format headers and complete BSD disclaimer.
* debian/docs: removed; README is only an ASCII copy of the man page.

See Also

Package Description
libpoe-component-client-dns-perl_1.053-1_all.deb POE Component for performing asynchronous DNS queries
libpoe-component-client-http-perl_0.949-1_all.deb POE Component for running asynchronous HTTP transactions
libpoe-component-client-ident-perl_1.07-2_all.deb a POE component that provides non-blocking ident lookups
libpoe-component-client-keepalive-perl_0.2720-1_all.deb POE component that manages and keeps alive client connections
libpoe-component-client-mpd-perl_2.000-2_all.deb client library for MPD (Music Player Daemon)
libpoe-component-client-ping-perl_1.171-1_all.deb ICMP ping client component for POE
libpoe-component-dbiagent-perl_0.26-2_all.deb POE Component for running asynchronous DBI calls
libpoe-component-ikc-perl_0.2402-1_all.deb Perl module for POE Inter-Kernel Communication
libpoe-component-irc-perl_6.88+dfsg-1_all.deb POE Component for manipulating IRC sessions
libpoe-component-jabber-perl_3.00-2_all.deb pOE Component for communicating over Jabber
libpoe-component-jobqueue-perl_0.5700-1_all.deb POE component to manage queues and worker pools
libpoe-component-pcap-perl_0.04-2_all.deb POE Interface to Net::Pcap
libpoe-component-pool-thread-perl_0.015-1_all.deb POE Managed Boss/Worker thread pool
libpoe-component-pubsub-perl_0.05-1_all.deb generic publish/subscribe POE::Component
libpoe-component-resolver-perl_0.920-1_all.deb POE Component for domain name resolution
Advertisement
Advertisement