libpod-coverage-perl_0.23-1_all.deb


Advertisement

Description

libpod-coverage-perl - checker for comprehensiveness of perl module documentation

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpod-coverage-perl
Package version 0.23
Package release 1
Package architecture all
Package type deb
Installed size 83 B
Download size 23.32 KB
Official Mirror ftp.br.debian.org
POD::Coverage provides a mechanism for determining if the pod for a given
module is comprehensive. It checks on a function by function basis and is
useful for finding holes in module documentation.

Alternatives

Package Version Architecture Repository
libpod-coverage-perl_0.23-1_all.deb 0.23 all Debian Main
libpod-coverage-perl - - -

Requires

Name Value
libdevel-symdump-perl -
perl -

Download

Type URL
Binary Package libpod-coverage-perl_0.23-1_all.deb
Source Package libpod-coverage-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpod-coverage-perl deb package:
    # sudo apt-get install libpod-coverage-perl

Files

Path
/usr/share/doc/libpod-coverage-perl/changelog.Debian.gz
/usr/share/doc/libpod-coverage-perl/changelog.gz
/usr/share/doc/libpod-coverage-perl/copyright
/usr/share/doc/libpod-coverage-perl/examples/check_installed
/usr/share/doc/libpod-coverage-perl/examples/pod_cover
/usr/share/doc/libpod-coverage-perl/examples/script-covered
/usr/share/man/man3/Pod::Coverage.3pm.gz
/usr/share/man/man3/Pod::Coverage::CountParents.3pm.gz
/usr/share/man/man3/Pod::Coverage::ExportOnly.3pm.gz
/usr/share/man/man3/Pod::Coverage::Overloader.3pm.gz
/usr/share/perl5/Pod/Coverage.pm
/usr/share/perl5/Pod/Coverage/CountParents.pm
/usr/share/perl5/Pod/Coverage/ExportOnly.pm
/usr/share/perl5/Pod/Coverage/Overloader.pm

Changelog

2013-08-16 - Florian Schlichting <fsfs@debian.org>
libpod-coverage-perl (0.23-1) unstable; urgency=low
* Team upload
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 0.23.
* Bump Standards-Version to 3.9.4 (update to copyright-format 1.0).
2012-02-10 - Fabrizio Regalli <fabreg@fabreg.it>
libpod-coverage-perl (0.22-1) unstable; urgency=low
[ Ansgar Burchardt ]
* Email change: Ansgar Burchardt -> ansgar@debian.org
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ Fabrizio Regalli ]
* Imported Upstream version 0.22
* Bump Standards-Version to 3.9.2 (no changes needed)
* Update d/compat to 8
* Update debhelper version to (>= 8)
* Added myself to Uploaders and Copyright
* Update d/copyright using latest .174 revision
* Removed 'GNU/Linux' from license text in d/copyright
* Added missing Files: stanza at the beginning of d/copyright
* Removed no more necessary --buildsystem=perl_build from d/rules
2010-07-28 - Ansgar Burchardt <ansgar@43-1.org>
libpod-coverage-perl (0.21-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* New upstream release.
* Use tiny debian/rules and Build.PL.
* Use source format 3.0 (quilt).
* Make build-dep on perl unversioned.
* debian/copyright: Formatting change for current DEP-5 proposal.
* debian/copyright: Refer to /usr/share/common-licenses/GPL-1.
* Bump Standards-Version to 3.9.1.
* Add myself to Uploaders.
2009-02-20 - Antonio Radici <antonio@dyne.org>
libpod-coverage-perl (0.20-1) unstable; urgency=low
[ Antonio Radici ]
* debian/control:
+ added myself to the Uploaders
+ Standers-Version updated to 3.8.0
+ moved libmodule-build-perl to B-D-I
* debian/copyright:
+ switched to the new format
[ gregor herrmann ]
* debian/rules: remove /usr/bin only if it exists.
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
* debian/watch: extended regexp for matching upstream releases.
* Set debhelper compatibility level to 7; adapt
debian/{control,compat,rules}.
* debian/control: remove libmodule-build-perl, dh7 prefers
ExtUtils::MakeMaker.
* Add /me to Uploaders.
* debian/control: improve short and long description.

See Also

Package Description
libpod-coverage-trustpod-perl_0.100003-1_all.deb module to support hints for Pod::Coverage
libpod-elemental-perl_0.103001-1_all.deb module for manipulating POD elements
libpod-elemental-perlmunger-perl_0.200002-1_all.deb Perl module that rewrites Perl documentation
libpod-eventual-perl_0.094001-1_all.deb module to read a POD as a series of trivial events
libpod-index-perl_0.14-2_all.deb index and search PODs using X<> entries
libpod-latex-perl_0.61-1_all.deb module to convert Pod data to formatted LaTeX
libpod-markdown-perl_2.002000-1_all.deb module to convert POD to the Markdown file format
libpod-plainer-perl_1.04-1_all.deb Perl extension for converting Pod to old-style Pod
libpod-pom-perl_0.29-1_all.deb module providing a Pod Object Model
libpod-pseudopod-perl_0.18-1_all.deb framework for parsing PseudoPod
libpod-readme-perl_0.11-1_all.deb Perl module to convert POD to README file
libpod-sax-perl_0.14-5_all.deb Perl module for generating SAX events from POD
libpod-simple-perl_3.28-1_all.deb framework for parsing files in the Pod markup language
libpod-simple-wiki-perl_0.16-1_all.deb Perl class for creating Pod to Wiki filters
libpod-spell-perl_1.15-1_all.deb formatter to easily check the spelling of POD
Advertisement
Advertisement