libplack-middleware-file-sass-perl_0.03-4_all.deb


Advertisement

Description

libplack-middleware-file-sass-perl - Sass and SCSS support for all Plack-based PSGI frameworks

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libplack-middleware-file-sass-perl
Package version 0.03
Package release 4
Package architecture all
Package type deb
Installed size 18 B
Download size 11.97 KB
Official Mirror ftp.br.debian.org
PSGI is a specification to decouple web server environments from web
application framework code.  Plack is an implementation of PSGI.
Plack::Middleware::File::Sass is a Plack middleware component that
works with Plack::App::File or Plack::Middleware::Static to compile
Sass templates into CSS stylesheet in every request.
When a request comes in for *.css* file, this middleware changes the
internal path to *.sass* or *.scss*, depending on the configuration, in
the same directory. If the Sass template is found, a new CSS stylesheet
is built on memory and served to the browsers. Otherwise, it falls back
to the original *.css* file in the directory.
This middleware should be very handy for the development. While Sass to
CSS rendering is reasonably fast, for the production environment you
might want to precompile Sass templates to CSS files on disk and serves
them with a real web server like nginx or lighttpd.
Text::Sass provides only a limited Sass implementation, so the Ruby
implementation is recommended even when Text::Sass is available.

Alternatives

Package Version Architecture Repository
libplack-middleware-file-sass-perl_0.03-4_all.deb 0.03 all Debian Main
libplack-middleware-file-sass-perl - - -

Requires

Name Value
libhaml-ruby << 3.1
libplack-perl -
libtext-sass-perl -
perl -
ruby-sass -

Download

Type URL
Binary Package libplack-middleware-file-sass-perl_0.03-4_all.deb
Source Package libplack-middleware-file-sass-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libplack-middleware-file-sass-perl deb package:
    # sudo apt-get install libplack-middleware-file-sass-perl

Files

Path
/usr/share/doc/libplack-middleware-file-sass-perl/README
/usr/share/doc/libplack-middleware-file-sass-perl/buildinfo_all.gz
/usr/share/doc/libplack-middleware-file-sass-perl/changelog.Debian.gz
/usr/share/doc/libplack-middleware-file-sass-perl/changelog.gz
/usr/share/doc/libplack-middleware-file-sass-perl/copyright
/usr/share/man/man3/Plack::Middleware::File::Sass.3pm.gz
/usr/share/perl5/Plack/Middleware/File/Sass.pm

Changelog

2014-07-28 - Damyan Ivanov <dmn@debian.org>
libplack-middleware-file-sass-perl (0.03-4) unstable; urgency=low
* Team upload
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* debian/rules: move broken file from inc/ out of the way before tests.
(Closes: #753036)
[ Damyan Ivanov ]
* use canonical Vcs-* URLs
* use material (not symlinked) GPL-1 license pointer
2013-03-10 - Jonas Smedegaard <dr@jones.dk>
libplack-middleware-file-sass-perl (0.03-3) unstable; urgency=low
[ gregor herrmann ]
* Remove debian/source/local-options: abort-on-upstream-changes and
unapply-patches are default in dpkg-source since 1.16.1.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org).
[ Jonas Smedegaard ]
* Update package relations:
+ Fix favor ruby-sass over libhaml-ruby also for recommendation.
+ Relax to build-depend unversioned on cdbs, debhelper and
devscripts: Needed versions satisfied in stable, and oldstable no
longer supported.
* Update copyright file:
+ Fix use pseudo-comment and -license sections to obey silly
restrictions of copyright format 1.0.
+ Fix double-indent in Copyright fields as per Policy ยง5.6.13.
* Bump dephelper compatibility level to 8.
* Bump standards-version to 3.9.4.
2011-07-03 - Jonas Smedegaard <dr@jones.dk>
libplack-middleware-file-sass-perl (0.03-2) unstable; urgency=low
* Update copyright file:
+ Consistently quote licenses in License comments.
* Depend on ruby-sass favored over libhaml-ruby and libtext-sass-perl,
and limit fallback libhaml-ruby dependency to only older versions
providing Sass.
2011-05-22 - Jonas Smedegaard <dr@jones.dk>
libplack-middleware-file-sass-perl (0.03-1) unstable; urgency=low
* Initial packaging release.
Closes: bug#627584.

See Also

Package Description
libplack-middleware-fixmissingbodyinredirect-perl_0.11-1_all.deb Plack::Middleware which ensures redirect response have a body
libplack-middleware-methodoverride-perl_0.10-1_all.deb Plack::Middleware to override REST methods via POST
libplack-middleware-removeredundantbody-perl_0.05-1_all.deb Plack::Middleware which removes an unnecessary HTTP response body
libplack-middleware-reverseproxy-perl_0.15-1_all.deb module supporting apps to run as a reverse proxy backend
libplack-middleware-session-perl_0.25-1_all.deb Perl module for Plack middleware session management
libplack-middleware-status-perl_1.101150-1_all.deb Perl module for Plack middleware mapping URLs to status codes
libplack-middleware-test-stashwarnings-perl_0.08-1_all.deb module for testing plack application warnings
libplack-perl_1.0033-1_all.deb interface between web servers and Perl web applications
libplack-test-anyevent-perl_0.05-2_all.deb run Plack::Test on AnyEvent-based PSGI applications
libplack-test-externalserver-perl_0.01-1_all.deb module for running HTTP tests on external live servers
libplasma-geolocation-interface4_4.11.13-2_amd64.deb library for the Plasma geolocation
libplasma3_4.14.2-5+deb8u2_amd64.deb Plasma Library for the KDE Platform
libplasmaclock4abi4_4.11.13-2_amd64.deb library for Plasma clocks
libplasmagenericshell4_4.11.13-2_amd64.deb shared elements for all the plasma shells
libplayer-bin_2.0.1-2.4_amd64.deb test utilities for libplayer
Advertisement
Advertisement