libpipeline1_1.4.0-1_amd64.deb


Advertisement

Description

libpipeline1 - pipeline manipulation library

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libpipeline1
Package version: 1.4.0
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 63 B
Download size: 27.25 KB
Official Mirror: ftp.br.debian.org
This is a C library for setting up and running pipelines of processes, without needing to involve shell command-line parsing which is often error-prone and insecure.

Alternatives

    Download

    Source package: libpipeline

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpipeline1 deb package:
      # sudo apt-get install libpipeline1

    Files

    • /usr/lib/x86_64-linux-gnu/libpipeline.so.1
    • /usr/lib/x86_64-linux-gnu/libpipeline.so.1.4.0
    • /usr/share/doc/libpipeline1/changelog.Debian.gz
    • /usr/share/doc/libpipeline1/changelog.gz
    • /usr/share/doc/libpipeline1/copyright

    Changelog

    2014-10-26 - Colin Watson <cjwatson@debian.org> libpipeline (1.4.0-1) unstable; urgency=medium * New upstream release. * Policy version 3.9.6: no changes required.

    2014-09-22 - Colin Watson <cjwatson@debian.org> libpipeline (1.3.1-1) unstable; urgency=medium * New upstream release. * Update Vcs-Browser URL for alioth cgit.

    2014-03-26 - Colin Watson <cjwatson@debian.org> libpipeline (1.3.0-1) unstable; urgency=medium * New upstream release.

    2014-02-08 - Colin Watson <cjwatson@debian.org> libpipeline (1.2.6-2) unstable; urgency=medium * Policy version 3.9.5: no changes required. * Set VERBOSE=1 when running tests so that Automake will print test logs on failure. * Move upstream signing key to debian/upstream/signing-key.asc (armoured). Requires devscripts 2.14.0.

    2013-12-18 - Colin Watson <cjwatson@debian.org> libpipeline (1.2.6-1) unstable; urgency=low * New upstream release. * Add OpenPGP signature checking configuration to watch file.

    2013-12-03 - Colin Watson <cjwatson@debian.org> libpipeline (1.2.5-1) unstable; urgency=low * New upstream release. - Restore compatibility with Automake 1.10 (closes: #730191). * Switch to git; adjust Vcs-* fields.

    2013-06-06 - Colin Watson <cjwatson@debian.org> libpipeline (1.2.4-1) unstable; urgency=low * New upstream release.

    2013-06-04 - Colin Watson <cjwatson@debian.org> libpipeline (1.2.3-2) unstable; urgency=low * Build-depend on debhelper (>= 9~) directly rather than requiring a Lintian override for use of 8.9.0. * Explicitly build-depend on automake (>= 1:1.10). * Add a Vcs-Browser field. * Policy version 3.9.4: no changes required.

    2013-04-24 - Colin Watson <cjwatson@debian.org> libpipeline (1.2.3-1) unstable; urgency=low * New upstream release.

    2013-03-22 - Colin Watson <cjwatson@debian.org> libpipeline (1.2.2-2) unstable; urgency=low [ Colin Watson ] * Use dh-autoreconf. * Support parallel builds. [ Vibhav Pant ] * Add simple autopkgtest.

    Advertisement
    Advertisement