libphysfs1_2.0.3-2_amd64.deb


Advertisement

Description

libphysfs1 - filesystem abstraction library for game programmers

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libphysfs1
Package version 2.0.3
Package release 2
Package architecture amd64
Package type deb
Installed size 188 B
Download size 52.18 KB
Official Mirror ftp.br.debian.org
The PhysicsFS filesystem abstraction library provides a simple C
interface to aid game programmers in utilizing game assets packaged in
many different types of archive files.

Alternatives

Package Version Architecture Repository
libphysfs1_2.0.3-2_i386.deb 2.0.3 i386 Debian Main
libphysfs1 - - -

Requires

Name Value
dpkg >= 1.15.6~
libc6 >= 2.4
multiarch-support -
zlib1g >= 1:1.1.4

Provides

Name Value
libphysfs-1.0-0 -

Conflicts

Name Value
libphysfs-1.0-0 -

Replaces

Name Value
libphysfs-1.0-0 -

Download

Type URL
Binary Package libphysfs1_2.0.3-2_amd64.deb
Source Package libphysfs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libphysfs1 deb package:
    # sudo apt-get install libphysfs1

Files

Path
/usr/lib/x86_64-linux-gnu/libphysfs.so.1
/usr/lib/x86_64-linux-gnu/libphysfs.so.2.0.3
/usr/share/doc/libphysfs1/changelog.Debian.gz
/usr/share/doc/libphysfs1/changelog.gz
/usr/share/doc/libphysfs1/copyright
/usr/share/lintian/overrides/libphysfs1

Changelog

2013-05-06 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.3-2) unstable; urgency=low
* Adopt debian/watch from Bart Martens.
* Uploading to unstable.
* Migrate package to minimal debhelper.
* Remove unused lintian overrides.
* Adjust Vcs-Browser debian/control field.
2012-11-12 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.3-1) experimental; urgency=low
* New upstream release.
Closes: #691867
- Remove merged patch remove_unused_variable.
- Rename patch do_not_link_against_curses to 01-do-not-link-against-curses
and also rewrite it.
* Bump Standards-Version to 3.9.4 (no changes needed).
* Switch to xz compression and add a Pre-Depends on dpkg.
* Update debian/watch: Releases are now bzip2 compressed.
* Remove old libphysfs-1.0.so.0 compatibility symlink.
* Use wildcards in lintian overrides.
* Overwrite duplicate-files and no-symbols-control-file lintian warnings.
2012-07-12 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.2-7) unstable; urgency=low
* Wrap all debian/control fields.
* Add multiarch support.
Closes: #680607
* Add lintian overrides for false positive hardening-no-fortify-functions
warnings.
* Drop unused debian/libphysfs1.symbols file.
2012-02-24 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.2-6) unstable; urgency=low
* Bump Standards-Version to 3.9.3 (no changes needed).
2011-11-05 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.2-5) unstable; urgency=high
* Do not remove the .pc directory in the clean target.
Closes: #647492
* Apply patch from Sven Joachim, to not unnecessarily link against ncurses.
Closes: #646146
* Wrap all control fields.
* Add missing patch description to remove_unused_variable.diff.
* Add missing build-arch and build-indep target.
2011-07-19 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
libphysfs (2.0.2-4) unstable; urgency=low
* Team upload.
* Drop an unsued variable from archivers/wad.c that caused an FTBFS by
remove_unused_variable.diff. (Closes: #634415)
2011-05-04 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.2-3) unstable; urgency=low
* Rebuild package. It looks like the building hardware was just damaged.
Closes: #624800
2011-04-30 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.2-2) unstable; urgency=low
* Bump Standards-Version to 3.9.2 (no changes needed).
* Wrap build dependencies.
* Build with enabled hardening-wrapper.
2011-02-19 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.2-1) unstable; urgency=low
* New upstream release.
- Remove merged 01-fix-gcc4.4-building patch.
* Bump Standards-Version to 3.9.1.
2010-07-11 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.1-2) unstable; urgency=low
* Fix link from libphysfs-1.0.so.0 to libphysfs.so.2.0.1.
Closes: #586248
* Bump Standards-Version to 3.9.0 (no changes needed).

See Also

Package Description
libpiano-dev_2014.06.08-1+b1_amd64.deb library to interface with Pandora radio -- development
libpiano0_2014.06.08-1+b1_amd64.deb library to interface with Pandora radio -- runtime files
libpiccolo-java_1.2-1_all.deb toolkit for development of 2D structured graphics
libpigment0.3-11_0.3.17-1_amd64.deb User interfaces with embedded multimedia - shared library
libpigment0.3-dev_0.3.17-1_amd64.deb User interfaces with embedded multimedia - development files
libpils2-dev_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster development files -- libpils2
libpils2_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster libraries -- libpils2
libpimcommon4_4.14.1-1+deb8u1_amd64.deb library for common bits of KDEPIM
libpinyin-utils_1.0.0+repack2-1_amd64.deb library to deal with PinYin - utilities
libpinyin4-dev_1.0.0+repack2-1_amd64.deb library to deal with PinYin - development files
libpinyin4_1.0.0+repack2-1_amd64.deb library to deal with PinYin
libpion-5.0_5.0.5+dfsg-1+b1_amd64.deb lightweight HTTP interface library - runtime files
libpion-dev_5.0.5+dfsg-1+b1_amd64.deb lightweight HTTP interface library - development files
libpion-doc_5.0.5+dfsg-1_all.deb lightweight HTTP interface library - documentation
libpion-plugins_5.0.5+dfsg-1+b1_amd64.deb lightweight HTTP interface library - plugins
Advertisement
Advertisement