libphone-ui-shr_0.1+git20130901-3_amd64.deb


Advertisement

Description

libphone-ui-shr - SHR library for user interface, EFL backend

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libphone-ui-shr
Package version 0.1+git20130901
Package release 3
Package architecture amd64
Package type deb
Installed size 216 B
Download size 59.37 KB
Official Mirror ftp.br.debian.org
This package provides the EFL phone UI from the SHR project.
It is a backend for libphone-ui.

Alternatives

Package Version Architecture Repository
libphone-ui-shr_0.1+git20130901-3_i386.deb 0.1+git20130901 i386 Debian Main
libphone-ui-shr - - -

Requires

Name Value
libc6 >= 2.4
libecore-evas1 >= 1.7.7
libecore-file1 >= 1.7.7
libecore-x1 >= 1.7.7
libecore1 >= 1.7.7
libedje1 >= 1.7.4
libelementary2 >= 1.8.4
libevas1 >= 1.7.7
libfso-glib2 >= 2012.07.27.2
libglib2.0-0 >= 2.30
libphone-ui-20110825 >= 1:0.0.1+git20110825
libphone-utils0 >= 0.1+git20091114
multiarch-support -

Provides

Name Value
libphone-ui-backend -

Download

Type URL
Binary Package libphone-ui-shr_0.1+git20130901-3_amd64.deb
Source Package libphone-ui-shr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libphone-ui-shr deb package:
    # sudo apt-get install libphone-ui-shr

Files

Path
/usr/lib/x86_64-linux-gnu/phoneui/modules/shr.so
/usr/share/doc/libphone-ui-shr/TODO
/usr/share/doc/libphone-ui-shr/changelog.Debian.gz
/usr/share/doc/libphone-ui-shr/copyright

Changelog

2014-05-30 - Sebastian Reichel <sre@debian.org>
libphone-ui-shr (0.1+git20130901-3) unstable; urgency=medium
[ Cyril Brulebois ]
* add patch to deal with libelementary2 API incompatible change:
replace elm_notify_orient_set() with elm_notify_align_set().
+ libelementary2.patch (Closes: #747760)
[ Sebastian Reichel ]
* update Debian Standards Version to 3.9.5
* bump elementary build dependency to 1.8 (elm_notify_align_set)
2013-10-30 - Sebastian Reichel <sre@debian.org>
libphone-ui-shr (0.1+git20130901-2) unstable; urgency=low
* upload to unstable
2013-09-08 - Sebastian Reichel <sre@debian.org>
libphone-ui-shr (0.1+git20130901-1) experimental; urgency=low
* new upstream snapshot (Closes: #707439)
* update debian copyright format to Debian Copyright Format 1.0
* remove deprecated DM-Upload-Allowed: yes
* update Debian Standards Version to 3.9.4
* build with --as-needed
* use canonical vcs fields
* new patch to link against libecore-x
2012-04-28 - Sebastian Reichel <sre@debian.org>
libphone-ui-shr (0.1+git20110827-3) unstable; urgency=low
* move translations and default.edj into libphone-ui-shr-data
(Closes: 670021)
* update debian standards version
2011-12-15 - Sebastian Reichel <sre@debian.org>
libphone-ui-shr (0.1+git20110827-2) unstable; urgency=low
* Upload to unstable
2011-12-14 - Sebastian Reichel <sre@debian.org>
libphone-ui-shr (0.1+git20110827-1) experimental; urgency=low
[ Sebastian Reichel ]
* use dh-autoreconf
* update my mail address
* use DEP5 style for copyright file
* update copyright information
[ Rico Rommel ]
* new upstream snapshot (Closes: #634419)
* use debhelper
* add multi-arch support
* unapply upstream changes due to api-change, because
Debian uses an old elementary snapshot
* add Rico Rommel <rico@bierrommel.de> to uploaders
2010-07-26 - Sebastian Reichel <elektranox@gmail.com>
libphone-ui-shr (0.1+git20100726-1) unstable; urgency=low
* New git checkout
+ use new sound API from libphone-ui
+ provide new log view
+ add sim-manager
+ prepare for fsogsmd
+ reworked UI
* Drop all patches, not needed anymore, since enlightenment
got updated in Debian
* Update Debian Standards Version to 3.9.1.0
* First upload to Debian main (Closes: #590457)
2010-03-02 - Sebastian Reichel <elektranox@gmail.com>
libphone-ui-shr (0.1+git20100302-1) pkg-fso; urgency=low
* New git checkout
+ quick settings
+ resizable idle screen
+ miscellaneous improvements
* Switch to DebSrc 3.0
* Add patch to disable a elm_layout_sizing_eval call because
this function is not yet in the elementary package of
Debian. This may break quick-settings-view.
2010-02-14 - Sebastian Reichel <elektranox@gmail.com>
libphone-ui-shr (0.1+git20100213-1) pkg-fso; urgency=low
* New git checkout
+ remove the "tel:" prefix
+ UI improvements
* Update Debian Standards Version to 3.8.4
2010-01-20 - Sebastian Reichel <elektranox@gmail.com>
libphone-ui-shr (0.1+git20100109-3) pkg-fso; urgency=low
* add patch:  check for nullpointers in edit contacts function

See Also

Package Description
libphone-utils-dev_0.1+git20110523-2.1_amd64.deb library for basic phone operations - development files
libphone-utils0_0.1+git20110523-2.1_amd64.deb library for basic phone operations
libphonenumber6-dev_6.3~svn698-3+b1_amd64.deb parsing/formatting/validating phone numbers - development files
libphonenumber6-java_6.3~svn698-3_all.deb parsing/formatting/validating phone numbers - java
libphonenumber6_6.3~svn698-3+b1_amd64.deb parsing/formatting/validating phone numbers
libphonon-dev_4.8.0-4_amd64.deb multimedia framework from KDE using Qt 4 - development files
libphonon4_4.8.0-4_amd64.deb multimedia framework from KDE - core library
libphonon4qt5-4_4.8.0-4_amd64.deb multimedia framework from KDE using Qt 5 - core library
libphonon4qt5-dev_4.8.0-4_amd64.deb multimedia framework from KDE using Qt 5 - development files
libphonon4qt5experimental-dev_4.8.0-4_amd64.deb multimedia framework from KDE using Qt 5 - experimental development files
libphonon4qt5experimental4_4.8.0-4_amd64.deb multimedia framework from KDE using Qt 5 - experimental library (internal)
libphononexperimental-dev_4.8.0-4_amd64.deb multimedia framework from KDE - experimental development files
libphononexperimental4_4.8.0-4_amd64.deb multimedia framework from KDE using Qt 4 - experimental library (internal)
libphotos202-1-gfortran_20061220+dfsg3-3_amd64.deb [Physics] Monte Carlo simulation of photon radiation in decays
libphotos202-dev_20061220+dfsg3-3_amd64.deb [Physics] Monte Carlo simulation of photon radiation in decays
Advertisement
Advertisement