libpgobject-perl_1.402.6-1_all.deb


Advertisement

Description

libpgobject-perl - base class for PG Object subclasses

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpgobject-perl
Package version 1.402.6
Package release 1
Package architecture all
Package type deb
Installed size 69 B
Download size 18.79 KB
Official Mirror ftp.br.debian.org
PGObject contains the base routines for object management using discoverable
stored procedures in PostgreSQL databases. PGObject contains only common
functionality and support structures, and low-level API's. Most developers
will want to use more functional modules which add to these functions.
The overall approach here is to provide the basics for a toolkit that other
modules can extend. This is thus intended to be a component for building
integration between PostgreSQL user defined functions and Perl objects.
Because decisions such as state handling are largely outside of the scope of
this module, this module itself does not do any significant state handling.
Database handles (using DBD::Pg 2.0 or later) must be passed in on every
call. This decision was made in order to allow for diversity in this area,
with the idea that wrapper classes would be written to implement this.

Alternatives

Package Version Architecture Repository
libpgobject-perl_1.402.6-1_all.deb 1.402.6 all Debian Main
libpgobject-perl - - -

Requires

Name Value
libdbd-pg-perl -
perl -

Download

Type URL
Binary Package libpgobject-perl_1.402.6-1_all.deb
Source Package libpgobject-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpgobject-perl deb package:
    # sudo apt-get install libpgobject-perl

Files

Path
/usr/share/doc/libpgobject-perl/changelog.Debian.gz
/usr/share/doc/libpgobject-perl/changelog.gz
/usr/share/doc/libpgobject-perl/copyright
/usr/share/man/man3/PGObject.3pm.gz
/usr/share/perl5/PGObject.pm

Changelog

2014-10-15 - Robert James Clay <jame@rocasa.us>
libpgobject-perl (1.402.6-1) unstable; urgency=medium
* New upstream release.
[ Robert James Clay ]
* Change debhelper requirement from '8' to '9'.
* Update the debian/* Files stanza in debian/copyright.
* Set Testsuite to 'autopkgtest-pkg-perl' in debian/control.
* Declare compliance with Debian Policy v3.9.6, no changes required.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
2014-04-14 - Robert James Clay <jame@rocasa.us>
libpgobject-perl (1.400.1-1) unstable; urgency=low
* Initial Release. (Closes: #712407)

See Also

Package Description
libpgobject-simple-perl_1.8-1_all.deb minimalist stored procedure mapper based on LedgerSMB's DBObject
libpgobject-simple-role-perl_1.11.0-1_all.deb Moo/Moose mappers for minimalist PGObject framework
libpgobject-util-dbmethod-perl_1.00.001-1_all.deb object mappings for the PGObject Framework
libpgocaml-ocaml-dev_2.1-1_amd64.deb OCaml type-safe bindings for PostgreSQL (development)
libpgocaml-ocaml_2.1-1_amd64.deb OCaml type-safe bindings for PostgreSQL (runtime)
libpgp-sign-perl_0.20-3_all.deb Perl module to create detached PGP signatures
libpgpool-dev_3.3.4-1_amd64.deb pgpool control protocol library - headers
libpgpool0_3.3.4-1_amd64.deb pgpool control protocol library
libpgraphutil-smlnj_110.76-2_amd64.deb Portable graph utility library for SML Compilation Manager
libpgtcl-dev_1.9+git20120911-3_amd64.deb Tcl client library binding for PostgreSQL - development files
libpgtcl_1.9+git20120911-3_amd64.deb Tcl client library binding for PostgreSQL
libpgtypes3_9.4.15-0+deb8u1_amd64.deb shared library libpgtypes for PostgreSQL 9.4
libphobos-4.8-dev_4.8.4-1_amd64.deb Phobos D standard library
libphobos-4.9-dev_4.9.2-10_amd64.deb Phobos D standard library
libphobos-dev_4.9.2-2_amd64.deb Phobos D standard library
Advertisement
Advertisement