libpg-perl - Perl modules for PostgreSQL

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libpg-perl
Package version: 2.1.1
Package release: 5+b1
Package architecture: amd64
Package type: deb
Installed size: 101 B
Download size: 38.58 KB
Official Mirror:
This library enables Perl scripts to communicate with the PostgreSQL database backend. Perl is a widely used scripting language, which is always installed in Debian systems.



    Source package: libpg-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpg-perl deb package:
      # sudo apt-get install libpg-perl


    • /usr/lib/x86_64-linux-gnu/perl5/5.20/
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Pg/
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Pg/autosplit.ix
    • /usr/share/doc/libpg-perl/changelog.Debian.amd64.gz
    • /usr/share/doc/libpg-perl/changelog.Debian.gz
    • /usr/share/doc/libpg-perl/changelog.gz
    • /usr/share/doc/libpg-perl/copyright
    • /usr/share/doc/libpg-perl/examples/
    • /usr/share/doc/libpg-perl/examples/example.newstyle.gz
    • /usr/share/doc/libpg-perl/examples/example.oldstyle.gz
    • /usr/share/man/man3/Pg.3pm.gz


    2014-07-29 - Martin Pitt <> libpg-perl (1:2.1.1-5) unstable; urgency=medium * Import packaging into git-buildpackage, add Vcs-* tags. * Set Maintainer to pkg-postgresql team. (Closes: #572670) * Drop long-obsolete Conflicts/Replaces. * Move to debhelper compat 9 and dh. This vastly simplifies debian/rules and avoids hardcoded Perl paths. (Closes: #752711) * Add missing ${misc:Depends}. * Move to 3.0 (quilt) source format. * Add autopkgtest. * Add test_table_with_oids.patch: Create table with OIDs in test, as OIDs are not created by default any more. * Add test_fix_endcopy.patch: Fix $conn->endcopy test. * Move to copyright format 1.0. * Bump Standards-Version to 3.9.5.

    2008-05-07 - Martin Pitt <> libpg-perl (1:2.1.1-4) unstable; urgency=high * Urgency high since this fixes a grave bug. * debian/rules: Robustify installation, to create /usr/share/perl5/ if it does not exist yet. The new perl apparently changed the behaviour of pure_vendor_install. (Closes: #479382) * debian/copyright: Update FSF address and upstream URL. * Remove debian/watch, libpg-perl cannot currently be downloaded from pgfoundry. Investigation is in progress. (see #453541) * Bump Standards-Version to 3.7.2 and debhelper compat to 5.

    2006-10-29 - Martin Pitt <> libpg-perl (1:2.1.1-3) unstable; urgency=low * Fix stray '=' in POD synopsis. Closes: #395392 * Add watch file.

    2005-06-22 - Martin Pitt <> libpg-perl (1:2.1.1-2) unstable; urgency=low * debian/rules: - Remove the install variables workaround again, it is not necessary any more with the fixed Perl. - Install upstream changelog.

    2005-06-08 - Martin Pitt <> libpg-perl (1:2.1.1-1) unstable; urgency=low * New upstream version. * Transition to new PostgreSQL architecture. * debian/control: - Changed build dependency postgresql-dev to libpq-dev. - Do not build the libpgperl transition package any more. * debian/rules: - Use pg_config to determine include and library directories. - Tweak internal variables of the generated Makefile to fix broken default values of the new Perl's MakeMaker.

    2004-10-18 - Martin Pitt <> libpg-perl (1:2.0.2-4) unstable; urgency=low * Fixed typo in generated manpage, thanks to Julian Gilbey for spotting this (closes: #275783)

    2004-02-07 - Martin Pitt <> libpg-perl (1:2.0.2-3) unstable; urgency=low * Conflicts to and Replaces old libpgperl (i. e. << 1:2.0.2-1) to make upgrading work in all cases (closes: #231490)

    2004-02-06 - Martin Pitt <> libpg-perl (1:2.0.2-2) unstable; urgency=low * renamed source package: an unrelated package pgperl already existed which was overwritten by the last upload

    2004-01-16 - Martin Pitt <> pgperl (1:2.0.2-1) unstable; urgency=low * Separated source tree out of postgresql; thus a new epoch had to be created, postgresql is already at 7.4.1 * Added examples * don't ship any more, this library has now moved to the core postgresql package * renamed package libpgperl to libpg-perl to comply with the Perl policy (closes: #47821); offer an empty transition package libpgperl