libpetal-perl_2.23-1_all.deb


Advertisement

Description

libpetal-perl - Perl Template Attribute Language - TAL for perl

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpetal-perl
Package version 2.23
Package release 1
Package architecture all
Package type deb
Installed size 251 B
Download size 78.02 KB
Official Mirror ftp.br.debian.org
Petal is an XML based templating engine that is able to process any kind of
XML, XHTML and HTML.
Petal borrows a lot of good ideas from the Zope Page Templates TAL
specification, it is very well suited for the creation of WYSIWYG XHTML
editable templates.

Alternatives

Package Version Architecture Repository
libpetal-perl_2.23-1_all.deb 2.23 all Debian Main
libpetal-perl - - -

Requires

Name Value
libmkdoc-xml-perl -
perl -

Download

Type URL
Binary Package libpetal-perl_2.23-1_all.deb
Source Package libpetal-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpetal-perl deb package:
    # sudo apt-get install libpetal-perl

Files

Path
/usr/share/doc/libpetal-perl/changelog.Debian.gz
/usr/share/doc/libpetal-perl/changelog.gz
/usr/share/doc/libpetal-perl/copyright
/usr/share/man/man3/Petal.3pm.gz
/usr/share/man/man3/Petal::Cookbook.3pm.gz
/usr/share/man/man3/Petal::Deprecated.3pm.gz
/usr/share/man/man3/Petal::Hash::Test.3pm.gz
/usr/share/man/man3/Petal::I18N.3pm.gz
/usr/share/perl5/Petal.pm
/usr/share/perl5/Petal/CodeGenerator.pm
/usr/share/perl5/Petal/Cookbook.pod
/usr/share/perl5/Petal/Deprecated.pod
/usr/share/perl5/Petal/Entities.pm
/usr/share/perl5/Petal/Functions.pm
/usr/share/perl5/Petal/Hash.pm
/usr/share/perl5/Petal/I18N.pm
/usr/share/perl5/Petal/Parser.pm
/usr/share/perl5/Petal/Cache/Disk.pm
/usr/share/perl5/Petal/Cache/Memory.pm
/usr/share/perl5/Petal/Canonicalizer/XHTML.pm
/usr/share/perl5/Petal/Canonicalizer/XML.pm
/usr/share/perl5/Petal/Hash/String.pm
/usr/share/perl5/Petal/Hash/Test.pm
/usr/share/perl5/Petal/Hash/Var.pm
/usr/share/perl5/Petal/TranslationService/Gettext.pm
/usr/share/perl5/Petal/TranslationService/MOFile.pm
/usr/share/perl5/Petal/TranslationService/Noop.pm
/usr/share/perl5/Petal/TranslationService/h4x0r.pm

Changelog

2013-09-25 - Nuno Carvalho <smash@cpan.org>
libpetal-perl (2.23-1) unstable; urgency=low
* Team upload.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Nuno Carvalho ]
* New upstream release.
* d/control: update standards version.
* Remove patch to fix spelling errors, fixed upstream.
* d/copyright: update file content to current format.
2011-08-29 - Damyan Ivanov <dmn@debian.org>
libpetal-perl (2.20-1) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* New upstream release.
* Remove no-Safe.patch and no-UNIVERSAL-import.patch, applied upstream.
2011-08-14 - Damyan Ivanov <dmn@debian.org>
libpetal-perl (2.19-2) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* debian/control: Added: ${misc:Depends} to Depends: field.
* Remove Florian Ragwitz from Uploaders (closes: #523195).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Damyan Ivanov ]
* Use source format '3.0 (quilt)'
* Import a patch from Stefan Seifert (nine_AT_detonation_DOT_org) replacing
UNIVERSAL usage. Closes: #614870 -- UNIVERSAL->import is getting
deprecated with Perl 5.12.0
* add liblocale-maketext-gettext-perl to B-D-I, enabling additional test
* add no-Safe.patch, removing usage of Safe.pm in taint mode. This has the
potential to break other code, but that code should be broken already by
the new Safe. Closes: #582805 -- breaks with new Safe
* use tiny debhelper rules and compatibility level 8
* remove unused lintian override about an unbreakable line in the manual
* claim conformance with POlicy 3.9.2
* add spelling-errors.patch fixing two spelling errors in Petal manual
2008-06-16 - gregor herrmann <gregoa@debian.org>
libpetal-perl (2.19-1) unstable; urgency=low
* Take over for the Debian Perl Group with maintainer's permission
(http://lists.debian.org/debian-perl/2008/06/msg00039.html)
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Changed:
Maintainer set to Debian Perl Group <pkg-perl-
maintainers@lists.alioth.debian.org> (was: Florian Ragwitz
<rafl@debian.org>); Florian Ragwitz <rafl@debian.org> moved to
Uploaders.
* Add debian/watch.
* New upstream release (closes: #445640).
* Set debhelper compatibility level to 5.
* Set Standards-Version to 3.8.0 (no changes).
* Add /me to Uploaders.
* debian/copyright: point to author-independent upstream source location.
* Refresh debian/rules, no functional changes.
* Remove -1 Debian revision from (build) dependencies.
* Add liburi-perl to Build-Depends-Indep to enable an additional test.
* Add a lintian override for a long line in a manpage that is caused by a
long URL.
2008-04-05 - Mark Hymers <mhy@debian.org>
libpetal-perl (2.18-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix FTBFS with Perl 5.10.  Closes: #468001 
2006-01-28 - Florian Ragwitz <rafl@debian.org>
libpetal-perl (2.18-1) unstable; urgency=low
* New upstream release.
2005-10-31 - Florian Ragwitz <rafl@debian.org>
libpetal-perl (2.17-1) unstable; urgency=low
* New upstream version.
* Updated Maintainer address.
2005-08-16 - Florian Ragwitz <rafl@debianforum.de>
libpetal-perl (2.16-1) unstable; urgency=low
* New upstream version.
* New Maintainer (Closes: #307073).
* Updated Standards-Version.
* Moved debhelper dependency to build-depends because it's needed for the
clean target.
* Added right bug number to changelog entry of version 2.05-1.

See Also

Package Description
libpetal-utils-perl_0.06-2_all.deb Useful template modifiers for Petal
libpetsc3.4.2-dev_3.4.2.dfsg1-8.1+b1_amd64.deb Static libraries, shared links, header files for PETSc
libpetsc3.4.2_3.4.2.dfsg1-8.1+b1_amd64.deb Shared libraries for version 3.4.2 of PETSc
libpff-dev_20120802-2_amd64.deb library to access various ms outlook files formats (development)
libpff1_20120802-2_amd64.deb library to access various ms outlook files formats
libpfm4-dev_4.5.0+git38-g1ca1338-2_amd64.deb Development files for the libpfm4 library
libpfm4_4.5.0+git38-g1ca1338-2_amd64.deb Library to program the performance monitoring events
libpfqueue-dev_0.5.6-9_amd64.deb interactive console-based tool to control MTA queues (development)
libpfqueue0_0.5.6-9_amd64.deb interactive console-based tool to control MTA queues (library)
libpfs-1.2-0_1.8.5-2+b1_amd64.deb C++ library to read and write pfs files
libpfs-dev_1.8.5-2+b1_amd64.deb C++ library to read and write pfs files (development files)
libpg-hstore-perl_1.04-1+b1_amd64.deb Perl module for working with PostgreSQLs HSTORE data type
libpg-java_9.2-1002-1_all.deb Transitional package for libpostgresql-jdbc-java
libpg-perl_2.1.1-5+b1_amd64.deb Perl modules for PostgreSQL
libpgapack-mpi1_1.1.1-3_amd64.deb General-purpose genetic algorithm package (mpi library)
Advertisement
Advertisement