libperlmenu-perl_4.0-5_all.deb


Advertisement

Description

libperlmenu-perl - Menu and Template (curses-based) UI for Perl

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libperlmenu-perl
Package version 4.0
Package release 5
Package architecture all
Package type deb
Installed size 220 B
Download size 82.32 KB
Official Mirror ftp.br.debian.org
perlmenu is a Perl module that provides your application
with access to easy-to-use functions for templates,
menus, forms, and the like -- everything needed
to put a slick UI on a program without resorting to
a GUI.
Homepage: http://search.cpan.org/~skunz/perlmenu/

Alternatives

Package Version Architecture Repository
libperlmenu-perl_4.0-5_all.deb 4.0 all Debian Main
libperlmenu-perl - - -

Requires

Name Value
libcurses-perl -
perl >= 5.6.0-16

Conflicts

Name Value
perlmenu -

Replaces

Name Value
perlmenu -

Download

Type URL
Binary Package libperlmenu-perl_4.0-5_all.deb
Source Package libperlmenu-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperlmenu-perl deb package:
    # sudo apt-get install libperlmenu-perl

Files

Path
/usr/share/doc/libperlmenu-perl/FAQ.gz
/usr/share/doc/libperlmenu-perl/MENUUTIL_DOC.gz
/usr/share/doc/libperlmenu-perl/MENU_DOC.gz
/usr/share/doc/libperlmenu-perl/README.gz
/usr/share/doc/libperlmenu-perl/TO_DO
/usr/share/doc/libperlmenu-perl/changelog.Debian.gz
/usr/share/doc/libperlmenu-perl/changelog.gz
/usr/share/doc/libperlmenu-perl/copyright
/usr/share/doc/libperlmenu-perl/examples/create_menu.pl
/usr/share/doc/libperlmenu-perl/examples/demo.gz
/usr/share/doc/libperlmenu-perl/examples/demo_getstr
/usr/share/doc/libperlmenu-perl/examples/demo_template.gz
/usr/share/doc/libperlmenu-perl/examples/demo_top
/usr/share/doc/libperlmenu-perl/examples/demo_util
/usr/share/doc/libperlmenu-perl/examples/ezpasswd
/usr/share/doc/libperlmenu-perl/examples/ezreg.gz
/usr/share/doc/libperlmenu-perl/examples/ezview.gz
/usr/share/doc/libperlmenu-perl/examples/menuutil.pl.gz
/usr/share/doc/libperlmenu-perl/examples/template_data
/usr/share/doc/libperlmenu-perl/examples/template_ezp
/usr/share/doc/libperlmenu-perl/examples/template_reg
/usr/share/perl5/perlmenu.pm

Changelog

2007-07-15 - Deepak Tripathi <apenguinlinux@gmail.com>
libperlmenu-perl (4.0-5) unstable; urgency=low
* New maintainer (Closes: #333193)
* Add Homepage in debian/control
* Add debian/watch
* Change debian/copyright
2006-05-17 - Michael Ablassmeier <abi@debian.org>
libperlmenu-perl (4.0-4) unstable; urgency=low
* QA Upload 
* Add menuutil.pl to examples (Closes: #338461) 
* Conforms to new Standards Version.
2005-10-27 - Andrew Pollock <apollock@debian.org>
libperlmenu-perl (4.0-3) unstable; urgency=low
* QA Group upload orphaning this package
2004-07-15 - Marc 'HE' Brockschmidt <he@debian.org>
libperlmenu-perl (4.0-2) unstable; urgency=low
* debian/control: 
+ I'm a DD.
+ Changed Section: to perl.
* debian/rules:
+ Cleaned up (also removed the debian/*dirs file).
* debian/copyright:
+ FIXED. This module is licensed under the *L*GPL or Artistic License,
*not* (as stated before) under the terms of the GPL or Artistic
License.
2003-08-25 - Marc Brockschmidt <marc@dch-faq.de>
libperlmenu-perl (4.0-1) unstable; urgency=low
* New maintainer. (Closes: #206117)
* Renamed package from perlmenu to libperlmenu-perl to obey perl policy.
* Fixed build script. (Closes: #190500)
2003-08-18 - John Goerzen <jgoerzen@complete.org>
perlmenu (4.0-5) unstable; urgency=low
* Orphaning package; set maintainer to QA group.
2002-04-20 - John Goerzen <jgoerzen@complete.org>
perlmenu (4.0-4) unstable; urgency=low
* Built so it can be included in woody.  (Has been awhile -- it's
been stable!)
* Uncompress examples.  Closes: #69872, #119053.  (Those were the
only bugs since 1999!)
1999-09-22 - John Goerzen <jgoerzen@complete.org>
perlmenu (4.0-3) unstable; urgency=low
* Update to standards-version 3.0.1.
* Closes: #41488.
1999-07-21 - Raphael Hertzog <rhertzog@hrnet.fr>
perlmenu (4.0-2.1) unstable; urgency=low
* NMU for the perl upgrade. Closes: #41488
* Corrected the dependencies. Depends on perl5 now. Depends
on libcurses-perl instead of curses-perl.
* Upgraded standards-version to 3.0.0. Uses the new debstd.
* Corrected the location of the licenses in the copyright file. 
1998-09-04 - John Goerzen <jgoerzen@complete.org>
perlmenu (4.0-2) unstable; urgency=low
* Applied patch from Sergey Kolychev for centering menus,
fixing bug #23311.

See Also

Package Description
libperlspeak-perl_2.01-2_all.deb Perl Module for text to speech with festival, espeak, cepstral
libperlx-maybe-perl_1.001-1_all.deb return a pair only if they are both defined
libperlx-maybe-xs-perl_1.001-2+b1_amd64.deb XS backend for PerlX::Maybe
libpetal-perl_2.23-1_all.deb Perl Template Attribute Language - TAL for perl
libpetal-utils-perl_0.06-2_all.deb Useful template modifiers for Petal
libpetsc3.4.2-dev_3.4.2.dfsg1-8.1+b1_amd64.deb Static libraries, shared links, header files for PETSc
libpetsc3.4.2_3.4.2.dfsg1-8.1+b1_amd64.deb Shared libraries for version 3.4.2 of PETSc
libpff-dev_20120802-2_amd64.deb library to access various ms outlook files formats (development)
libpff1_20120802-2_amd64.deb library to access various ms outlook files formats
libpfm4-dev_4.5.0+git38-g1ca1338-2_amd64.deb Development files for the libpfm4 library
libpfm4_4.5.0+git38-g1ca1338-2_amd64.deb Library to program the performance monitoring events
libpfqueue-dev_0.5.6-9_amd64.deb interactive console-based tool to control MTA queues (development)
libpfqueue0_0.5.6-9_amd64.deb interactive console-based tool to control MTA queues (library)
libpfs-1.2-0_1.8.5-2+b1_amd64.deb C++ library to read and write pfs files
libpfs-dev_1.8.5-2+b1_amd64.deb C++ library to read and write pfs files (development files)
Advertisement
Advertisement