libpeas-1.0-0_1.12.1-2_amd64.deb


Advertisement

Description

libpeas-1.0-0 - Application plugin library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpeas-1.0-0
Package version 1.12.1
Package release 2
Package architecture amd64
Package type deb
Installed size 355 B
Download size 169.76 KB
Official Mirror ftp.br.debian.org
libpeas is a library that allows applications to support plugins.

Alternatives

Package Version Architecture Repository
libpeas-1.0-0_1.12.1-2_i386.deb 1.12.1 i386 Debian Main
libpeas-1.0-0 - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.14
libcairo-gobject2 >= 1.10.0
libcairo2 >= 1.2.4
libgdk-pixbuf2.0-0 >= 2.22.0
libgirepository-1.0-1 >= 0.9.2
libglib2.0-0 >= 2.37.3
libgtk-3-0 >= 3.0.0
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpeas-common -
libpython2.7 >= 2.7
libpython3.4 >= 3.4.2~rc1

Download

Type URL
Binary Package libpeas-1.0-0_1.12.1-2_amd64.deb
Source Package libpeas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpeas-1.0-0 deb package:
    # sudo apt-get install libpeas-1.0-0

Files

Path
/usr/lib/libpeas-1.0.so.0
/usr/lib/libpeas-1.0.so.0.1201.0
/usr/lib/libpeas-gtk-1.0.so.0
/usr/lib/libpeas-gtk-1.0.so.0.1201.0
/usr/lib/libpeas-1.0/loaders/libpython3loader.so
/usr/lib/libpeas-1.0/loaders/libpythonloader.so
/usr/share/doc/libpeas-1.0-0/AUTHORS
/usr/share/doc/libpeas-1.0-0/NEWS.gz
/usr/share/doc/libpeas-1.0-0/README.gz
/usr/share/doc/libpeas-1.0-0/changelog.Debian.gz
/usr/share/doc/libpeas-1.0-0/changelog.gz
/usr/share/doc/libpeas-1.0-0/copyright

Changelog

2014-11-06 - Emilio Pozuelo Monfort <pochu@debian.org>
libpeas (1.12.1-2) unstable; urgency=medium
* Disable seed support everywhere.
2014-09-22 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.12.1-1) unstable; urgency=medium
* New upstream release.
* Bump libglib2.0-dev build-dependency to >= 2.32.0 according to configure.ac
2014-09-07 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-4) unstable; urgency=medium
* Also exclude arm64 hppa and arm from the seed build-dependency.
* Add ppc64el and ia64 to archs where we don't enable seed
and exclude them from the seed build-dependency.
2014-09-07 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-3) unstable; urgency=medium
* Also add arm64 to platforms where we don't enable seed.
2014-09-05 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-2) unstable; urgency=medium
* Add hppa and alpha to the list of architectures where we don't enable
seed (Closes: #757241)
2014-08-28 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.1-1) unstable; urgency=medium
[ Emilio Pozuelo Monfort ]
* debian/rules:
+ Don't run the test suite when DEB_BUILD_OPTIONS contains nocheck.
Thanks to Pino Toscano. Closes: #755251.
* debian/rules,
debian/control.in:
+ Disable seed support on hurd-i386. Thanks to Pino Toscano.
Closes: #755259.
[ Andreas Henriksson ]
* New upstream release.
2014-04-26 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.0-2) unstable; urgency=medium
* debian/rules, debian/control.in:
Disable seed support on big-endian architectures (Closes: #727127)
- add powerpc s390x sparc since mips was already excluded.
- seed (because of webkit?) is broken on big endian.
2014-04-01 - Andreas Henriksson <andreas@fatal.se>
libpeas (1.10.0-1) experimental; urgency=medium
* export NOCONFIGURE in debian/rules to avoid double-configure.
* Add --disable-gjs configure flag for now.
- the gjs support has been dropped upstream
- it causes test failures (see 1.9.0-1 changelog entry)
- doesn't build with gjs >= 1.39 (mozjs24)
* Make test-suite fatal again.
* Bump Standards-Version to 3.9.5
* New upstream release.
* Update build-dependencies according to configure.ac changes:
- Bump gobject-introspection to >= 1.39.0
- Drop libgjs-dev
* Remove --disable-gjs configure flag (gjs no longer exists)
* Drop debian/patches/Fix-autogen-with-latest-gnome-common.patch
- from upstream, now part of released version.
2013-11-03 - Sjoerd Simons <sjoerd@debian.org>
libpeas (1.9.0-1) experimental; urgency=low
* New upstream release
* debian/patches/0001-Fix-tests-after-glib-string-change.patch
+ Dropped, fixed upstream
* debian/patches/0002-Fix-autogen-with-latest-gnome-common.patch
+ Dropped, fixed upstream
* debian/patches/Fix-autogen-with-latest-gnome-common.patch
+ Added, fix autogen (from upstream git)
* make the test-suite non-fatal, issues filed upstream as bgo#711356
2013-10-14 - Michael Biebl <biebl@debian.org>
libpeas (1.8.1-2) unstable; urgency=low
* debian/patches/0002-Fix-autogen-with-latest-gnome-common.patch:
Cherry-pick patch from upstream to drop usage of AM_GNU_GETTEXT as this is
not working in combination with IT_PROG_INTLTOOL. This fixes a FTBFS with
latest gnome-common which uses autoreconf now. (Closes: #724555)
* Delete __pycache__ directory in addition to compiled .pyc and .pyo files.

See Also

Package Description
libpeas-common_1.12.1-2_all.deb Application plugin library (common files)
libpeas-dev_1.12.1-2_amd64.deb Application plugin library (development files)
libpeas-doc_1.12.1-2_amd64.deb Application plugin library (documentation)
libpegex-perl_0.55-1_all.deb Acmeist PEG Parser Framework
libpentaho-reporting-flow-engine-java-doc_0.9.4-4_all.deb report library for java documentation
libpentaho-reporting-flow-engine-java_0.9.4-4_all.deb report library for java
libperformance-dev_0.5.0-1_amd64.deb GNUstep performance library (development files)
libperformance0.5_0.5.0-1_amd64.deb GNUstep performance library (runtime library)
libperinci-object-perl_0.13-1_all.deb module that provides a object-oriented interface for Rinci
libperl-apireference-perl_0.19-1_all.deb Perl module to programmatically query the perlapi
libperl-critic-perl_1.122-1_all.deb Perl module to critique code for best practices
libperl-destruct-level-perl_0.02-2+b1_amd64.deb Perl module to change Perl's destruction level
libperl-dev_5.20.2-3+deb8u9_amd64.deb Perl library: development files
libperl-metrics-simple-perl_0.17-1_all.deb module to provide metrics of Perl code
libperl-minimumversion-perl_1.38-1_all.deb module to determine minimum required version of perl required
Advertisement
Advertisement