libparse-cpan-packages-perl_2.38-1_all.deb


Advertisement

Description

libparse-cpan-packages-perl - module to parse the CPAN Packages file

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libparse-cpan-packages-perl
Package version 2.38
Package release 1
Package architecture all
Package type deb
Installed size 78 B
Download size 19.32 KB
Official Mirror ftp.br.debian.org
Parse::CPAN::Packages is a Perl module that parses the package details index
file named "02packages.details.txt.gz". This file contains lots of useful
information and this module provides a simple interface to the data contained
within.
Note that this module does not concern itself with downloading or unpacking
the "02packages.details.txt.gz" file; you will need to do this yourself.

Alternatives

Package Version Architecture Repository
libparse-cpan-packages-perl_2.38-1_all.deb 2.38 all Debian Main
libparse-cpan-packages-perl - - -

Requires

Name Value
libarchive-peek-perl -
libcpan-distnameinfo-perl -
libfile-slurp-perl -
libmoose-perl -
libpath-class-perl -
libppi-perl -
perl -

Download

Type URL
Binary Package libparse-cpan-packages-perl_2.38-1_all.deb
Source Package libparse-cpan-packages-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libparse-cpan-packages-perl deb package:
    # sudo apt-get install libparse-cpan-packages-perl

Files

Path
/usr/share/doc/libparse-cpan-packages-perl/changelog.Debian.gz
/usr/share/doc/libparse-cpan-packages-perl/changelog.gz
/usr/share/doc/libparse-cpan-packages-perl/copyright
/usr/share/man/man3/Parse::CPAN::Packages.3pm.gz
/usr/share/man/man3/Parse::CPAN::Packages::Distribution.3pm.gz
/usr/share/man/man3/Parse::CPAN::Packages::Package.3pm.gz
/usr/share/perl5/Parse/CPAN/Packages.pm
/usr/share/perl5/Parse/CPAN/Packages/Distribution.pm
/usr/share/perl5/Parse/CPAN/Packages/Package.pm

Changelog

2013-02-18 - gregor herrmann <gregoa@debian.org>
libparse-cpan-packages-perl (2.38-1) unstable; urgency=low
[ Nuno Carvalho ]
* New upstream release 2.37
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release 2.38.
* Update years of packaging copyright.
* Set Standards-Version to 3.9.4 (no changes).
2012-07-11 - Nuno Carvalho <smash@cpan.org>
libparse-cpan-packages-perl (2.36-1) unstable; urgency=low
* Team upload
* d/control: Remove libtest-pod* from B-D-I
* d/control: Update standards version
* d/copyright: Update copyright format
* New upstream release
2011-09-19 - gregor herrmann <gregoa@debian.org>
libparse-cpan-packages-perl (2.35-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ gregor herrmann ]
* debian/control: Changed: (build-)depend on perl instead of perl-
modules.
[ Jonathan Yu ]
* New upstream release 2.33
* Use new 3.0 (quilt) source format
* Use new short debhelper rules format
* Refresh copyright information
* Refresh patches and headers
* Rewrite control description
* Standards-Version 3.9.1 (no changes)
* Add myself to Uploaders and Copyright
[ Ansgar Burchardt ]
* Email change: Ansgar Burchardt -> ansgar@debian.org
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ gregor herrmann ]
* New upstream releases 2.34, 2.35.
* Refresh patch.
* Update years of packaging copyright.
* Bump debhelper compatibility level to 8.
* Set Standards-Version to 3.9.2 (no changes).
* Add new build and runtime dependencies.
* Refresh patch (offset).
2009-04-24 - Brian Cassidy <brian.cassidy@gmail.com>
libparse-cpan-packages-perl (2.31-1) unstable; urgency=low
[ Brian Cassidy ]
* New upstream release
* debian/control:
+ Standards-Version to 3.8.1
+ Added myself to Uploaders
[ Ryan Niebur ]
* Remove Florian Ragwitz from Uploaders (Closes: #523222)
2009-01-23 - Ansgar Burchardt <ansgar@43-1.org>
libparse-cpan-packages-perl (2.30-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Ansgar Burchardt ]
* New upstream release.
+ Update copyright years in debian/copyright.
* debian/control: Update dependencies.
* Add missing whatis entry for Parse::CPAN::Distribution.
+ Add quilt framework and README.source to debian/*.
[ gregor herrmann ]
* debian/control:
- add (build) dependency on perl-modules (>= 5.10) | libcompress-zlib-perl
- mention module name in long description
2008-08-22 - Ansgar Burchardt <ansgar@43-1.org>
libparse-cpan-packages-perl (2.29-1) unstable; urgency=low
[ Ansgar Burchardt ]
* New upstream release.
+ Update copyright years in debian/copyright
* Add myself to Uploaders.
[ gregor herrmann ]
* debian/control: (build) depend on "perl-modules (>= 5.10) |
libversion-perl" instead of libversion-perl alone.
2008-08-12 - gregor herrmann <gregoa@debian.org>
libparse-cpan-packages-perl (2.28-1) unstable; urgency=low
[ Frank Lichtenheld ]
* Add a missing comma in Uploaders field
[ gregor herrmann ]
* New upstream release.
* Set debhelper compatibility level to 7; adapt
debian/{control,compat,rules}.
* debian/control: change my email address.
* Switch debian/copyright to new format.
* Set Standards-Version to 3.8.0 (no changes).

See Also

Package Description
libparse-debcontrol-perl_2.005-4_all.deb parser for debian control-like files
libparse-debian-packages-perl_0.03-2_all.deb module for parsing the data from a Debian Packages.gz
libparse-debianchangelog-perl_1.2.0-1.1_all.deb parse Debian changelogs and output them in other formats
libparse-dia-sql-perl_0.27-1_all.deb module for parsing Dia diagram files and generating SQL
libparse-dmidecode-perl_0.03-1_all.deb interface to SMBIOS using dmidecode
libparse-edid-perl_1.0.6-1_all.deb Extended display identification data (EDID) parser
libparse-errorstring-perl-perl_0.21-1_all.deb module for parsing error messages from the Perl interpreter
libparse-exuberantctags-perl_1.02-1+b1_amd64.deb exuberant ctags parser for Perl
libparse-fixedlength-perl_5.39-1_all.deb Perl module to parse a string containing fixed length fields
libparse-http-useragent-perl_0.39-1_all.deb parser for the HTTP User Agent string
libparse-mediawikidump-perl_1.0.6-1_all.deb Perl module to parse MediaWiki dump files
libparse-method-signatures-perl_1.003016-1_all.deb Perl module to parse Perl6-like method signatures
libparse-netstat-perl_0.4-1_all.deb module to parse the output of the "netstat" command
libparse-pidl-perl_4.2.14+dfsg-0+deb8u9_amd64.deb IDL compiler written in Perl
libparse-plainconfig-perl_2.06-1_all.deb parser for plain-text configuration files
Advertisement
Advertisement