libparpack2_3.1.5-3_amd64.deb


Advertisement

Description

libparpack2 - Parallel subroutines to solve large scale eigenvalue problems

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libparpack2
Package version 3.1.5
Package release 3
Package architecture amd64
Package type deb
Installed size 622 B
Download size 147.59 KB
Official Mirror ftp.br.debian.org
ARPACK software is capable of solving large scale symmetric,
nonsymmetric, and generalized eigenproblems from significant
application areas. The software is designed to compute a few (k)
eigenvalues with user specified features such as those of largest
real part or largest magnitude. Storage requirements are on the order
of n*k locations. No auxiliary storage is required. A set of Schur
basis vectors for the desired k-dimensional eigen-space is computed
which is numerically orthogonal to working precision. Numerically
accurate eigenvectors are available on request.
Important Features:
* Reverse Communication Interface.
* Single and Double Precision Real Arithmetic Versions for Symmetric,
Non-symmetric,
* Standard or Generalized Problems.
* Single and Double Precision Complex Arithmetic Versions for Standard or
Generalized Problems.
* Routines for Banded Matrices - Standard or Generalized Problems.
* Routines for The Singular Value Decomposition.
* Example driver routines that may be used as templates to implement
numerous Shift-Invert strategies for all problem types, data types and
precision.
This package provides parpack: the MPI implementation of arpack.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libparpack2_3.1.5-3_i386.deb 3.1.5 i386 Debian Main
libparpack2 - - -

Requires

Name Value
libblas.so.3 -
libblas3 -
libc6 >= 2.2.5
libgcc1 >= 1:4.1.1
libgfortran3 >= 4.6
liblapack.so.3 -
liblapack3 -
libopenmpi1.6 -
libquadmath0 >= 4.6

Replaces

Name Value
libarpack2 -

Download

Type URL
Binary Package libparpack2_3.1.5-3_amd64.deb
Source Package arpack

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libparpack2 deb package:
    # sudo apt-get install libparpack2

Files

Path
/usr/lib/libparpack.so.2
/usr/lib/libparpack.so.2.0.0
/usr/share/doc/libparpack2/changelog.Debian.gz
/usr/share/doc/libparpack2/changelog.gz
/usr/share/doc/libparpack2/copyright

Changelog

2014-04-30 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.5-3) unstable; urgency=medium
* update the symbol list for mips64 & mips64el (Closes: #746277)
2014-02-27 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.5-2) unstable; urgency=medium
* fix FTBFS on various port architectures by updating the symbol list.
Thanks to Adrian Glaubitz (Closes: #740198)
2014-02-15 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.5-1) unstable; urgency=medium
* New upstream release
* Fix the m68k symbols list (Closes: #726969)
* Fix the arm64 symbol list
* Remove mpi-dep-lib.diff (applied upstream)
* Standards-Version updated to version 3.9.5
2013-11-13 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.4-1) unstable; urgency=low
* New upstream release
2013-10-14 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.3-4) unstable; urgency=low
* Update of the list of symbols for mips64(el) and mipsn32(el)
Thanks for YunQiang Su (Closes: #726096)
2013-08-06 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.3-3) unstable; urgency=low
* libparpack: Missing dependency on MPI (Closes: #718790)
2013-05-07 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.3-2) unstable; urgency=low
* Update the symbols file for:
mips, mipsel, s390, s390x and powerpcspe
(Closes: #706940)
* Reintroduce changes from 3.1.1-2.1
2013-05-06 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.3-1) unstable; urgency=low
* Upload to unstable
* Standards-Version updated to 3.9.4
2013-04-02 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.3-1~exp1) experimental; urgency=low
* New upstream release
2012-08-27 - Sylvestre Ledru <sylvestre@debian.org>
arpack (3.1.2-2~exp1) experimental; urgency=low
* Drop the dependency between libarpack2 => libparpack2 and
libarpack2-dev => libparpack2-dev
It was added to simplify the split between arpack serial and parallel.

See Also

Package Description
libparrot-dev_6.6.0-1_amd64.deb Parrot shared library development files
libparrot6.6.0_6.6.0-1_amd64.deb Parrot shared library
libparse-cpan-meta-perl_1.4414-1_all.deb module to parse META.yml and other similar CPAN metadata files
libparse-cpan-packages-perl_2.38-1_all.deb module to parse the CPAN Packages file
libparse-debcontrol-perl_2.005-4_all.deb parser for debian control-like files
libparse-debian-packages-perl_0.03-2_all.deb module for parsing the data from a Debian Packages.gz
libparse-debianchangelog-perl_1.2.0-1.1_all.deb parse Debian changelogs and output them in other formats
libparse-dia-sql-perl_0.27-1_all.deb module for parsing Dia diagram files and generating SQL
libparse-dmidecode-perl_0.03-1_all.deb interface to SMBIOS using dmidecode
libparse-edid-perl_1.0.6-1_all.deb Extended display identification data (EDID) parser
libparse-errorstring-perl-perl_0.21-1_all.deb module for parsing error messages from the Perl interpreter
libparse-exuberantctags-perl_1.02-1+b1_amd64.deb exuberant ctags parser for Perl
libparse-fixedlength-perl_5.39-1_all.deb Perl module to parse a string containing fixed length fields
libparse-http-useragent-perl_0.39-1_all.deb parser for the HTTP User Agent string
libparse-mediawikidump-perl_1.0.6-1_all.deb Perl module to parse MediaWiki dump files
Advertisement
Advertisement