libpam-mklocaluser_0.10_all.deb


Advertisement

Description

libpam-mklocaluser - Configure PAM to create a local user if it do not exist already

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libpam-mklocaluser
Package version 0.10
Package release
Package architecture all
Package type deb
Installed size 54 B
Download size 6.35 KB
Official Mirror ftp.br.debian.org
When the user log in for the first time, a local user is created in
/etc/passwd and primary group created in /etc/group, and a local home
directory is created in /home.  This is useful on roaming computers when
the password is set up to be cached by for example libpam-ccreds or sssd
to allow login without network connectivity using the password provided
by a network authentication service like Kerberos or LDAP.

Alternatives

Package Version Architecture Repository
libpam-mklocaluser_0.10_all.deb 0.10 all Debian Main
libpam-mklocaluser - - -

Requires

Name Value
libpam-python -
python >= 2.6.6-3

Download

Type URL
Binary Package libpam-mklocaluser_0.10_all.deb
Source Package libpam-mklocaluser

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpam-mklocaluser deb package:
    # sudo apt-get install libpam-mklocaluser

Files

Path
/usr/lib/libpam-mklocaluser/pam-python.py
/usr/share/doc/libpam-mklocaluser/changelog.gz
/usr/share/doc/libpam-mklocaluser/copyright
/usr/share/pam-configs/mklocaluser
/usr/share/python/runtime.d/libpam-mklocaluser.rtupdate

Changelog

2014-08-14 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.10) unstable; urgency=high
* Using urgency high to fix RC bug quickly.
* Make sure to add trailing newline when updating /etc/passwd and
/etc/shadow.  This is an RC bug blocking the package from working.
* Change priority from extra to optional to match the archive override
file.
* Switch from python-support to dh-python.
2014-06-09 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.9) unstable; urgency=low
* Update standard-version from 3.9.2 to 3.9.5.  No changes needed.
* Make PAM module more robust:
* Add to /etc/passwd and /etc/shadow using python code instead of
calling "echo 'something' >> /etc/file" in a subshell.
* Do not try to syslog an exception, as a string is needed in newer
python versions.
* Do not call chown -R, implement it in python instead.
* Correct test pam_handler function arguments and make it output
more info during testing.
* Make sure syslog message make it clear that both passwd and shadow
is updated by the module.
* Change priority from optional to extra, as it depend on libpam-python
which is priority extra, to avoid priority inversion.
* Source is moved to git.  Update Vcs-* control file fields.
2013-05-04 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.8) unstable; urgency=low
* Rewrite runcmd() to work with Python on Wheezy (Closes: #706753).
2013-05-04 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.8~deb7u1) wheezy; urgency=low
* Rewrite runcmd() to work with Python on Wheezy (Closes: #706753).
2011-07-28 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.7) unstable; urgency=low
* Rewrite how Popen() is used to ensure the script wait for the
subprocesses to start before looking for their status (Closes:
#634829).  Patch from Wolfgang Schulze-Zachau.
* Update standards-version from 3.9.1 to 3.9.2.  No changes needed.
2010-09-18 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.6) unstable; urgency=low
* Make module more robust.  Move group lookup into the code path
where it is used, to avoid failing if the group is missing when
the user is already available locally (Closes: #597174).
* Add code to handle missing primary group information when creating
the local user.
* Change module to only run /usr/sbin/nscd if it exist (Closes: #597241).
* Update standards-version from 3.8.4 to 3.9.1.  No changes needed.
2010-07-23 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.5) unstable; urgency=low
* Do not create local home directory if the directory mentioned in
passwd already exist.
2010-06-01 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.4) unstable; urgency=low
[ Morten Werner Forsbring ]
* Do not add localuser if it already exist in /etc/passwd.
* Add build-dependency on python-support.
* Make sure that dh_pysupport is run during build.
* Added myself as uploader.
2010-05-19 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.3) unstable; urgency=low
* Make sure the path to the original home directory and the user
name of the user logging in is passed on to the hook scripts.
2010-05-19 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.2) unstable; urgency=low
* Correct typo in pam-configs entry causing the PAM module to fail.

See Also

Package Description
libpam-modules-bin_1.1.8-3.1+deb8u2+b1_amd64.deb Pluggable Authentication Modules for PAM - helper binaries
libpam-modules_1.1.8-3.1+deb8u2+b1_amd64.deb Pluggable Authentication Modules for PAM
libpam-mount_2.14-1.1_amd64.deb PAM module that can mount volumes for a user session
libpam-mysql_0.7~RC1-4+b3_amd64.deb PAM module allowing authentication from a MySQL server
libpam-nufw_2.4.3-3.1_amd64.deb The authenticating firewall [PAM module]
libpam-oath_2.4.1-1_amd64.deb OATH Toolkit libpam_oath PAM module
libpam-ocaml-dev_1.1-4+b4_amd64.deb OCaml bindings for the PAM library (development files)
libpam-ocaml_1.1-4+b4_amd64.deb OCaml bindings for the PAM library (runtime)
libpam-openafs-kaserver_1.6.9-2+deb8u5_amd64.deb AFS distributed filesystem kaserver PAM module
libpam-otpw_1.3-2_amd64.deb Use OTPW for PAM authentication
libpam-p11_0.1.5-4_amd64.deb PAM module for using PKCS#11 smart cards
libpam-passwdqc_1.3.0-1_amd64.deb PAM module for password strength policy enforcement
libpam-pgsql_0.7.3.2-1_amd64.deb PAM module to authenticate using a PostgreSQL database
libpam-pkcs11_0.6.8-4_amd64.deb Fully featured PAM module for using PKCS#11 smart cards
libpam-poldi_0.4.1-3+b1_amd64.deb PAM module allowing authentication using a OpenPGP smartcard
Advertisement
Advertisement