libopenexr6_1.6.1-8_amd64.deb


Advertisement

Description

libopenexr6 - runtime files for the OpenEXR image library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package filename libopenexr6_1.6.1-8_amd64.deb
Package name libopenexr6
Package version 1.6.1
Package release 8
Package architecture amd64
Package type deb
Category implemented-in::c++ libs role::shared-lib
Homepage http://www.openexr.com
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 178.43 KB
Installed size 755.00 KB
OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.
OpenEXR's features include:
* Higher dynamic range and colour precision than existing 8- and
10-bit image file formats.
* Support for the "half" 16-bit floating-point pixel format.
* Multiple lossless image compression algorithms. Some of the
included codecs can achieve 2:1 lossless compression ratios on
images with film grain.
* Extensibility. New compression codecs and image types can easily
be added by extending the C++ classes included in the OpenEXR
software distribution. New image attributes (strings, vectors,
integers, etc.) can be added to OpenEXR image headers without
affecting backward compatibility with existing OpenEXR
applications.
This package contains the following shared library:
* IlmImf - a library that reads and writes OpenEXR images.

Alternatives

Package Version Architecture Repository
libopenexr6_1.6.1-8_i386.deb 1.6.1 i386 Debian Main
libopenexr6 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libilmbase6 >= 1.0.1
libstdc++6 >= 4.9
multiarch-support -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libopenexr6_1.6.1-8_amd64.deb
Source Package openexr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopenexr6 deb package:
    # sudo apt-get install libopenexr6

Files

Path
/usr/lib/x86_64-linux-gnu/libIlmImf.so.6
/usr/lib/x86_64-linux-gnu/libIlmImf.so.6.0.0
/usr/share/doc/libopenexr6/AUTHORS
/usr/share/doc/libopenexr6/NEWS.gz
/usr/share/doc/libopenexr6/README
/usr/share/doc/libopenexr6/buildinfo_amd64.gz
/usr/share/doc/libopenexr6/changelog.Debian.gz
/usr/share/doc/libopenexr6/changelog.gz
/usr/share/doc/libopenexr6/copyright

Changelog

2014-08-31 - Andreas Metzler <ametzler@debian.org>
openexr (1.6.1-8) unstable; urgency=medium
* QA upload.
* Orphan package, set maintainer to QA.
* Add 20_autoreconf.diff by Andreas Barth to let autoreconf run successfully
and use dh-autoreconf. Closes: #759719
* Point Vcs-* to anonscm.debian.org.
2012-12-08 - Andreas Metzler <ametzler@debian.org>
openexr (1.6.1-7) unstable; urgency=low
* Convert to multi-arch.
+ Use debhelper v9 compat, bump build-dep. Drop unneeded invocation of
dpkg-buildflags.
+ Update *.install.
+ Add Pre-Depends: ${misc:Pre-Depends}.
+ Runtime library is Multi-Arch: same, cmd-line utils Multi-Arch: foreign.
2012-07-07 - Andreas Metzler <ametzler@debian.org>
openexr (1.6.1-6) unstable; urgency=low
* nonlinuxlargestack.diff Fix FTBFS when large stacks are disabled.
Bug-report, diagnosis and patch by Pino Toscano. Closes: #680509
2012-04-01 - Andreas Metzler <ametzler@debian.org>
openexr (1.6.1-5) unstable; urgency=low
* Update package short description, openexr does not contain a viewer.
Closes: #471783
* Use 3.0 (quilt) source format.
* Re-enable doc-base support. At least dhelp works without problems.
* Use dh $@ --with autotools_dev. Version autotools-dev b-d.
* The latter three changes add support for build-arch target, fixing FTBFS.
Closes: #666297
* Change override_dh_auto_test target to invoke dh_auto_test, otherwise the
testsuite is run twice. (Once for build and binary).
* Add myself to uploaders, remove Cyril. (Thanks for you work!)
* Empty dependency_libs in libtool la file.
* Fix doc-base ids. (lowercase, no underscore.)
* Drop Section: graphics from binary package stanza in debian/control.
* Fix typo mutiple in exrmaketiled.1.
* Use 'dpkg-buildflags --export=configure' to get hardening-flags. (Thanks,
Moritz Muehlenhoff). Add required b-d on dpkg-dev (>= 1.16.1). 
Closes: #656506
2009-10-21 - Giuseppe Iuculano <iuculano@debian.org>
openexr (1.6.1-4.1) unstable; urgency=high
* Non-maintainer upload by the Security Team.
* Fixed CVE-2009-1720: Integer overflows in Imf::PreviewImage::PreviewImage
and integer overflows in compressor constructors
* Fixed CVE-2009-1721: uninitialized pointers in Imf::hufUncompress
* Patch stolen from stable-security, thanks to Cyril Brulebois
(Closes: #550424)
2009-04-11 - Cyril Brulebois <kibi@debian.org>
openexr (1.6.1-4) unstable; urgency=low
* Adopt the package within pkg-phototools (Closes: #494877):
- Thanks to Adeodato Simó et al. for having taken care of it until
now!
- Set Maintainer to the group.
- Set Uploaders to myself.
- Update Vcs-{Git,Browser}.
- Remove XS-X-Collab-Maint field, no longer relevant. Patches are
still welcome, though!
* Switch to debhelper 7:
- Bump debian/compat to 7.
- Version the B-D on debhelper: >= 7.0.50 to allow the use of
overrides.
- Specify some overrides to tweak as needed for the build:
- dh_auto_configure: pass the --with-openexr flag to configure
script.
- dh_auto_test: don't run “check” on arm and ia64 for now, and
bypass dh_auto_test due to bad target detection.
- dh_compress: no longer compress .h/.cpp examples.
- dh_link: needed since libopenexr-dev's and openexr's /us/s/d
directories are symlinks to libopenexr6's one.
- dh_makeshlibs: keep on using -V.
- dh_installdeb: add a call to dh_buildinfo to keep on storing the
versions of packages installed during the build.
- Specify some targets:
- build and clean to handle patching/unpatching and
updating/cleaning config.{guess,sub}.
* Now compress PDF documentation. Any sane PDF viewer should be able to
handle decompression.
* Remove .gitignore file.
* Add ${misc:Depends} to all binaries.
* Bump Standards-Version from 3.7.3 to 3.8.1 (no changes needed).

See Also

Package Description
libopengl-image-perl_1.03-1_all.deb Image loader for OpenGL
libopengl-perl_0.6703+dfsg-1+b1_amd64.deb Perl interface providing graphics display using OpenGL
libopengl-xscreensaver-perl_0.05-1+b1_amd64.deb Perl module for writing OpenGL-based XScreenSaver hacks
libopenhpi-dev_2.14.1-1.4_amd64.deb OpenHPI libraries (development files)
libopenhpi2_2.14.1-1.4_amd64.deb OpenHPI libraries (runtime and support files)
libopenid4java-java-doc_0.9.6.662-2_all.deb documentation for libopenid4java
libopenid4java-java_0.9.6.662-2_all.deb This library allows you to OpenID-enable your Java webapp
libopenigtlink-dev_1.10.5-1_amd64.deb Open IGT Link is a simple network protocol - development
libopenigtlink1.10_1.10.5-1_amd64.deb Open IGT Link is a simple network protocol - runtime
libopenimageio-dev_1.4.14~dfsg0-1_amd64.deb Library for reading and writing images - development
libopenimageio1.4_1.4.14~dfsg0-1_amd64.deb Library for reading and writing images - runtime
libopenipmi-dev_2.0.16-1.4_amd64.deb Intelligent Platform Management Interface - development
libopenipmi0_2.0.16-1.4_amd64.deb Intelligent Platform Management Interface - runtime
libopenjp2-7-dev_2.1.0-2+deb8u3+b1_amd64.deb development files for OpenJPEG, a JPEG 2000 image library
libopenjp2-7_2.1.0-2+deb8u3+b1_amd64.deb JPEG 2000 image compression/decompression library
Advertisement
Advertisement