libocas0_0.97-1_amd64.deb


Advertisement

Description

libocas0 - OCAS solver for training linear SVM classifiers

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libocas0
Package version 0.97
Package release 1
Package architecture amd64
Package type deb
Installed size 66 B
Download size 21.96 KB
Official Mirror ftp.br.debian.org
This library implements Optimized Cutting Plane Algorithm (OCAS) for
training linear Support Vector Machine (SVM) classifiers from
large-scale data. The computational effort of OCAS scales linearly with
the number of training examples. It is one of the fastest SVM solvers
around for solving linear and multiclass L2 regularized SVMs.
This package contains the shared libraries.

Alternatives

Package Version Architecture Repository
libocas0_0.97-1_i386.deb 0.97 i386 Debian Main
libocas0 - - -

Requires

Name Value
libc6 >= 2.14
multiarch-support -

Download

Type URL
Binary Package libocas0_0.97-1_amd64.deb
Source Package libocas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libocas0 deb package:
    # sudo apt-get install libocas0

Files

Path
/usr/lib/x86_64-linux-gnu/libocas.so.0
/usr/lib/x86_64-linux-gnu/libocas.so.0.97
/usr/share/doc/libocas0/AUTHORS
/usr/share/doc/libocas0/NEWS.Debian.gz
/usr/share/doc/libocas0/README
/usr/share/doc/libocas0/changelog.Debian.gz
/usr/share/doc/libocas0/changelog.gz
/usr/share/doc/libocas0/copyright

Changelog

2014-08-24 - Christian Kastner <debian@kvr.at>
libocas (0.97-1) unstable; urgency=medium
* New upstream release.
- Upstream renamed the linclass executable to linclassif
* debian/libocas-tools.*
debian/{linclassif,svmocas,msvmocas}.1:
- Adjust for upstream-renamed executable
* debian/NEWS:
- Add to notify users of the renamed linclassif
* Migrate git repo to Debian-Science at git.debian.org
* debian/control:
- Update VCS-* URLs to point to new location
- Add XS-Testsuite for autopkgtest
* debian/tests/*:
- Add an autopkgtest "executables" that runs the examples from the
documentation
* debian/watch:
- Mangle uversion instead of dversion, otherwise uscan renames using
the unwanted version number
* debian/libocas0.symbols:
- Update with new symbol
* debian/patches (refreshed):
- 0001-Properly-build-shared-and-static-libraries-programs
Refresh Makefile patch to new upstream version
2014-07-27 - Christian Kastner <debian@kvr.at>
libocas (0.93-3) unstable; urgency=low
* debian/control:
- Add Multi-Arch fields to packages where necessary
- Add Pre-Depends for package liblinear1
* debian/rules:
- Install to multi-arch locations
* debian/patches (updated):
- 0001-Properly-build-shared-and-static-libraries-programs
Add an install target to upstream's Makefile, with configurable
destinations for libraries and executables
* debian/*.install:
- Update paths as a consequence of the new install target and
multi-arch-ification
2014-02-19 - Christian Kastner <debian@kvr.at>
libocas (0.93-2) unstable; urgency=low
* debian/copyright:
- Corrected upstream license version from GPL-3+ to GPL-3. Thanks to
Vincent Cheng for catching this. Closes: #751668
* debian/control:
- Bumped Standards-Version to 3.9.5 (no changes required)
- Bumped debhelper dependency to 9
- Demoted libocas0's Recommends for libocas-tools to Suggests, so
packages depending only on the library don't pull in the tools.
* debian/compat:
- Bumped debhelper compatibility level to recommended level 9
* debian/copyright:
- Refreshed to machine-readable copyright format 1.0
* debian/rules:
- Use DEB_CFLAGS_MAINT_APPEND, as recommended, instead of CFLAGS
* debian/patches (modified):
- 0001-Properly-build-shared-and-static-libraries-programs
Include CPPFLAGS to avoid hardening flag warnings
* debian/source/lintian-overrides:
- Added override for debian-watch-may-check-gpg-signature
* debian/libocas-tools.lintian-overrides:
- Added override for arch-dep-package-has-big-usr-share
2010-06-17 - Christian Kastner <debian@kvr.at>
libocas (0.93-1) unstable; urgency=low
* Initial release (Closes: #585788)
* debian/patches:
- 0001-Properly-build-shared-and-static-libraries-programs

See Also

Package Description
liboce-foundation-dev_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform library development files
liboce-foundation8_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform shared library
liboce-modeling-dev_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform library development files
liboce-modeling8_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform shared library
liboce-ocaf-dev_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform library development files
liboce-ocaf-lite-dev_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform library development files
liboce-ocaf-lite8_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform shared library
liboce-ocaf8_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform shared library
liboce-visualization-dev_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform library development files
liboce-visualization8_0.15-5_amd64.deb OpenCASCADE Community Edition CAE platform shared library
libocp-indent-lib-ocaml-dev_1.4.2-1_amd64.deb OCaml indentation tool for emacs and vim - development libraries
libocp-indent-lib-ocaml_1.4.2-1_amd64.deb OCaml indentation tool for emacs and vim - libraries
libocpf-dev_2.2-6+deb8u1_amd64.deb Development files for the OCPF library
libocpf0_2.2-6+deb8u1_amd64.deb Scripting library for the MAPI protocol
libocrad-dev_0.24-1_amd64.deb optical character recognition library
Advertisement
Advertisement