libnet-inet6glue-perl_0.603-1_all.deb


Advertisement

Description

libnet-inet6glue-perl - glue module to make perl modules IPv6 ready

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libnet-inet6glue-perl
Package version 0.603
Package release 1
Package architecture all
Package type deb
Installed size 62 B
Download size 13.15 KB
Official Mirror ftp.br.debian.org
Net::INET6Glue is a collection of modules to make common modules IPv6 ready
by hotpatching them.
Unfortunatly the current state of IPv6 support in perl is that no IPv6
support is in the core and that a lot of important modules (like Net::FTP,
Net::SMTP, LWP, ...) do not support IPv6 even if the modules for IPv6 sockets
like Socket6, IO::Socket::IP or IO::Socket::INET6 are available.

Alternatives

Package Version Architecture Repository
libnet-inet6glue-perl_0.603-1_all.deb 0.603 all Debian Main
libnet-inet6glue-perl - - -

Requires

Name Value
libio-socket-inet6-perl -
libio-socket-ip-perl >= 0.25
perl >= 5.19.8
perl -

Download

Type URL
Binary Package libnet-inet6glue-perl_0.603-1_all.deb
Source Package libnet-inet6glue-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnet-inet6glue-perl deb package:
    # sudo apt-get install libnet-inet6glue-perl

Files

Path
/usr/share/doc/libnet-inet6glue-perl/changelog.Debian.gz
/usr/share/doc/libnet-inet6glue-perl/changelog.gz
/usr/share/doc/libnet-inet6glue-perl/copyright
/usr/share/man/man3/Net::INET6Glue.3pm.gz
/usr/share/man/man3/Net::INET6Glue::FTP.3pm.gz
/usr/share/man/man3/Net::INET6Glue::INET_is_INET6.3pm.gz
/usr/share/perl5/Net/INET6Glue.pm
/usr/share/perl5/Net/INET6Glue/FTP.pm
/usr/share/perl5/Net/INET6Glue/INET_is_INET6.pm

Changelog

2014-09-08 - Salvatore Bonaccorso <carnil@debian.org>
libnet-inet6glue-perl (0.603-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
* Add debian/upstream/metadata
* Imported upstream version 0.603
* Add alternative (build-)dependency on perl.
Add alternative Build-Depends and Depends on perl (>= 5.19.8) which
includes the required version of IO::Socket::IP in Perl core.
* Wrap and sort fields in debian/control
* Add autopkgtest control file
2014-01-20 - gregor herrmann <gregoa@debian.org>
libnet-inet6glue-perl (0.602-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update years of upstream and packaging copyright.
* Update (build) dependencies. The module prefers IO::Socket::IP now.
* Update long description.
* Declare compliance with Debian Policy 3.9.5.
2013-08-18 - Michael Stapelberg <stapelberg@debian.org>
libnet-inet6glue-perl (0.6-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
* debian/watch: update to ignore development releases.
[ Salvatore Bonaccorso ]
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Michael Stapelberg ]
* New upstream version
* Maintainer: Debian Perl Group, Uploaders: Michael
* remove obsolete DM-Upload-Allowed
* add Vcs-* headers
* use debhelper 8
* switch to source format 3.0 (quilt)
* don’t install README as documentation, it is unhelpful
* update debian/copyright
* Email change: Michael Stapelberg -> stapelberg@debian.org
* bump standards-version to 3.9.4 (no changes necessary)
2011-08-27 - Michael Stapelberg <michael@stapelberg.de>
libnet-inet6glue-perl (0.5-1) unstable; urgency=low
* New upstream release
2010-04-06 - Michael Stapelberg <michael@stapelberg.de>
libnet-inet6glue-perl (0.4-2) unstable; urgency=low
* Fix FTBFS (Closes: #576667)
2010-03-28 - Michael Stapelberg <michael@stapelberg.de>
libnet-inet6glue-perl (0.4-1) unstable; urgency=low
* New upstream release
* fix EPRT in Net::INET6Glue::FTP so that it can also be used with IPv4 (when
eprt is explicitly called)
2009-07-11 - Michael Stapelberg <michael@stapelberg.de>
libnet-inet6glue-perl (0.3-2) unstable; urgency=low
* Add dependency on libio-socket-inet6-perl
2009-06-08 - Michael Stapelberg <michael@stapelberg.de>
libnet-inet6glue-perl (0.3-1) unstable; urgency=low
* Initial Release. (Closes: #532291)

See Also

Package Description
libnet-ip-minimal-perl_0.06-1_all.deb module to check if an IP address is version 4 or 6
libnet-ip-perl_1.26-1_all.deb Perl extension for manipulating IPv4/IPv6 addresses
libnet-ipaddress-perl_1.10-3_all.deb Functions used to manipulate IP addresses, masks and FQDN's
libnet-iptrie-perl_0.7-1_all.deb Perl module for building IPv4 and IPv6 address space hierarchies
libnet-ipv6addr-perl_0.2.dfsg.1-3_all.deb Check validity of IPv6 addresses
libnet-irc-perl_0.79-1_all.deb IRC (Internet Relay Chat) interface module for Perl
libnet-irr-perl_0.08-1_all.deb perl interface to the Internet Route Registry daemon
libnet-jabber-bot-perl_2.1.5-1_all.deb automated Bot creation with safeties
libnet-jabber-loudmouth-perl_0.07-3+b1_amd64.deb Perl interface for the loudmouth jabber library
libnet-jabber-perl_2.0-6_all.deb Perl modules for accessing the Jabber protocol
libnet-jifty-perl_0.14-1_all.deb interface to applications using the Jifty web framework
libnet-ldap-filterbuilder-perl_1.0004-1_all.deb Build LDAP filter statements
libnet-ldap-perl_0.6400+dfsg-2_all.deb client interface to LDAP servers
libnet-ldap-server-perl_0.4-2_all.deb LDAP server-side protocol handling in Perl
libnet-ldapapi-perl_3.0.3-7+b4_amd64.deb Perl bindings for OpenLDAP C API
Advertisement
Advertisement