libmozjs-24-bin_24.2.0-2_amd64.deb


Advertisement

Description

libmozjs-24-bin - Spidermonkey JavaScript shell

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libmozjs-24-bin
Package version 24.2.0
Package release 2
Package architecture amd64
Package type deb
Installed size 5.52 KB
Download size 1.61 MB
Official Mirror ftp.br.debian.org
SpiderMonkey is the code-name for the Mozilla's C++ implementation of
JavaScript. It is intended to be embedded in other applications
that provide host environments for JavaScript.
This package contains js24 JavaScript interpreter.

Alternatives

Package Version Architecture Repository
libmozjs-24-bin_24.2.0-2_i386.deb 24.2.0 i386 Debian Main
libmozjs-24-bin - - -

Requires

Name Value
libc6 >= 2.14
libffi6 >= 3.0.4
libgcc1 >= 1:4.1.1
libnspr4 >= 2:4.9.2
libstdc++6 >= 4.1.1

Download

Type URL
Binary Package libmozjs-24-bin_24.2.0-2_amd64.deb
Source Package mozjs24

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmozjs-24-bin deb package:
    # sudo apt-get install libmozjs-24-bin

Files

Path
/usr/bin/js24
/usr/share/doc/libmozjs-24-bin/changelog.Debian.gz
/usr/share/doc/libmozjs-24-bin/copyright

Changelog

2014-05-02 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
mozjs24 (24.2.0-2) unstable; urgency=low
* Make shlibs fix unconditional of Operating System (closes: #746705).
2014-02-27 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
mozjs24 (24.2.0-1) unstable; urgency=low
* Initial upload to Debian (closes: #739132).
* libmozjs-24-dev doesn't need ${shlibs:Depends} dependency.
* Add DEB_BUILD_OPTIONS nocheck option to disable build time tests.
* Look for 24.x upstream releases only in debian/watch .
* Update Standards-Version to 3.9.5 .
2014-02-14 - Adam Conrad <adconrad@ubuntu.com>
mozjs24 (24.2.0-0ubuntu2) trusty; urgency=medium
* Drop debian/docs, which references files we no longer ship.
2014-02-11 - Tim Lunn <tim@feathertop.org>
mozjs24 (24.2.0-0ubuntu1) trusty; urgency=medium
[ Tim Lunn ]
* New upstream release (LP: #1279175)
* Bump packaging to mozjs24
* debian/rules:
- Disable intl-api
* debian/control:
- Bump build-dep on libnspr4-dev (>= 2:4.9.2)
* debian/patches/fix-soname.patch: Refreshed
* debian/watch: added
[ Dmitry Shachnev ]
* Update package descriptions.
* Make all packages except dbg ones Priority: optional.
* debian/copyright: Upgrade to 1.0 format, add python-which license,
remove unused MPL-1.1 license.
2014-01-03 - Colin Watson <cjwatson@ubuntu.com>
mozjs17 (17.0.0-1ubuntu1) trusty; urgency=medium
* Apply openSUSE patch to add arm64 support.
2013-09-18 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
mozjs17 (17.0.0-1) unstable; urgency=low
* Initial release (closes: #709434).
* Update to debhelper level 9.
* Convert to multi-arch.
* Fix copyright .
2013-05-25 - Rico Tzschichholz <ricotz@ubuntu.com>
mozjs17 (17.0.0-0ubuntu1) saucy; urgency=low
* New upstream release (LP: #1113166)
- Should noticably improve GNOME Shell performance by fixing
memory leaks and avoiding garbage collector deadlocks
- A separate source package is used because some rdepends like couchdb
won't be ready for this version any time soon
* Adjust packaging to new firefox versioned releases
* Drop .symbols files
* Add -dbg package
* debian/patches:
- Dropped all existing patches, they are included in new version
- fix-soname.patch, added to correct soname for shared library
* debian/rules:
- enable parallel build
- move shared library and create symlinks for standard soname versioning

See Also

Package Description
libmozjs-24-dev_24.2.0-2_amd64.deb Spidermonkey JavaScript library - development headers
libmozjs185-1.0_1.8.5-1.0.0+dfsg-4.3_amd64.deb Spidermonkey javascript engine
libmozjs185-dev_1.8.5-1.0.0+dfsg-4.3_amd64.deb Spidermonkey javascript library - development headers
libmp3-info-perl_1.24-1_all.deb Perl MP3::Info - Manipulate / fetch info from MP3 audio files
libmp3-tag-perl_1.13-1_all.deb Module for reading tags of MP3 audio files
libmp3lame-dev_3.99.5+repack1-7+deb8u2_amd64.deb MP3 encoding library (development)
libmp3lame-ocaml-dev_0.3.2-1+b1_amd64.deb OCaml interface to the lame library -- developpement files
libmp3lame-ocaml_0.3.2-1+b1_amd64.deb OCaml interface to the lame library -- runtime files
libmp3lame0_3.99.5+repack1-7+deb8u2_amd64.deb MP3 encoding library
libmp3spi-java_1.9.5-1_all.deb interface to support MP3 (MPEG 1/2/2.5 Layer 1/2/3) audio format
libmp3splt-dev_0.7.2-2.1_amd64.deb development files for libmp3splt0
libmp3splt0-mp3_0.7.2-2.1_amd64.deb MP3 plugin for mp3splt
libmp3splt0-ogg_0.7.2-2.1_amd64.deb Ogg Vorbis plugin for mp3splt
libmp3splt0_0.7.2-2.1_amd64.deb library for splitting MP3 and Ogg Vorbis files
libmp4-info-perl_1.13-1_all.deb Fetch info from MPEG-4 files
Advertisement
Advertisement