libmodule-versions-report-perl_1.06-1_all.deb


Advertisement

Description

libmodule-versions-report-perl - Report versions of all modules in memory

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libmodule-versions-report-perl
Package version 1.06
Package release 1
Package architecture all
Package type deb
Installed size 68 B
Download size 9.84 KB
Official Mirror ftp.br.debian.org
The author says: "I often get email from someone reporting a bug in a
module I've written. I email back, asking what version of the module
it is, what version of Perl on what OS, and sometimes what version of
some relevant third library (like XML::Parser). They reply, saying
"Perl5". I say "I need the exact version, as reported by 'perl -v'".
They tell me. And I say "I, uh, also asked about the version of my
module and XML::Parser [or whatever]". They say "Oh yeah. It is 2.27".
"Is that my module or XML::Parser?" "XML::Parser." "OK, and what
about my module's version?" "Oh yeah. That's 3.11." By this time,
days have passed, and what should have been a simple operation --
reporting the version of Perl and relevant modules, has been
needlessly complicated".
This module is for simplifying that task. If you add "use
Module::Versions::Report;" to a program (especially handy if your
program is one that demonstrates a bug in some module), then when the
program has finished running, you well get a report detailing all the
modules in memory, and noting the version of each (for modules that
defined a $VERSION, at least).

Alternatives

Package Version Architecture Repository
libmodule-versions-report-perl_1.06-1_all.deb 1.06 all Debian Main
libmodule-versions-report-perl - - -

Requires

Name Value
perl >= 5.6.0-16

Download

Type URL
Binary Package libmodule-versions-report-perl_1.06-1_all.deb
Source Package libmodule-versions-report-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-versions-report-perl deb package:
    # sudo apt-get install libmodule-versions-report-perl

Files

Path
/usr/share/doc/libmodule-versions-report-perl/changelog.Debian.gz
/usr/share/doc/libmodule-versions-report-perl/changelog.gz
/usr/share/doc/libmodule-versions-report-perl/copyright
/usr/share/man/man3/Module::Versions::Report.3pm.gz
/usr/share/perl5/Module/Versions/Report.pm

Changelog

2008-10-25 - Ansgar Burchardt <ansgar@43-1.org>
libmodule-versions-report-perl (1.06-1) unstable; urgency=low
[ Ansgar Burchardt ]
* New upstream release.
* Add myself to Uploaders.
* Convert debian/copyright to proposed machine-readable format.
Copyright holders for debian/* are taken from the changelog.
[ gregor herrmann ]
* debian/rules: use the group's default template.
2008-06-14 - gregor herrmann <gregoa@debian.org>
libmodule-versions-report-perl (1.05-1) unstable; urgency=low
* New upstream release.
* debian/watch: extended regexp for matching upstream releases.
* Set Standards-Version to 3.8.0 (no changes).
* Add /me to Uploaders.
* Use ${perl:Depends} in Depends instead of hard-coding the perl version.
* debian/copyright: use author-independent upstream source location.
2008-06-07 - Damyan Ivanov <dmn@debian.org>
libmodule-versions-report-perl (1.04-1) unstable; urgency=low
* New upstream release
* debhelper 7
+ debian/rules replaced with a three-liner
+ Build-Depends: debhelper (>=7)
+ compatibility level 7
* do not ship README that is the same as the POD
* add myself to Uploaders
2008-01-09 - Roberto C. Sanchez <roberto@connexer.com>
libmodule-versions-report-perl (1.03-2) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Removed: XS-
Vcs-Svn fields.
* debian/rules: delete /usr/lib/perl5 only if it exists.
[ Jose Luis Rivas ]
* Typo fixed by René Mayorga (Closes: #439275)
* debian/rules: `touch $@' instead of `touch *-stamp'
* debian/copyright: fixed formatting
* debian/watch: now is dist-based.
[ Roberto C. Sanchez ]
* Update to debhelper compatibility level 6.
* Update to Standards-Version 3.7.3 (no changes).
2007-05-22 - Niko Tyni <ntyni@iki.fi>
libmodule-versions-report-perl (1.03-1) unstable; urgency=low
* New upstream release.
* Update watch file.
2006-12-05 - Niko Tyni <ntyni@iki.fi>
libmodule-versions-report-perl (1.02-4) unstable; urgency=low
* New maintainer.
* Upgrade to debhelper compatibility level 5.
* Update debian/copyright.
2006-10-16 - Stephen Quinney <sjq@debian.org>
libmodule-versions-report-perl (1.02-3) unstable; urgency=low
* debian/control:
- Switched to my debian.org email address
- Moved debhelper to Build-Depends
2005-06-11 - Stephen Quinney <sjq@debian.org>
libmodule-versions-report-perl (1.02-2) unstable; urgency=low
* debian/watch - Updated URL so lookups no longer randomly fail.
2004-07-02 - Stephen Quinney <sjq@debian.org>
libmodule-versions-report-perl (1.02-1) unstable; urgency=low
*  Inital release, closes: #256647.

See Also

Package Description
libmodule-want-perl_0.6-1_all.deb module to check @INC only once for wanted modules
libmoe-dev_1.5.8-1_amd64.deb library to handle multiple octets character encoding scheme (devel files)
libmoe1.5_1.5.8-1_amd64.deb library to handle multiple octets character encoding scheme
libmojo-server-fastcgi-perl_0.41-1_all.deb Mojolicious FastCGI Server
libmojolicious-perl_5.54+dfsg-1_all.deb simple, yet powerful, Web Application Framework
libmojolicious-plugin-authentication-perl_1.26-1_all.deb module to make authentication a bit easier for Mojolicious
libmojolicious-plugin-authorization-perl_1.0302-1_all.deb module to make authorization a bit easier for Mojolicious
libmojolicious-plugin-basicauth-perl_0.08-1_all.deb basic HTTP auth helper for Mojolicious
libmojolicious-plugin-bcrypt-perl_0.14-1_all.deb module to bcrypt passwords for Mojolicious
libmojolicious-plugin-cgi-perl_0.12-1_all.deb Mojolicious plugin to run CGI scripts
libmojolicious-plugin-i18n-perl_1.30-1_all.deb internationalization plugin for Mojolicious 3.x and higher
libmojolicious-plugin-mailexception-perl_0.19-1_all.deb Mojolicious plugin to send crash information by email
libmojomojo-perl_1.10+dfsg1-4_all.deb wiki- and blog-inspired content management system
libmondrian-java-doc_3.4.1-1_all.deb OLAP server written in Java - documentation
libmondrian-java_3.4.1-1_all.deb OLAP server written in Java
Advertisement
Advertisement