libmodule-cpanfile-perl_1.1000-1_all.deb


Advertisement

Description

libmodule-cpanfile-perl - format for describing CPAN dependencies of Perl applications

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libmodule-cpanfile-perl
Package version 1.1000
Package release 1
Package architecture all
Package type deb
Installed size 99 B
Download size 28.19 KB
Official Mirror ftp.br.debian.org
Module::CPANfile is a tool to handle cpanfile format to load application
specific dependencies, not just for CPAN distributions.
`cpanfile` describes CPAN dependencies required to execute associated Perl
code.
Place the `cpanfile` in the root of the directory containing the associated
code. For instance, in a Catalyst application, place the `cpanfile` in the
same directory as `myapp.conf`.
Tools supporting `cpanfile` format (e.g. cpanm and carton) will automatically
detect the file and install dependencies for the code to run.

Alternatives

Package Version Architecture Repository
libmodule-cpanfile-perl_1.1000-1_all.deb 1.1000 all Debian Main
libmodule-cpanfile-perl - - -

Requires

Name Value
libcpan-meta-perl >= 2.120910
perl >= 5.17.1
perl -

Download

Type URL
Binary Package libmodule-cpanfile-perl_1.1000-1_all.deb
Source Package libmodule-cpanfile-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-cpanfile-perl deb package:
    # sudo apt-get install libmodule-cpanfile-perl

Files

Path
/usr/bin/cpanfile-dump
/usr/bin/mymeta-cpanfile
/usr/share/doc/libmodule-cpanfile-perl/changelog.Debian.gz
/usr/share/doc/libmodule-cpanfile-perl/changelog.gz
/usr/share/doc/libmodule-cpanfile-perl/copyright
/usr/share/man/man1/cpanfile-dump.1p.gz
/usr/share/man/man1/mymeta-cpanfile.1p.gz
/usr/share/man/man3/Module::CPANfile.3pm.gz
/usr/share/man/man3/cpanfile-faq.3pm.gz
/usr/share/man/man3/cpanfile.3pm.gz
/usr/share/perl5/cpanfile-faq.pod
/usr/share/perl5/cpanfile.pod
/usr/share/perl5/Module/CPANfile.pm
/usr/share/perl5/Module/CPANfile/Environment.pm
/usr/share/perl5/Module/CPANfile/Prereq.pm
/usr/share/perl5/Module/CPANfile/Prereqs.pm
/usr/share/perl5/Module/CPANfile/Requirement.pm

Changelog

2014-09-27 - gregor herrmann <gregoa@debian.org>
libmodule-cpanfile-perl (1.1000-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Imported upstream version 1.1000
* Update copyright years.
* Mark package as autopkgtest-able.
* Mention module name in long description.
* Declare compliance with Debian Policy 3.9.6.
2013-09-17 - gregor herrmann <gregoa@debian.org>
libmodule-cpanfile-perl (1.0002-1) unstable; urgency=low
* New upstream release.
* Switch alternative (build) dependencies. Perl 5.18 has arrived in
unstable.
2013-08-09 - gregor herrmann <gregoa@debian.org>
libmodule-cpanfile-perl (1.0001-1) unstable; urgency=low
* New upstream release.
2013-07-29 - gregor herrmann <gregoa@debian.org>
libmodule-cpanfile-perl (0.9036-2) unstable; urgency=low
* Fix version of libcpan-meta-perl (build) dependency and drop bogus
lintian overrides. Thanks to Niko Tyni for catching this mistake.
(Closes: #718266)
2013-07-25 - gregor herrmann <gregoa@debian.org>
libmodule-cpanfile-perl (0.9036-1) unstable; urgency=low
* New upstream release.
2013-07-24 - gregor herrmann <gregoa@debian.org>
libmodule-cpanfile-perl (0.9034-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update years of packaging and upstream copyright.
* Update (build) dependencies.
* Set Standards-Version to 3.9.4 (no further changes).
* Add lintian override for slightly twisted dependency.
2012-05-05 - gregor herrmann <gregoa@debian.org>
libmodule-cpanfile-perl (0.9007-1) unstable; urgency=low
* Initial release (closes: #671656 ).

See Also

Package Description
libmodule-cpants-analyse-perl_0.95-1_all.deb Perl module to generate Kwalitee ratings for a distribution
libmodule-depends-perl_0.16-1_all.deb Perl module to identify the dependencies of a distribution
libmodule-extract-perl_0.01-2_all.deb base class for working with Perl distributions
libmodule-extract-use-perl_1.04-1_all.deb Perl module to extract which modules some code uses
libmodule-extractuse-perl_0.33-1_all.deb Perl module to find out modules used by the specified Perl source
libmodule-faker-perl_0.017-1_all.deb module to build fake dists for testing CPAN tools
libmodule-find-perl_0.12-1_all.deb module to find and use installed Perl modules
libmodule-implementation-perl_0.09-1_all.deb module for loading one of several alternate implementations of a module
libmodule-info-perl_0.35-1_all.deb Perl module providing information about Perl modules
libmodule-inspector-perl_1.05-2_all.deb integrated API for inspecting Perl distributions
libmodule-install-authorrequires-perl_0.02-1_all.deb declare author-only dependencies
libmodule-install-authortests-perl_0.002-1_all.deb designate tests only run by module authors
libmodule-install-autolicense-perl_0.08-1_all.deb automagically generate LICENSE files
libmodule-install-automanifest-perl_0.003-2_all.deb generate MANIFEST automatically
libmodule-install-contributors-perl_0.001-1_all.deb add an "x_contributors" section to your META.yml
Advertisement
Advertisement