libmemcachedutil2_1.0.18-4_amd64.deb


Advertisement

Description

libmemcachedutil2 - library implementing connection pooling for libmemcached

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libmemcachedutil2
Package version 1.0.18
Package release 4
Package architecture amd64
Package type deb
Installed size 80 B
Download size 21.80 KB
Official Mirror ftp.br.debian.org
libmemcached is a C and C++ client library to the memcached server
(http://memcached.org/). It has been designed to be light on memory
usage, thread safe, and provide full access to server side methods.
A few notes on its design:
* Synchronous and Asynchronous support.
* Access to large object support.
* Local replication.
* TCP and Unix Socket protocols.
* A half dozen or so different tuneable hash algorithms.
* Implementations of the new cas, replace, and append operators.
* Man pages written up on entire API.
* Implements both modulo and consistent hashing solutions.
* Tools to Manage your Memcached networks.
This package provides the libmemcachedutil library.

Alternatives

Package Version Architecture Repository
libmemcachedutil2_1.0.18-4_i386.deb 1.0.18 i386 Debian Main
libmemcachedutil2 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libmemcached11 -
libstdc++6 >= 4.1.1
multiarch-support -

Download

Type URL
Binary Package libmemcachedutil2_1.0.18-4_amd64.deb
Source Package libmemcached

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmemcachedutil2 deb package:
    # sudo apt-get install libmemcachedutil2

Files

Path
/usr/lib/x86_64-linux-gnu/libmemcachedutil.so.2
/usr/lib/x86_64-linux-gnu/libmemcachedutil.so.2.0.0
/usr/share/doc/libmemcachedutil2/changelog.Debian.gz
/usr/share/doc/libmemcachedutil2/changelog.gz
/usr/share/doc/libmemcachedutil2/copyright
/usr/share/lintian/overrides/libmemcachedutil2

Changelog

2014-11-12 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-4) unstable; urgency=medium
* Add move-ax_confix_aux_dir.patch to move AC_CONFIG_AUX_DIR up a few lines
so autofoo can find it (Closes: #768688).
* Bump Standards-Version to 3.9.6.
* Update Vcs-Browser field.
* Move main license entry to top in d/copyright.
2014-03-19 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-3) unstable; urgency=low
* Upload to unstable.
2014-03-17 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-2) experimental; urgency=low
* Include c++11.patch to prevent relying on C++11 features in
reverse-dependencies (Closes: #740940,#740941,#740935).
2014-02-28 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.18-1) experimental; urgency=medium
* Imported Upstream version 1.0.18 (Closes: #724729,#688089).
* Move git packaging repository to alioth.
Update Vcs-* fields accordingly.
* Bump Standards-Version to 3.9.5.
* Check PGP detached signature for source tarball.
+ Add upstream signing key DA248813 in d/upstream-signing-key.pgp.
+ Add pgpsigurlmangle option to d/watch.
* Fix typos in long description, thanks to
Pascal De Vuyst (Closes: #732764).
* Update years in d/copyright.
* Make Build-Depends on automake unversioned.
* Make license short names in d/copyright conformant to machine readable
format 1.0:
+ BSD-TangentOrg to BSD-3-clause-TangentOrg
+ "Paul Hsieh derivative license" to Paul-Hsieh
+ "RSA Data Security License" to RSA-Data-Security
+ "Bob Jenkins License" to Bob-Jenkins
+ BSD-Sun to BSD-3-clause-Sun
+ BSD to BSD-3-clause
* Add lintian overrides for missing symbol files.
* Include debian/upstream-signing-key.pgp in the allowed binary files.
* Remove patches included in upstream:
+ autoconf_ax_memcached
+ gcc-4.8.patch
* Unfuzz patches:
+ fix_spelling.patch
+ hurd.patch
2013-06-17 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.17-2) experimental; urgency=low
* Add hurd.patch to fix build failures on GNU/Hurd, thanks to Pino Toscano
(Closes: #644657).
2013-06-12 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.17-1) experimental; urgency=low
[ Faidon Liambotis ]
* New upstream release.
- Fixes FTBFS on multiple architectures.
* Add patch autoconf_ax_memcached, fixing an upstream bug manifesting in the
absence of a memcached binary during the execution of the test suite.
* Add --with autoreconf to dh and build-depend on dh_autoreconf; necessary
for the above autoconf patch to work.
* Remove patch fix-for-gcc47.patch from source: not in series, applied
upstream.
[ Michael Fladischer ]
* Bump Standards version to 3.9.4.
* Add 'Multi-Arch: same' to -dbg package.
* Add patch m4_pthread, which fixes the flags for pthreads.
* Add patch gcc-4.8, fixing incompatible flags with gcc-4.8 (taken from
upstream BTS).
2013-02-13 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.16-1) experimental; urgency=low
* New upstream release.
* Update spelling patch.
* Remove conflicts on older versions of libmemcached and libhashkit
(Closes:700091).
* Update spelling patch.
* Install libhashkit2 manpages manually.
* Bump SONAME to 11 for libmemcached.
* Manually install libmemcached manpages.
* Update naming conflict resolution to cope with new manpages.
* Drop libmemcachedprotocol package as it is broken and no longer maintained
in upstream.
* Manually install libmemcached-tools manpages.
2012-05-30 - Michael Fladischer <FladischerMichael@fladi.at>
libmemcached (1.0.8-1) unstable; urgency=low
* New upstream release.
* Clean up files to allow two builds in a row.
* Fix duplicate Copyright fields.
* Switch to dh format 9:
+ Enable hardening.
+ Enable mutli-arch.

See Also

Package Description
libmemoize-expirelru-perl_0.55-1_all.deb Expiry plug-in for Memoize that adds LRU cache expiration
libmemoize-memcached-perl_0.03-2_all.deb implementation of Memoize using memcached for storage
libmemphis-0.2-0_0.2.3-2_amd64.deb A map-rendering library for OpenStreetMap
libmemphis-0.2-dev_0.2.3-2_amd64.deb A map-rendering library for OpenStreetMap (Developpement files)
libmemphis-doc_0.2.3-2_all.deb A map-rendering library for OpenStreetMap (Documentation)
libmenhir-ocaml-dev_20140422.dfsg-1_amd64.deb Menhir library for OCaml
libmenu-cache-bin_1.0.0-1_amd64.deb LXDE implementation of the freedesktop Menu's cache (libexec)
libmenu-cache-dev_1.0.0-1_amd64.deb LXDE implementation of the freedesktop Menu's cache (devel)
libmenu-cache-doc_1.0.0-1_all.deb LXDE implementation of the freedesktop Menu's cache (docs)
libmenu-cache3_1.0.0-1_amd64.deb LXDE implementation of the freedesktop Menu's cache
libmerb-core-ruby1.8_1.1.3+dfsg-2_all.deb Transitional package for ruby-merb-core
libmerb-core-ruby_1.1.3+dfsg-2_all.deb Transitional package for ruby-merb-core
libmerb-helpers-ruby1.8_1.1.3-1_all.deb Transitional package for ruby-merb-helpers
libmerb-helpers-ruby_1.1.3-1_all.deb Transitional package for ruby-merb-helpers
libmercator-0.3-3_0.3.2-1.1_amd64.deb WorldForge terrain library
Advertisement
Advertisement