libm4ri-dev_20140914-2_amd64.deb


Advertisement

Description

libm4ri-dev - Method of the Four Russians Inversion library, development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libm4ri-dev
Package version 20140914
Package release 2
Package architecture amd64
Package type deb
Installed size 453 B
Download size 104.53 KB
Official Mirror ftp.br.debian.org
M4RI is a library for fast arithmetic with dense matrices over F2.
The name M4RI comes from the first implemented algorithm: The "Method
of the Four Russians" inversion algorithm. This algorithm in turn is
named after the "Method of the Four Russians" multiplication
algorithm which is probably better referred to as Kronrod's method.
This package contains development files for libm4ri.

Alternatives

Package Version Architecture Repository
libm4ri-dev_20140914-2_i386.deb 20140914 i386 Debian Main
libm4ri-dev - - -

Requires

Name Value
libm4ri-0.0.20140914 = 20140914-2

Download

Type URL
Binary Package libm4ri-dev_20140914-2_amd64.deb
Source Package libm4ri

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libm4ri-dev deb package:
    # sudo apt-get install libm4ri-dev

Files

Path
/usr/include/m4ri/brilliantrussian.h
/usr/include/m4ri/debug_dump.h
/usr/include/m4ri/djb.h
/usr/include/m4ri/echelonform.h
/usr/include/m4ri/graycode.h
/usr/include/m4ri/io.h
/usr/include/m4ri/m4ri.h
/usr/include/m4ri/m4ri_config.h
/usr/include/m4ri/misc.h
/usr/include/m4ri/mmc.h
/usr/include/m4ri/mp.h
/usr/include/m4ri/mzd.h
/usr/include/m4ri/mzp.h
/usr/include/m4ri/parity.h
/usr/include/m4ri/ple.h
/usr/include/m4ri/ple_russian.h
/usr/include/m4ri/ple_russian_template.h
/usr/include/m4ri/solve.h
/usr/include/m4ri/strassen.h
/usr/include/m4ri/triangular.h
/usr/include/m4ri/triangular_russian.h
/usr/include/m4ri/xor.h
/usr/include/m4ri/xor_template.h
/usr/lib/x86_64-linux-gnu/libm4ri.a
/usr/lib/x86_64-linux-gnu/libm4ri.so
/usr/lib/x86_64-linux-gnu/pkgconfig/m4ri.pc
/usr/share/doc/libm4ri-dev/changelog.Debian.gz
/usr/share/doc/libm4ri-dev/copyright
/usr/share/lintian/overrides/libm4ri-dev

Changelog

2014-10-18 - Cédric Boutillier <boutil@debian.org>
libm4ri (20140914-2) unstable; urgency=medium
[ Cédric Boutillier ]
* Re-add changelog entry for 20130416-6, accidentally removed in previous
upload.
* Fix attribution of changes in previous changelog entry
[ Andreas Tille ]
* Use "" as YAML value delimiter in debian/upstream/metadata
2014-10-15 - Cédric Boutillier <boutil@debian.org>
libm4ri (20140914-1) unstable; urgency=medium
[ Martin Albrecht ]
* Imported Upstream version 20140914
* debian/watch: update URL
* Update package name of libraries to new soname
* Bump Standards-Version to 3.9.6 (no changes needed)
* Remove paragraph in copyright file for file not shipped anymore
* debian/patches:
+ drop dont_disable_sse2_for_opteron.patch, applied upstream
+ add fix_pkgconfig_file.patch, to not include bad directives in
pkg-config file
* Remove gbp configuration; now using released tarballs imported with uscan
instead of bitbucket repository as upstream source
* Move upstream data to debian/upstream/metadata
* Automatically read upstream version in debian/rules and reuse it to guess
the name of the -dbg package
2013-11-21 - Cédric Boutillier <boutil@debian.org>
libm4ri (20130416-6) unstable; urgency=low
* Build-Depend on autoconf instead of autoconf1.10 (Closes: #724406)
* Bump Standards-Version to 3.9.5 (no changes needed)
2013-09-16 - Cédric Boutillier <boutil@debian.org>
libm4ri (20130416-5) unstable; urgency=low
* Disable openMP on all architectures for now, as recommended by upstream.
2013-09-16 - Cédric Boutillier <boutil@debian.org>
libm4ri (20130416-4) unstable; urgency=low
* Deactivate openMP on sparc to avoid randomly failing tests. 
2013-06-17 - Cédric Boutillier <boutil@debian.org>
libm4ri (20130416-3) unstable; urgency=low
* Upload to unstable.
2013-04-02 - Cédric Boutillier <boutil@debian.org>
libm4ri (20130416-2) experimental; urgency=low
* debian/rules: use DEB_HOST_ARCH_CPU instead of DEB_BUILD_ARCH_CPU
in test for activation of SSE2 instructions.
2013-03-28 - Cédric Boutillier <boutil@debian.org>
libm4ri (20130416-1) experimental; urgency=low
* New upstream version 
* debian/control: use anonscm.debian.org instead of git.debian.org
for Vcs-* fields
* debian/patches:
+ add dont_disable_sse2_for_opteron.patch: enable sse2 for non Intel CPUs
+ add disable_sse3.patch patches: disable sse3 unconditionally
+ remove (unapplied) upstream-versioning-change patch (not needed anymore)
* debian/rules : do not disable sse2 for x86_64 CPUs (Closes: #702287)
* add debian/upstream file
2013-01-27 - Cédric Boutillier <boutil@debian.org>
libm4ri (20120613-2) experimental; urgency=low
* Bump Standards-Version: to 3.9.4 (no changes needed)
* Add Vcs-* fields 
* Add pkg-config and libpng-dev to Build-Depends (Closes: #699071)
* Add --enable-openmp flag to add OpenMP support for parallel multiplication
and elimination
* Build a libm4ri-0.0.20120613-dbg package
+ override lintian message about the absence of upstream changelog
* debian/control: reformat using cme fix dpkg-control

See Also

Package Description
libm4rie-0.0.20140914_20140914-1_amd64.deb extended Method of the Four Russians Inversion library, shared library
libm4rie-dev_20140914-1_amd64.deb extended Method of the Four Russians Inversion library, development files
libmaa-dev_1.3.2-3_amd64.deb maa programming library, development files
libmaa3_1.3.2-3_amd64.deb maa programming library
libmac-widgets-doc_0.10.0+svn416-dfsg1-1_all.deb documentation for libmac-widgets-java
libmac-widgets-java_0.10.0+svn416-dfsg1-1_all.deb collection of Mac style widgets written in Java
libmad-ocaml-dev_0.4.4-1+b2_amd64.deb OCaml bindings for the MAD library (Development package)
libmad-ocaml_0.4.4-1+b2_amd64.deb OCaml bindings for the MAD library (Runtime library)
libmad0-dev_0.15.1b-8_amd64.deb MPEG audio decoder development library
libmad0_0.15.1b-8_amd64.deb MPEG audio decoder library
libmadlib-dev_1.3.0-2.1_amd64.deb mesh adaptation library
libmadlib_1.3.0-2.1_amd64.deb mesh adaptation library
libmagic-dev_5.22+15-2+deb8u3_amd64.deb File type determination library using "magic" numbers (development)
libmagic-ocaml-dev_0.7.3-5+b4_amd64.deb OCaml bindings for the File type determination library
libmagic-ocaml_0.7.3-5+b4_amd64.deb OCaml bindings for the File type determination library
Advertisement
Advertisement