liblzo2-dev_2.08-1.2_amd64.deb


Advertisement

Description

liblzo2-dev - data compression library (development files)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name liblzo2-dev
Package version 2.08
Package release 1.2
Package architecture amd64
Package type deb
Installed size 780 B
Download size 108.96 KB
Official Mirror ftp.br.debian.org
LZO is a portable, lossless data compression library.
This package contains the header files and static libraries for the
LZO data compression library.

Alternatives

Package Version Architecture Repository
liblzo2-dev_2.08-1.2_i386.deb 2.08 i386 Debian Main
liblzo2-dev - - -

Requires

Name Value
libc6-dev -
liblzo2-2 = 2.08-1.2

Replaces

Name Value
liblzo-dev -

Download

Type URL
Binary Package liblzo2-dev_2.08-1.2_amd64.deb
Source Package lzo2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblzo2-dev deb package:
    # sudo apt-get install liblzo2-dev

Files

Path
/usr/include/lzo/lzo1.h
/usr/include/lzo/lzo1a.h
/usr/include/lzo/lzo1b.h
/usr/include/lzo/lzo1c.h
/usr/include/lzo/lzo1f.h
/usr/include/lzo/lzo1x.h
/usr/include/lzo/lzo1y.h
/usr/include/lzo/lzo1z.h
/usr/include/lzo/lzo2a.h
/usr/include/lzo/lzo_asm.h
/usr/include/lzo/lzoconf.h
/usr/include/lzo/lzodefs.h
/usr/include/lzo/lzoutil.h
/usr/lib/x86_64-linux-gnu/liblzo2.a
/usr/lib/x86_64-linux-gnu/liblzo2.so
/usr/share/doc/liblzo2-dev/AUTHORS
/usr/share/doc/liblzo2-dev/LZO.FAQ.gz
/usr/share/doc/liblzo2-dev/LZO.TXT.gz
/usr/share/doc/liblzo2-dev/LZOAPI.TXT.gz
/usr/share/doc/liblzo2-dev/THANKS
/usr/share/doc/liblzo2-dev/changelog.Debian.gz
/usr/share/doc/liblzo2-dev/changelog.gz
/usr/share/doc/liblzo2-dev/copyright
/usr/share/doc/liblzo2-dev/examples/dict.c.gz
/usr/share/doc/liblzo2-dev/examples/lzopack.c.gz
/usr/share/doc/liblzo2-dev/examples/overlap.c.gz
/usr/share/doc/liblzo2-dev/examples/portab.h
/usr/share/doc/liblzo2-dev/examples/portab_a.h
/usr/share/doc/liblzo2-dev/examples/precomp.c.gz
/usr/share/doc/liblzo2-dev/examples/precomp2.c.gz
/usr/share/doc/liblzo2-dev/examples/simple.c.gz
/usr/share/lzo/minilzo/README.LZO
/usr/share/lzo/minilzo/lzoconf.h
/usr/share/lzo/minilzo/lzodefs.h
/usr/share/lzo/minilzo/minilzo.c
/usr/share/lzo/minilzo/minilzo.h

Changelog

2014-12-20 - Simon McVittie <smcv@debian.org>
lzo2 (2.08-1.2) unstable; urgency=low
* Non-maintainer upload.
* Adjust patch from previous upload so the "modern C" code path still
defines some typedefs: lzo_memops_TU1p is a pointer to unsigned byte
(used by the byteswapping implementation on non-powerpc big-endian
architectures), and lzo_memops_TU2p and lzo_memops_TU4p
are pointers to unsigned 2- and 4-byte quantities (needed by the
powerpc assembler implementation). Together, these fix FTBFS on
big-endian platforms. (Closes: #773580)
2014-12-16 - Simon McVittie <smcv@debian.org>
lzo2 (2.08-1.1) unstable; urgency=low
* Non-maintainer upload.
* Replace liblzo's reinvention of memcpy() with calls to memcpy().
gcc already knows how to inline memcpy calls with constant n,
and also gets the alignment constraints right, avoiding incorrect
unaligned accesses on armel (Closes: #757037)
2014-07-14 - Peter Eisentraut <petere@debian.org>
lzo2 (2.08-1) unstable; urgency=low
* New upstream release (closes: #752861) (CVE-2014-4607)
* Update standards version
* Add autotools-dev to build dependencies (closes: #750622)
2013-08-26 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
lzo2 (2.06-1.2) unstable; urgency=low
* Non-maintainer upload.
* Correct /usr/lib/liblzo2.so symlink (Closes: #720749)
2013-08-16 - Dmitrijs Ledkovs <xnox@debian.org>
lzo2 (2.06-1.1) unstable; urgency=low
* Non-maintainer upload to unbreak btrfs/installer.
* Install libzo2 library into /lib, because btrfs user space now depends
on this library and thus is needed before /usr might be
mounted. (Closes: #709422)
* Create libzo2-2-udeb, for the debian-installer to use btrfs at install
time.
* Piggy-back release-goal, mark dev package Multi-Arch (Closes: #681840)
2011-11-10 - Peter Eisentraut <petere@debian.org>
lzo2 (2.06-1) unstable; urgency=low
* New upstream release
* Fixed lintian warning brace-expansion-in-debhelper-config-file
2011-08-01 - Peter Eisentraut <petere@debian.org>
lzo2 (2.05-2) unstable; urgency=low
* Converted to multiarch
* Changed priority to optional to match override
2011-07-04 - Peter Eisentraut <petere@debian.org>
lzo2 (2.05-1) unstable; urgency=low
* New upstream release
* Updated standards version
* Removed *.la file (closes: #622467)
2011-02-19 - Peter Eisentraut <petere@debian.org>
lzo2 (2.04-1) unstable; urgency=low
* New upstream release (closes: #610732)
* Updated standards version
* Changed to debhelper level 8
2009-11-06 - Peter Eisentraut <petere@debian.org>
lzo2 (2.03-2) unstable; urgency=low
* Changed source format to 3.0 (quilt)
* Added ${misc:Depends} to all packages
* Set a version on the dependency of liblzo2-dev to liblzo2-2
* Removed redundant section and priority fields
* Pointed copyright to non-symlinked version of GPL file
* Updated standards version
* Really changed to debhelper level 6

See Also

Package Description
libm17n-0_1.6.4-3_amd64.deb multilingual text processing library - runtime
libm17n-dev_1.6.4-3_amd64.deb multilingual text processing library - development
libm17n-im-config-dev_0.9.0-3_amd64.deb input method configuration library for m17n-lib - development
libm17n-im-config0_0.9.0-3_amd64.deb input method configuration library for m17n-lib - runtime
libm4ri-0.0.20140914_20140914-2_amd64.deb Method of the Four Russians Inversion library, shared library
libm4ri-dev_20140914-2_amd64.deb Method of the Four Russians Inversion library, development files
libm4rie-0.0.20140914_20140914-1_amd64.deb extended Method of the Four Russians Inversion library, shared library
libm4rie-dev_20140914-1_amd64.deb extended Method of the Four Russians Inversion library, development files
libmaa-dev_1.3.2-3_amd64.deb maa programming library, development files
libmaa3_1.3.2-3_amd64.deb maa programming library
libmac-widgets-doc_0.10.0+svn416-dfsg1-1_all.deb documentation for libmac-widgets-java
libmac-widgets-java_0.10.0+svn416-dfsg1-1_all.deb collection of Mac style widgets written in Java
libmad-ocaml-dev_0.4.4-1+b2_amd64.deb OCaml bindings for the MAD library (Development package)
libmad-ocaml_0.4.4-1+b2_amd64.deb OCaml bindings for the MAD library (Runtime library)
libmad0-dev_0.15.1b-8+deb8u1_amd64.deb MPEG audio decoder development library
Advertisement
Advertisement