liblz4-dev_0.0~r122-2_amd64.deb


Advertisement

Description

liblz4-dev - Fast LZ compression algorithm library - development files

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: liblz4-dev
Package version: 0.0~r122
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 102 B
Download size: 22.55 KB
Official Mirror: ftp.br.debian.org
LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems. This package contains files that are needed to build applications.

Alternatives

    Download

    Source package: lz4

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liblz4-dev deb package:
      # sudo apt-get install liblz4-dev

    Files

    • /usr/include/lz4.h
    • /usr/include/lz4hc.h
    • /usr/lib/x86_64-linux-gnu/liblz4.a
    • /usr/lib/x86_64-linux-gnu/liblz4.so
    • /usr/lib/x86_64-linux-gnu/pkgconfig/liblz4.pc
    • /usr/share/doc/liblz4-dev/changelog.Debian.gz
    • /usr/share/doc/liblz4-dev/copyright
    • /usr/share/doc/liblz4-dev/lz4_format_description.txt.gz

    Changelog

    2014-09-17 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r122-2) unstable; urgency=medium * Install pkgconfig file into liblz4-dev. (Closes: #761906)

    2014-09-17 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r122-1) unstable; urgency=high * Snapshot, taken from the trunk (r122). * Fix test on s390x. (Closes: #757581) Add patches/0001-Add-support-s390x-architecture.patch. * Remove patches. - add-support-kfreebsd.patch, add-support-hurd.patch and Add-LDFLAGS.patch were applied to upstream. - Makefile of upstream was updated. Remove 0001-Remove-test-32-from-test-target.patch. * Update patches/0001-Disable-valgrind.patch. * Update debian/rules. - Re-enable test on s390x. * Update symbols file.

    2014-07-29 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r119-2) unstable; urgency=medium * Disable test on s390x and sparc. (Closes: #755170)

    2014-07-15 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r119-1) unstable; urgency=medium * Snapshot, taken from the trunk (r119) (Closes: #751256). * The r119 fixed CVE-2014-4715, and r118 fixed CVE-2014-4611. * Disable valgrind test. Add patches/0001-Disable-valgrind.patch. * Disable test with -m32 option. Add patches/0001-Remove-test-32-from-test-target.patch. * Update liblz4-1.symbols.

    2014-06-09 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r117-1) unstable; urgency=medium * Snapshot, taken from the trunk (r117). * Remove patches/add-ldflags.patch and patches/fix-install.patch. * Update patches/add-support-kfreebsd.patch. * Add patches/add-support-hurd.patch (Closes: #749901). * Add patches/Remove-32bit-test-program-from-target.patch. * Add patches/Add-LDFLAGS.patch.

    2014-03-22 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r114-2) unstable; urgency=low * Update patches/add-support-kfreebsd.patch. Support programs.Makefile too.

    2014-03-22 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r114-1) unstable; urgency=low * Snapshot, taken from the trunk (r113). * Remove support-library-version.patch Applied to upstream. * Update add-ldflags.patch. * Add patches/fix-install.patch. Fix install library. * Update symbols file. * Add patches/add-support-kfreebsd.patch. Support install on kFreeBSD.

    2014-03-10 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r113-2) unstable; urgency=low * Update debian/control. - Add Conflict and Replaces field of libz4-1-dbg (Closes: #741003). - Update package description (Closes: #741001).

    2014-03-05 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r113-1) unstable; urgency=low * Snapshot, taken from the trunk (r113). * Update debian/rules. - Change build tool from cmake to GNU make. * Update debian/control. - cmake from Build-Depends - Update Standards-Version to 3.9.5 * Update symbols file. * Add patches/add-dlflags.patch. * Add patches/support-library-version.patch. * Remove old patches. * Change package name and install script name. * Add manpage of lz4.

    2013-12-25 - Nobuhiro Iwamatsu <iwamatsu@debian.org> lz4 (0.0~r109-1) unstable; urgency=low * Snapshot, taken from the trunk (r109).

    Advertisement
    Advertisement