liblwt-glib-ocaml-dev_2.4.3-4+b1_amd64.deb


Advertisement

Description

liblwt-glib-ocaml-dev - cooperative GLib bindings for OCaml

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name liblwt-glib-ocaml-dev
Package version 2.4.3
Package release 4+b1
Package architecture amd64
Package type deb
Installed size 45 B
Download size 16.98 KB
Official Mirror ftp.br.debian.org
Lwt is a library of cooperative threads implemented in monadic style.
With respect to preemptive threads, cooperative threads are not using
a scheduler to distribute processor time between threads. Instead of
this, each thread must tell the others that he wants to let them
work.
This package contains all the development stuff you need to use Lwt
with cooperative GLib in your programs.

Alternatives

Package Version Architecture Repository
liblwt-glib-ocaml-dev_2.4.3-4+b1_i386.deb 2.4.3 i386 Debian Main
liblwt-glib-ocaml-dev - - -

Requires

Name Value
liblwt-glib-ocaml-siny1 -
liblwt-ocaml-dev-6uih9 -
ocaml-nox-4.01.0 -

Provides

Name Value
liblwt-glib-ocaml-dev-siny1 -

Replaces

Name Value
liblwt-ocaml-dev <= 2.3.0

Download

Type URL
Binary Package liblwt-glib-ocaml-dev_2.4.3-4+b1_amd64.deb
Source Package lwt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblwt-glib-ocaml-dev deb package:
    # sudo apt-get install liblwt-glib-ocaml-dev

Files

Path
/usr/lib/ocaml/lwt/liblwt-glib_stubs.a
/usr/lib/ocaml/lwt/lwt-glib.a
/usr/lib/ocaml/lwt/lwt-glib.cmxa
/usr/lib/ocaml/lwt/lwt_glib.cmi
/usr/lib/ocaml/lwt/lwt_glib.cmx
/usr/lib/ocaml/lwt/lwt_glib.mli
/usr/share/doc/liblwt-glib-ocaml-dev/changelog.Debian.amd64.gz
/usr/share/doc/liblwt-glib-ocaml-dev/changelog.Debian.gz
/usr/share/doc/liblwt-glib-ocaml-dev/changelog.gz
/usr/share/doc/liblwt-glib-ocaml-dev/copyright
/var/lib/ocaml/lintian/liblwt-glib-ocaml-dev.info
/var/lib/ocaml/md5sums/liblwt-glib-ocaml-dev.md5sums

Changelog

2013-12-04 - Stéphane Glondu <glondu@debian.org>
lwt (2.4.3-4) unstable; urgency=low
* Upload to unstable
2013-11-09 - Stéphane Glondu <glondu@debian.org>
lwt (2.4.3-3) experimental; urgency=low
* debian/patches:
+ Add Unix.O_CLOEXEC flag to Lwt_unix (for OCaml >= 4.01)
2013-07-26 - Stéphane Glondu <glondu@debian.org>
lwt (2.4.3-2) experimental; urgency=low
* Compile with OCaml >= 4
* Update Vcs-*
2013-05-09 - Stéphane Glondu <glondu@debian.org>
lwt (2.4.3-1) unstable; urgency=low
* New upstream release
* Use format version 1.0 in debian/copyright
* Bump Standards-Version to 3.9.4
* Upload to unstable
2012-12-07 - Stéphane Glondu <glondu@debian.org>
lwt (2.4.2-1) experimental; urgency=low
* New upstream release
2011-12-31 - Stéphane Glondu <glondu@debian.org>
lwt (2.3.2-1) unstable; urgency=low
* New upstream release
- remove fix-a-race-condition-in-Lwt_io.patch (applied upstream)
- remove fix-data-corruption-in-Lwt_io.patch (applied upstream)
- add Remove-buggy-dependencies-causing-FTBFS-on-no-natdyn.patch
* Update debian/watch
2011-07-28 - Stéphane Glondu <glondu@debian.org>
lwt (2.3.1-1) unstable; urgency=low
* New upstream release
- patches removed because they were applied upstream:
Fix-FTBFS-on-hurd, Fix-link-order-in-library-detection-test
- new patches cherry-picked from upstream:
fix-a-race-condition-in-Lwt_io, fix-data-corruption-in-Lwt_io
2011-07-12 - Stéphane Glondu <glondu@debian.org>
lwt (2.3.0-3) unstable; urgency=low
* Fix link order in library detection test (fixes FTBFS on Ubuntu)
2011-05-27 - Nicolas Dandrimont <nicolas.dandrimont@crans.org>
lwt (2.3.0-2) unstable; urgency=low
* Fix FTBFS on Hurd due to use of PATH_MAX and HOSTNAME_MAX
2011-04-24 - Nicolas Dandrimont <nicolas.dandrimont@crans.org>
lwt (2.3.0-1) unstable; urgency=low
[ Stéphane Glondu ]
* New upstream release 2.2.1
- add dependency to libev-dev (Closes: #612768)
* Bump Standards-Version to 3.9.1
* Bump debhelper compatibility level to 8
[ Nicolas Dandrimont ]
* Update to upstream release 2.3.0
* Install the .cmxs and .cma files in the library packages
* Add package liblwt-ssl-ocaml (Cooperative OpenSSL bindings runtime)
* Install META in liblwt-ocaml (Closes: #587472)
* Bump Standards-Version to 3.9.2 (no changes)

See Also

Package Description
liblwt-glib-ocaml_2.4.3-4+b1_amd64.deb cooperative GLib bindings for OCaml (runtime)
liblwt-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative light-weight thread library for OCaml
liblwt-ocaml-doc_2.4.3-4_all.deb cooperative light-weight thread library (documentation)
liblwt-ocaml_2.4.3-4+b1_amd64.deb cooperative light-weight thread library for OCaml (runtime)
liblwt-ssl-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative OpenSSL bindings for OCaml
liblwt-ssl-ocaml_2.4.3-4+b1_amd64.deb cooperative OpenSSL bindings for OCaml (runtime)
liblz-dev_1.6-2_amd64.deb data compressor based on the LZMA algorithm (development)
liblz1_1.6-2_amd64.deb data compressor based on the LZMA algorithm (library)
liblz4-1_0.0~r122-2_amd64.deb Fast LZ compression algorithm library - runtime
liblz4-dev_0.0~r122-2_amd64.deb Fast LZ compression algorithm library - development files
liblz4-tool_0.0~r122-2_amd64.deb Fast LZ compression algorithm library - tool
liblzma-dev_5.1.1alpha+20120614-2+b3_amd64.deb XZ-format compression library - development files
liblzma-doc_5.1.1alpha+20120614-2_all.deb XZ-format compression library - API documentation
liblzma5_5.1.1alpha+20120614-2+b3_amd64.deb XZ-format compression library
liblzo2-2_2.08-1.2_amd64.deb data compression library
Advertisement
Advertisement