liblwp-protocol-socks-perl_1.7-1_all.deb


Advertisement

Description

liblwp-protocol-socks-perl - SOCKS proxy support for LWP

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name liblwp-protocol-socks-perl
Package version 1.7
Package release 1
Package architecture all
Package type deb
Installed size 65 B
Download size 12.21 KB
Official Mirror ftp.br.debian.org
LWP::Protocol::socks implements the SOCKS protocol for Perl WWW library. It
provides the essential hooks into the LWP system to add the capability to
setup a LWP::UserAgent to use a SOCKS proxy the same way as already possible
for a HTTP proxy.

Alternatives

Package Version Architecture Repository
liblwp-protocol-socks-perl_1.7-1_all.deb 1.7 all Debian Main
liblwp-protocol-socks-perl - - -

Requires

Name Value
libio-socket-socks-perl >= 0.2
libio-socket-ssl-perl -
liblwp-protocol-https-perl -
liburi-perl -
libwww-perl -
perl -

Download

Type URL
Binary Package liblwp-protocol-socks-perl_1.7-1_all.deb
Source Package liblwp-protocol-socks-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblwp-protocol-socks-perl deb package:
    # sudo apt-get install liblwp-protocol-socks-perl

Files

Path
/usr/share/doc/liblwp-protocol-socks-perl/changelog.Debian.gz
/usr/share/doc/liblwp-protocol-socks-perl/changelog.gz
/usr/share/doc/liblwp-protocol-socks-perl/copyright
/usr/share/man/man3/LWP::Protocol::socks.3pm.gz
/usr/share/man/man3/LWP::Protocol::socks4.3pm.gz
/usr/share/man/man3/URI::socks.3pm.gz
/usr/share/perl5/LWP/Protocol/socks.pm
/usr/share/perl5/LWP/Protocol/socks4.pm
/usr/share/perl5/URI/socks.pm
/usr/share/perl5/URI/socks4.pm

Changelog

2014-07-31 - gregor herrmann <gregoa@debian.org>
liblwp-protocol-socks-perl (1.7-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* New upstream release.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.5.
2012-02-16 - Fabrizio Regalli <fabreg@fabreg.it>
liblwp-protocol-socks-perl (1.6-1) unstable; urgency=low
* Imported Upstream version 1.6
* Add myself to Uploaders and Copyright
* Updated d/copyright with latest (.174) DEP5 format
* Added liblwp-protocol-https-perl in B-D-I and Depends 
2011-08-28 - gregor herrmann <gregoa@debian.org>
liblwp-protocol-socks-perl (1.5-1) unstable; urgency=low
[ Ansgar Burchardt ]
* Email change: Ansgar Burchardt -> ansgar@debian.org
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ gregor herrmann ]
* New upstream release.
* Bump versioned (build) dependency on libio-socket-socks-perl.
* Add /me to Uploaders.
* Update formatting in debian/copyright.
* Set Standards-Version to 3.9.2 (no further changes).
* Bump debhelper compatibility level to 8.
* Remove version from libio-socket-ssl-perl (build) dependency, already
satisfied in etch.
2010-07-24 - Ansgar Burchardt <ansgar@43-1.org>
liblwp-protocol-socks-perl (1.3-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ansgar Burchardt ]
* New upstream release.
* Add (build-)dep on liburi-perl for URI::Escape.
* Use tiny debian/rules.
* Use source format 3.0 (quilt).
* debian/copyright: Formatting changes for current DEP-5 proposal.
* Bump Standards-Version to 3.9.0.
* Add myself to Uploaders.
2009-04-14 - Pierre Neyron <pierre.neyron@free.fr>
liblwp-protocol-socks-perl (1.1-1) unstable; urgency=low
* Initial Release. (Closes: #517027)

See Also

Package Description
liblwp-useragent-determined-perl_1.07-1_all.deb LWP useragent that retries errors
liblwpx-paranoidagent-perl_1.10-5_all.deb a "paranoid" subclass of LWP::UserAgent
liblwres90_9.9.5.dfsg-9+deb8u15_amd64.deb Lightweight Resolver Library used by BIND
liblwt-glib-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative GLib bindings for OCaml
liblwt-glib-ocaml_2.4.3-4+b1_amd64.deb cooperative GLib bindings for OCaml (runtime)
liblwt-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative light-weight thread library for OCaml
liblwt-ocaml-doc_2.4.3-4_all.deb cooperative light-weight thread library (documentation)
liblwt-ocaml_2.4.3-4+b1_amd64.deb cooperative light-weight thread library for OCaml (runtime)
liblwt-ssl-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative OpenSSL bindings for OCaml
liblwt-ssl-ocaml_2.4.3-4+b1_amd64.deb cooperative OpenSSL bindings for OCaml (runtime)
liblz-dev_1.6-2_amd64.deb data compressor based on the LZMA algorithm (development)
liblz1_1.6-2_amd64.deb data compressor based on the LZMA algorithm (library)
liblz4-1_0.0~r122-2_amd64.deb Fast LZ compression algorithm library - runtime
liblz4-dev_0.0~r122-2_amd64.deb Fast LZ compression algorithm library - development files
liblz4-tool_0.0~r122-2_amd64.deb Fast LZ compression algorithm library - tool
Advertisement
Advertisement