liblwp-protocol-https-perl_6.06-2_all.deb


Advertisement

Description

liblwp-protocol-https-perl - HTTPS driver for LWP::UserAgent

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name liblwp-protocol-https-perl
Package version 6.06
Package release 2
Package architecture all
Package type deb
Installed size 56 B
Download size 9.36 KB
Official Mirror ftp.br.debian.org
The LWP::Protocol::https module provides support for using HTTPS schemed URLs
with LWP. LWP::Protocol::https is a plug-in to the LWP protocol handling, so
you don't use it directly. Once the module is installed LWP is able to access
sites using HTTP over SSL/TLS.
If hostname verification is requested by LWP::UserAgent's ssl_opts, and
neither SSL_ca_file nor SSL_ca_path is set, then SSL_ca_file is implied to be
the one provided by ca-certificates.
This module used to be bundled with libwww-perl, but it was unbundled in
v6.02 in order to be able to declare its dependencies properly for the CPAN
tool-chain. Applications that need HTTPS support can just declare their
dependency on LWP::Protocol::https and will no longer need to know what
underlying modules to install.

Alternatives

Package Version Architecture Repository
liblwp-protocol-https-perl_6.06-2_all.deb 6.06 all Debian Main
liblwp-protocol-https-perl - - -

Requires

Name Value
ca-certificates -
libio-socket-ssl-perl >= 1.54
libnet-http-perl -
libwww-perl >= 6.05-2
perl -

Replaces

Name Value
libwww-perl << 6.02

Download

Type URL
Binary Package liblwp-protocol-https-perl_6.06-2_all.deb
Source Package liblwp-protocol-https-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblwp-protocol-https-perl deb package:
    # sudo apt-get install liblwp-protocol-https-perl

Files

Path
/usr/share/doc/liblwp-protocol-https-perl/changelog.Debian.gz
/usr/share/doc/liblwp-protocol-https-perl/changelog.gz
/usr/share/doc/liblwp-protocol-https-perl/copyright
/usr/share/man/man3/LWP::Protocol::https.3pm.gz
/usr/share/perl5/LWP/Protocol/https.pm

Changelog

2014-07-15 - Dominique Dumont <dod@debian.org>
liblwp-protocol-https-perl (6.06-2) unstable; urgency=medium
* added patch to fix ssl issue with local proxy
2014-07-10 - Dominique Dumont <dod@debian.org>
liblwp-protocol-https-perl (6.06-1) unstable; urgency=medium
* Imported Upstream version 6.06
* removed fix-https-proxy patch (applied upstream)
* refreshed cert.patch
+ added patch to disable test which tries to connect to apache.org
+ added patch to fix test broken by 746579-fix-peer-* patch
2014-05-13 - Salvatore Bonaccorso <carnil@debian.org>
liblwp-protocol-https-perl (6.04-3) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* debian/control: remove Nicholas Bamber from Uploaders on request of
the MIA team.
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Refresh cert.patch for offset
* Add 746579-fix-peer-certificate-verification.patch patch.
Fixes "HTTPS_CA_DIR or HTTPS_CA_FILE disables peer certificate
verification for IO::Socket::SSL". When the intention was to only
disable hostname verification LWP::Protocol::HTTPS disabled also the
peer certificate verification completely. (CVE-2014-3230)
Thanks to Jakub Wilk and Steffen Ullrich (Closes: #746579)
* Update fix-https-proxy for fixed behaviour of LWP::Protocol::https
2013-11-30 - Dominique Dumont <dod@debian.org>
liblwp-protocol-https-perl (6.04-2) unstable; urgency=low
* added patch to fix https_proxy (Closes: #129528, #622212, #687834)
* compat: bumped to 9
* control:
*Standards-Version -> 3.9.5
* depends on libwww-perl 6.05-2 (yes -2 to get https proxy fix)
* added dod to uploaders
2013-05-25 - Florian Schlichting <fsfs@debian.org>
liblwp-protocol-https-perl (6.04-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Imported Upstream version 6.04.
* Fixed typos in extended description (closes: #660778).
* Droppd README.Debian, support for ca-certificates was added long ago.
* Refreshed cert.patch (offset).
* Bumped Standards-Version to 3.9.4 (update to copyright-format 1.0).
* Added myself to uploaders and copyright.
2012-02-20 - gregor herrmann <gregoa@debian.org>
liblwp-protocol-https-perl (6.03-1) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ Alessandro Ghedini ]
* New upstream release
* One sorted dep per line
* Bump debhelper compat level to 8
* Bump version (build) depends on libwww-perl and libio-socket-ssl-perl
* Drop network.patch (merged upstream)
* Update cert.patch
[ gregor herrmann ]
* Uppercase HTTPS in short/long description where it doesn't refer to
the module name itself. (Closes: #629822)
2011-05-19 - Nicholas Bamber <nicholas@periapt.co.uk>
liblwp-protocol-https-perl (6.02-1) unstable; urgency=low
* Initial Release (Closes: #620180).

See Also

Package Description
liblwp-protocol-psgi-perl_0.07-1_all.deb override LWP's HTTP/HTTPS backend with your own PSGI application
liblwp-protocol-socks-perl_1.7-1_all.deb SOCKS proxy support for LWP
liblwp-useragent-determined-perl_1.07-1_all.deb LWP useragent that retries errors
liblwpx-paranoidagent-perl_1.10-5_all.deb a "paranoid" subclass of LWP::UserAgent
liblwres90_9.9.5.dfsg-9+deb8u15_amd64.deb Lightweight Resolver Library used by BIND
liblwt-glib-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative GLib bindings for OCaml
liblwt-glib-ocaml_2.4.3-4+b1_amd64.deb cooperative GLib bindings for OCaml (runtime)
liblwt-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative light-weight thread library for OCaml
liblwt-ocaml-doc_2.4.3-4_all.deb cooperative light-weight thread library (documentation)
liblwt-ocaml_2.4.3-4+b1_amd64.deb cooperative light-weight thread library for OCaml (runtime)
liblwt-ssl-ocaml-dev_2.4.3-4+b1_amd64.deb cooperative OpenSSL bindings for OCaml
liblwt-ssl-ocaml_2.4.3-4+b1_amd64.deb cooperative OpenSSL bindings for OCaml (runtime)
liblz-dev_1.6-2_amd64.deb data compressor based on the LZMA algorithm (development)
liblz1_1.6-2_amd64.deb data compressor based on the LZMA algorithm (library)
liblz4-1_0.0~r122-2_amd64.deb Fast LZ compression algorithm library - runtime
Advertisement
Advertisement