libluabind0.9.1_0.9.1+dfsg-9_amd64.deb


Advertisement

Description

libluabind0.9.1 - luabind c++ binding for lua: runtime library

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libluabind0.9.1
Package version: 0.9.1+dfsg
Package release: 9
Package architecture: amd64
Package type: deb
Installed size: 153 B
Download size: 41.46 KB
Official Mirror: ftp.br.debian.org
Luabind is a library that helps you create bindings between C++ and Lua. It has the ability to expose functions and classes, written in C++, to Lua. It will also supply the functionality to define classes in lua and let them derive from other lua classes or C++ classes. Lua classes can override virtual functions from their C++ baseclasses. It is written towards Lua 5.0, and does not work with other Lua versions. This package contains the luabind runtime libraries, for applications that have been built with luabind.

Alternatives

    Download

    Source package: luabind

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libluabind0.9.1 deb package:
      # sudo apt-get install libluabind0.9.1

    Files

    • /usr/lib/libluabind.so.0.9.1
    • /usr/share/doc/libluabind0.9.1/README.Debian
    • /usr/share/doc/libluabind0.9.1/changelog.Debian.gz
    • /usr/share/doc/libluabind0.9.1/copyright

    Changelog

    2014-08-09 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-9) unstable; urgency=low * Change Build-Depends from "libboost1.54-all-dev | libboost1.55-all-dev | libboost1.53-dev | libboost1.49-dev" to libboost-all-dev (Closes: #757542) * libluabind-dev: Change Depends from "libboost1.53-dev | libboost-dev (>= 1.46.1-3~)" to libboost-dev (Closes: #754425) * debian/rules: Add build-arch and build-indep targets to the .PHONY target

    2014-03-09 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-8) unstable; urgency=low * Drop Build-Depends on libboost1.53-dev (Closes: #731066) * Update to Standards-Version 3.9.5 (no changes) * Fix lintian errors (privacy-breach-w3c-valid-html & privacy-breach-logo) by removing remote image references in doc/index.html

    2013-07-13 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-7) unstable; urgency=low * Tweak bjam invocation to account for instances where dpkg-buildflags returns an empty string; corrects FTBFS on ia64

    2013-07-13 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-6) unstable; urgency=low * Add Vcs-Git and Vcs-Browser fields in debian/control * Remove Arthur Loiret as maintainer (he has retired from the project) and move /me from uploaders to maintainer * Build with hardening options * Fix architecture independent and architecture dependent build targets * Update to Standards-Version 3.9.4 (no changes) * Support building with clang, cherry pick patch from upstream commit 3044a90 (Closes: #660375) (LP: #1055374) * Add patch to fix bug in cast graph cache, thanks to Peter Colberg (Closes: #660380) * Adjust build dependencies to prefer building against Boost 1.53 (Closes: #705182) * Add patch to support Lua 5.2, thanks to Peter Colberg (Closes: 660384) * Adjust build dependencies to build against Lua 5.2 instead of 5.1 * Drop unnecessary dependency on libboost-python-dev (LP: #568444)

    2012-04-23 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-5) unstable; urgency=low * Fix FTBFS (Closes: #667833) * Bump standards version to 3.9.3 (no changes required)

    2011-10-01 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-4) unstable; urgency=low * Support new multi-arch library locations (Closes: #642728, #641502)

    2011-06-14 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-3) unstable; urgency=low * Adjust Build-Depends for removal of boost-built (Closes: #629771) * Bump standards version to 3.9.2 (no changes required)

    2010-10-14 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-2) unstable; urgency=low * New binary package libluabind0.9.1 replaces libluabind0.9.0 (Thanks to Roman Shtylman for catching the ommission in the previous upload)

    2010-10-11 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9.1+dfsg-1) unstable; urgency=low * New Upstream Version * Refresh patches and remove 04_defer_longjmp.diff (now included upstream) * Fix watch file to properly mangle +dfsg suffix on upstream version * Update repack.sh script to deal with .tar.gz instead of .zip * Bump standards version to 3.9.1 (no changes required) * Specify source format as 3.0

    2010-06-19 - Roberto C. Sanchez <roberto@connexer.com> luabind (0.9+dfsg-3) unstable; urgency=low * New patch (Thanks to Andrew Morrow): + Move lua_error out of catch handler to defer longjmp

    Advertisement
    Advertisement