libloudmouth1-0_1.4.3-12_amd64.deb


Advertisement

Description

libloudmouth1-0 - Lightweight C Jabber library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libloudmouth1-0
Package version 1.4.3
Package release 12
Package architecture amd64
Package type deb
Installed size 120 B
Download size 57.50 KB
Official Mirror ftp.br.debian.org
Loudmouth is a lightweight and easy-to-use C library for programming
with the Jabber protocol. It's designed to be easy to get started
with and yet extensible to let you do anything the Jabber protocol
allows.

Alternatives

Package Version Architecture Repository
libloudmouth1-0_1.4.3-12_i386.deb 1.4.3 i386 Debian Main
libloudmouth1-0 - - -

Requires

Name Value
libasyncns0 >= 0.3
libc6 >= 2.14
libglib2.0-0 >= 2.16.0
libgnutls-deb0-28 >= 3.2.10-0
libidn11 >= 1.13

Download

Type URL
Binary Package libloudmouth1-0_1.4.3-12_amd64.deb
Source Package loudmouth

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libloudmouth1-0 deb package:
    # sudo apt-get install libloudmouth1-0

Files

Path
/usr/lib/libloudmouth-1.so.0
/usr/lib/libloudmouth-1.so.0.1.0
/usr/share/doc/libloudmouth1-0/AUTHORS
/usr/share/doc/libloudmouth1-0/NEWS.gz
/usr/share/doc/libloudmouth1-0/README
/usr/share/doc/libloudmouth1-0/changelog.Debian.gz
/usr/share/doc/libloudmouth1-0/changelog.gz
/usr/share/doc/libloudmouth1-0/copyright

Changelog

2014-07-05 - Andreas Henriksson <andreas@fatal.se>
loudmouth (1.4.3-12) unstable; urgency=medium
* Team upload
- brown paper bag release.
* Also make libloudmount1-dev depend on libgnutls28-dev
- like the build-dependency, this drops libgnutls-dev (gnutls26)
2014-07-05 - Andreas Henriksson <andreas@fatal.se>
loudmouth (1.4.3-11) unstable; urgency=medium
* Team upload.
[ Sébastien Villemot ]
* Add Vcs-* fields.
[ Andreas Henriksson ]
* Put Debian Gnome Maintainers in Maintainer field.
- Ross Burton isn't very active in Debian these days...
* Build-depend on libgnutls28-dev (Closes: #753127)
- instead of libgnutls-dev (gnutls26)
* Fix debian/watch regex to properly match stable releases only.
- change url to use ftp.gnome.org while at it.
2013-11-03 - Sébastien Villemot <sebastien@debian.org>
loudmouth (1.4.3-10) unstable; urgency=low
* Team upload.
* 09-libcheck-pthread.patch: new patch by Matthias Klose. Fixes build
failure, correcting the the configure check for the check library, and
manually add -lpthread (see #712140). Closes: #713710.
* Bump Standards-Version to 3.9.5, no changes needed.
2013-02-03 - Sébastien Villemot <sebastien@debian.org>
loudmouth (1.4.3-9) unstable; urgency=low
* Team upload.
* debian/patches/08-fix-ipv6-connect.patch: Fix crash when falling back
from IPv6 to IPv4. Thanks to Michael Stapelberg for the patch.
Closes: #631729
2012-03-26 - Michael Biebl <biebl@debian.org>
loudmouth (1.4.3-8) unstable; urgency=low
* Switch to dpkg source format 3.0 (quilt).
* Use dh-autoreconf:
- Drop debian/patches/90_autoreconf.patch
- Add Build-Depends on dh-autoreconf.
- Include /usr/share/cdbs/1/rules/autoreconf.mk in debian/rules.
* debian/patches/07-glib-single-include.patch: Fix build failure with
glib 2.32. where including individual glib headers is no longer allowed.
Closes: #665576
* debian/libloudmouth1-0.symbols: Strip debian revision from symbol
versions.
* debian/copyright: Add copyright information.
2010-12-05 - Emilio Pozuelo Monfort <pochu@debian.org>
loudmouth (1.4.3-7) unstable; urgency=low
* debian/patches/06_-lasyncns.patch:
- Move libasyncns from Libs to Libs.private. It's not needed
to link dynamically and that's causing build failures in
other packages because we don't depend on libasyncns-dev.
Closes: #605992.
2010-11-29 - Emilio Pozuelo Monfort <pochu@debian.org>
loudmouth (1.4.3-6) unstable; urgency=low
[ Tanguy Ortolo ]
* debian/patches/05-use-packaged-libasyncns.patch: Use packaged libasyncns
instead of embedded one. (Closes: #566143)
* debian/patches/90_autoreconf.patch: Run libtoolize and autoreconf on top
of the above patch.
[ Emilio Pozuelo Monfort ]
* debian/control.in:
- Build depend on libasyncns-dev.
2009-12-07 - Sjoerd Simons <sjoerd@debian.org>
loudmouth (1.4.3-5) unstable; urgency=low
* Use both whitespace and TCP keepalives. Some routers don't notice TCP
keepalive and some XMPP server time out clients after a certain amount
of idleness on the application layer (Openfire). (Closes: #520572)
2009-08-17 - Emilio Pozuelo Monfort <pochu@ubuntu.com>
loudmouth (1.4.3-4) unstable; urgency=low
* debian/rules, debian/watch: use ftp.gnome.org
* debian/patches/04-use-pkg-config-for-gnutls.patch: Use pkg-config to
look for gnutls. Closes: #529835.
* debian/patches/90_autoreconf.patch: Run autoreconf on top of the
above patch.
* debian/control.in: Let libloudmouth1-0-dbg and libloudmouth1-dev depend
on ${misc:Depends}.
* Standards-Version is 3.8.2, no changes needed.
* Inherit section from the source stanza.
* -dbg package is section debug.
* Remove note that people won't usually need the -dbg package from its
description.
* Run tests during build, build depend on check.

See Also

Package Description
libloudmouth1-dev_1.4.3-12_amd64.deb Development files for Loudmouth Jabber library
liblouis-bin_2.5.3-3+deb8u1_amd64.deb Braille translation library - utilities
liblouis-data_2.5.3-3+deb8u1_all.deb Braille translation library - data
liblouis-dev_2.5.3-3+deb8u1_amd64.deb Braille translation library - static libs and headers
liblouis2_2.5.3-3+deb8u1_amd64.deb Braille translation library - shared libs
liblouisutdml-bin_2.5.0-1_amd64.deb Braille UTDML translation utilities
liblouisutdml-data_2.5.0-1_all.deb Braille UTDML translation library - data
liblouisutdml-dev_2.5.0-1_amd64.deb Braille UTDML translation library - static libs and headers
liblouisutdml-java-doc_2.5.0-1_all.deb Braille UTDML translation library - java bindings documentation
liblouisutdml-java_2.5.0-1_all.deb Braille UTDML translation library - java bindings
liblouisutdml6_2.5.0-1_amd64.deb Braille UTDML translation library - shared libs
liblouisxml-bin_2.4.0-5_amd64.deb Braille XML translation utilities
liblouisxml-data_2.4.0-5_all.deb Braille XML translation library - data
liblouisxml-dev_2.4.0-5_amd64.deb Braille XML translation library - static libs and headers
liblouisxml1_2.4.0-5_amd64.deb Braille XML translation library - shared libs
Advertisement
Advertisement