libloki0.1.7_0.1.7-3_amd64.deb


Advertisement

Description

libloki0.1.7 - C++ library of generic design patterns

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libloki0.1.7
Package version 0.1.7
Package release 3
Package architecture amd64
Package type deb
Installed size 124 B
Download size 32.69 KB
Official Mirror ftp.br.debian.org
Loki is a ("the"?) C++ library of generic programming techniques, containing
flexible implementations of common design patterns and idioms. It is an
essential library for modern C++ programming and exposes many cool features
of the language.
The code accompanies the (non-free) book, _Modern C++ Design_ (Alexandrescu,
2001), which goes into depth on the design of the library.

Alternatives

Package Version Architecture Repository
libloki0.1.7_0.1.7-3_i386.deb 0.1.7 i386 Debian Main
libloki0.1.7 - - -

Requires

Name Value
libc6 >= 2.3
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.6

Download

Type URL
Binary Package libloki0.1.7_0.1.7-3_amd64.deb
Source Package libloki

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libloki0.1.7 deb package:
    # sudo apt-get install libloki0.1.7

Files

Path
/usr/lib/libloki.so.0.1.7
/usr/share/doc/libloki0.1.7/changelog.Debian.gz
/usr/share/doc/libloki0.1.7/changelog.gz
/usr/share/doc/libloki0.1.7/copyright

Changelog

2011-06-27 - Petr Baranov <petr@baranov.fi>
libloki (0.1.7-3) unstable; urgency=low
* New maintainer. (Closes: #620021)
* Sponsored by Al Nikolov <clown@debian.org>.
* Update Standards-Version (no changes)
* debian/control: add ${misc:Depends}
* debian/control: fix synopsis
2009-08-30 - Ivan Borzenkov <ivan1986@list.ru>
libloki (0.1.7-2) unstable; urgency=low
* fix yasli/random.h - error in bug number :) (Closes: #503829)
(only wrong number - fixed in 0.1.7-1)
* add watch file
* Update Standards-Version (no changes)
2009-05-08 - Ivan Borzenkov <ivan1986@list.ru>
libloki (0.1.7-1) unstable; urgency=low
* New upstream release
* New mantainer. (Closes: #508085)
* No needed rename (Closes: #430268)
* fix yasli/random.h (Closes: #512044)
* Update Standards-Version (no changes)
2008-04-05 - Stephen Gran <sgran@debian.org>
libloki (0.1.5-3.1) unstable; urgency=low
* Non-maintainer upload.
* Fix FTBFS with gcc-4.3 (closes: #413432)
* Update Standards-Version (no changes)
* Make lintian happy:
- Change from Source-Version to binary:Version in debian/control
- Don't ignore errors on clean
- Add copyright symbol to debian/copyright
- Move Homepage: from description to control field
- Register doc-base files with right section
2006-11-06 - Lukas Fittl <lfittl@fsfe.org>
libloki (0.1.5-3) unstable; urgency=low
* debian/rules: Always build with OS=Linux to fix FTBFS on kFreeBSD, Hurd
thanks to Petr Salinger (Closes: #392350)
* debian/control: Remove libloki-dev Depends on libc-dev, c++abi2-dev
they are already drawn in by build-essential
* debian/control: Priority should be optional, not extra
* debian/rules: Remove useless comments
* debian/rules: Set CXXFLAGS, not CFLAGS
* debian/copyright: Add myself as having "cleaned up" the package
2006-10-04 - Lukas Fittl <lfittl@fsfe.org>
libloki (0.1.5-2) unstable; urgency=low
* Add debian/libloki-doc.doc-base (Closes: #390976)
2006-09-11 - Lukas Fittl <lfittl@fsfe.org>
libloki (0.1.5-1) unstable; urgency=low
* New upstream release (Closes: #386825)
* debian/control: Adopt the package
* debian/control: Update to Standards-Version 3.7.2, no changes needed
* debian/compat, debian/control: Use debhelper compat level 5,
no changes needed
* debian/README.Debian: Update book website address (Closes: #336889)
* debian/copyright: Update copyright summary
* debian/rules: Cleanup
* debian/README.Debian: Replace 'Debian GNU/Linux',
there is also kfreebsd and hurd
* debian/README.Debian, rename to libloki-dev.README.Debian, as
only developer information is in there
* Drop debian/patches
- debian/patches/50-pkgconfig.dpatch: pkg-config is not needed for
this package
- debian/patches/20-Makefile.dpatch: Merged upstream and later removed,
because the original Makefile has been fixed
- debian/rules: Remove dpatch parts
- debian/control: Remove Build-Depends on dpatch
* src/Makefile: Avoid FTBFS by overriding CPPFLAGS and LDFLAGS
(taken from upstream cvs)
* src/Makefile: Link after calling install, otherwise we end up with
2 copies of the lib and no links (taken from upstream cvs)
* Build shared library packages
- debian/control: Add libloki{-dbg,0.1.5} packages
- debian/README.Debian: Remove obsolete 'About the package' section
- Add debian/libloki-dev.install
- Add debian/libloki0.1.5.install
* Install doxygen documentation
- debian/control: Add libloki-doc package
- Add debian/libloki-doc.install
2005-05-14 - martin f. krafft <madduck@debian.org>
libloki (0.0.20030413-2) unstable; urgency=low
* Removed suggestion on libtut-doc. Oops.
* Added more notes to README.Debian.
2005-05-11 - martin f. krafft <madduck@debian.org>
libloki (0.0.20030413-1) unstable; urgency=low
* Initial release (closes: Bug#251229).

See Also

Package Description
libloudmouth1-0_1.4.3-12_amd64.deb Lightweight C Jabber library
libloudmouth1-dev_1.4.3-12_amd64.deb Development files for Loudmouth Jabber library
liblouis-bin_2.5.3-3+deb8u1_amd64.deb Braille translation library - utilities
liblouis-data_2.5.3-3+deb8u1_all.deb Braille translation library - data
liblouis-dev_2.5.3-3+deb8u1_amd64.deb Braille translation library - static libs and headers
liblouis2_2.5.3-3+deb8u1_amd64.deb Braille translation library - shared libs
liblouisutdml-bin_2.5.0-1_amd64.deb Braille UTDML translation utilities
liblouisutdml-data_2.5.0-1_all.deb Braille UTDML translation library - data
liblouisutdml-dev_2.5.0-1_amd64.deb Braille UTDML translation library - static libs and headers
liblouisutdml-java-doc_2.5.0-1_all.deb Braille UTDML translation library - java bindings documentation
liblouisutdml-java_2.5.0-1_all.deb Braille UTDML translation library - java bindings
liblouisutdml6_2.5.0-1_amd64.deb Braille UTDML translation library - shared libs
liblouisxml-bin_2.4.0-5_amd64.deb Braille XML translation utilities
liblouisxml-data_2.4.0-5_all.deb Braille XML translation library - data
liblouisxml-dev_2.4.0-5_amd64.deb Braille XML translation library - static libs and headers
Advertisement
Advertisement