liblockdev1-dev_1.0.3-1.6+b1_amd64.deb


Advertisement

Description

liblockdev1-dev - Development library for locking devices

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name liblockdev1-dev
Package version 1.0.3
Package release 1.6+b1
Package architecture amd64
Package type deb
Installed size 54 B
Download size 7.71 KB
Official Mirror ftp.br.debian.org
It provides a reliable way to put an exclusive lock to
devices using _both_ FSSTND and SVr4 methods.
Includes header files and static lib.

Alternatives

Package Version Architecture Repository
liblockdev1-dev_1.0.3-1.6+b1_i386.deb 1.0.3 i386 Debian Main
liblockdev1-dev - - -

Requires

Name Value
libc6-dev -
liblockdev1 = 1.0.3-1.6+b1

Conflicts

Name Value
liblockdev0-dev -
liblockdev0g-dev -

Replaces

Name Value
liblockdev0-dev -
liblockdev0g-dev -

Download

Type URL
Binary Package liblockdev1-dev_1.0.3-1.6+b1_amd64.deb
Source Package lockdev

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblockdev1-dev deb package:
    # sudo apt-get install liblockdev1-dev

Files

Path
/usr/include/lockdev.h
/usr/include/ttylock.h
/usr/lib/liblockdev.a
/usr/lib/liblockdev.so
/usr/share/doc/liblockdev1-dev
/usr/share/man/man3/dev_lock.3.gz
/usr/share/man/man3/dev_relock.3.gz
/usr/share/man/man3/dev_testlock.3.gz
/usr/share/man/man3/dev_unlock.3.gz
/usr/share/man/man3/liblockdev.3.gz
/usr/share/man/man3/lockdev.3.gz

Changelog

2014-08-02 - gregor herrmann <gregoa@debian.org>
lockdev (1.0.3-1.6) unstable; urgency=medium
* Non-maintainer upload.
* Fix "hardcodes /usr/lib/perl5":
debian/rules:
- use $Config{vendorarch} for getting correct directory
- revamp install target for perl library
(Closes: #752714)
2012-06-08 - Samuel Thibault <sthibault@debian.org>
lockdev (1.0.3-1.5) unstable; urgency=low
* Non-maintainer upload.
* Fix hurd-i386 FTBFS (Closes: #668951).
2010-02-19 - Christoph Egger <christoph@debian.org>
lockdev (1.0.3-1.4) unstable; urgency=low
* Non-maintainer upload.
* Don't install copyright in both liblockdev1 and liblockdev1-dbg as
they share the same folde rin /usr/share/doc via symlink (Closes:
#563600)
* Use binary:Version instead of Source-Version
2009-12-30 - Christoph Egger <christoph@debian.org>
lockdev (1.0.3-1.3) unstable; urgency=low
* Non-maintainer upload.
* Don't remove non-existant file (Closes: #549731)
* Add ${shlibs:Depends} to -perl and -db (Closes: #553240, #553242)
*  -dbg package is section debug
* add misc:Depends
2006-11-28 - Andreas Barth <aba@not.so.argh.org>
lockdev (1.0.3-1.2) unstable; urgency=low
* Non-maintainer upload.
* Brown paperbag release: Fix uninstallability of the -dbg-package.
Closes: #400676
2006-11-27 - Andreas Barth <aba@not.so.argh.org>
lockdev (1.0.3-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix postinst. Closes: #366384
+ don't use numerical compares for version history, but
dpkg --compare-versions
+ do never wait for someone entering a key - that could be in
non-interactive mode ...
* Add upgrade information into NEWS.Debian.
2006-04-20 - Paweł Więcek <coven@debian.org>
lockdev (1.0.3-1) unstable; urgency=low
* New release
* Distinguish character and block devices when creating SVR4 type lockfiles
(closes: #331249)
* Fixed some typos in comments
2005-10-03 - Roger Leigh <rleigh@debian.org>
lockdev (1.0.2-1) unstable; urgency=low
* New release.
* debian/control:
+ Added myself as an uploader.  Thanks to Pawel Wiecek for granting
me co-maintainership.
+ Build-Depend upon debhelper 4.
+ Update to Standards-Version 3.6.2.
* debian/copyright:
+ Update FSF address.
+ Add myself as a contributor.
* debian/compat: Use debhelper v4.
* Remove all postinst and preinst templates; debhelper v4 generates
ldconfig calls automatically.
* Devices within subdirectories of /dev are locked properly, using
':' as a path delimiter in the device lock name.  For example,
/dev/pts/2 is locked as /var/lock/LCK..pts:2
(Closes: #115109, #135299).
* Device major and minor numbers are computed using GNU libc
builtins, rather than kernel headers (Closes: #331139).
* src/sample.c debugging is amended to use the proper debugging
functions (Closes: #331255).
2005-05-19 - Pawel Wiecek <coven@debian.org>
lockdev (1.0.1-7) unstable; urgency=low
* Applied patch from Aurelien Jarno <aurel32@debian.org> to support
GNU/k*BSD (closes: #302457)
* Fixed patch from 1.0.1-5.1 NMU to clean after itself (!)
2004-01-22 - Pawel Wiecek <coven@debian.org>
lockdev (1.0.1-6) unstable; urgency=low
* Applied patch from Kristof Koehler
<Kristof.Koehler@stud.uni-karlsruhe.de> to fix behavior when device is
locked by process with different UID (closes: #215807)

See Also

Package Description
liblockdev1-perl_1.0.3-1.6+b1_amd64.deb perl extension library for locking devices
liblockdev1_1.0.3-1.6+b1_amd64.deb Run-time shared library for locking devices
liblockfile-bin_1.09-6_amd64.deb support binaries for and cli utilities based on liblockfile
liblockfile-dev_1.09-6_amd64.deb Development library for liblockfile
liblockfile-simple-perl_0.208-1_all.deb Perl module for simple advisory file locking
liblockfile1_1.09-6_amd64.deb NFS-safe locking library
liblog-agent-logger-perl_0.1.1-6_all.deb extension for Log::Agent providing an application-level logging API
liblog-agent-perl_1.000-1_all.deb Perl module providing helper logging routines
liblog-agent-rotate-perl_0.104-2_all.deb extension for Log::Agent providing file-rotating features
liblog-any-adapter-callback-perl_0.09-1_all.deb module to send Log::Any logs to a subroutine
liblog-any-adapter-dispatch-perl_0.06-1_all.deb adapter to use Log::Dispatch with Log::Any
liblog-any-adapter-filehandle-perl_0.008-1_all.deb basic Log::Any::Adapter to forward messages to a filehandle
liblog-any-adapter-log4perl-perl_0.06-1_all.deb adapter to use Log::Log4perl with Log::Any
liblog-any-adapter-perl_0.11-1_all.deb class methods to tell Log::Any where to send its logs
liblog-any-perl_0.15-1_all.deb Perl module to log messages safely and efficiently
Advertisement
Advertisement