liblldb-3.4_3.4.2-13_amd64.deb


Advertisement

Description

liblldb-3.4 - Next generation, high-performance debugger, library

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: liblldb-3.4
Package version: 3.4.2
Package release: 13
Package architecture: amd64
Package type: deb
Installed size: 22.48 KB
Download size: 5.96 MB
Official Mirror: ftp.br.debian.org
LLDB is a next generation, high-performance debugger. It is built as a set of reusable components which highly leverage existing libraries in the larger LLVM Project, such as the Clang expression parser and LLVM disassembler. This package contains the LLDB runtime library.

Alternatives

Replaces

  • lldb-3.4 << 1:3.4.2-9~

    Download

    Source package: llvm-toolchain-3.4

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liblldb-3.4 deb package:
      # sudo apt-get install liblldb-3.4

    Files

    • /usr/lib/llvm-3.4/lib/liblldb.so.1
    • /usr/lib/python2.7/dist-packages/lldb-3.4/_lldb.so
    • /usr/lib/x86_64-linux-gnu/liblldb-3.4.so
    • /usr/lib/x86_64-linux-gnu/liblldb-3.4.so.1
    • /usr/share/doc/liblldb-3.4/NEWS.Debian.gz
    • /usr/share/doc/liblldb-3.4/changelog.Debian.gz
    • /usr/share/doc/liblldb-3.4/copyright
    • /usr/share/lintian/overrides/liblldb-3.4

    Changelog

    2014-10-15 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-13) unstable; urgency=medium * Try again to fix the arm64 FTBFS (Closes: #764530)

    2014-10-10 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-12) unstable; urgency=medium * Drop the LFS changes. FTBFS on most of the archs

    2014-10-09 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-11) unstable; urgency=medium * Fix some issues in the testsuite * lldb arm64 is disabled but a directory was installed. Create an empty directory to make dh_install happy. (Closes: #764530) * Build with LFS (large file support) (Closes: #759162)

    2014-09-26 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-10) unstable; urgency=medium * Fix my screw up. Add .1 to the libclang soname to make dpkg-shlibdeps happy * python-lldb-3.4 and lldb-3.3: error when trying to install together (Closes: #762902) * Remove useless dependency on doxygen

    2014-09-24 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-9) unstable; urgency=medium * Upload in unstable * Disable the co-instability of lldb & python-lldb (Python stuff conflicts)

    2014-09-18 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-9~exp2) experimental; urgency=medium * Remove the useless dependency lldb-3.4 => liblldb-3.4. Should be transparently managed by Debian tools * Does not have multiarch include paths on !linux (Closes: #759303) * Fails to find C++ include paths under Kfreebsd (Closes: #731711) Thanks to Steven Chamberlain for the help on the two previous fixes

    2014-08-30 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-9~exp1) experimental; urgency=medium * libclang-3.4.so should be used instead libclang.so. Update the soname to match the new lib name (Closes: #759538) * Rename liblldb.so to liblldb-3.4.so + update of the soname. * python-clang-3.4 description updated * liblldb-3.4 and python-lldb-3.4 added * lldb-3.4-dev renamed to liblldb-3.4-dev to match the previous changes * Manpages for llvm-ranlib, clang-apply-replacements, pp-trace and clang-tidy added * clang-3.4 should depends on binutils (for ld, at least) (Closes: #751030) * clang/www/analyzer/scripts/dbtree.js removed

    2014-08-16 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-8) unstable; urgency=medium * Try to bring back lldb-3.4-dev on mips & mipsel (Closes: #758314)

    2014-08-05 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-7) unstable; urgency=medium * Upload in unstable * Try to bring back lldb on mips & mipsel * Force scan-build to use the same version of clang * Try to fix hurd (hurd-EIEIO-undef.diff)

    2014-08-02 - Sylvestre Ledru <sylvestre@debian.org> llvm-toolchain-3.4 (1:3.4.2-7~exp1) experimental; urgency=medium * Co installation of clang (Closes: #736057) - scan-build => scan-build-3.4 - scan-view => scan-view-3.4 - asan_symbolize => asan_symbolize-3.4 * Remove of pollycc * clang alternatives are managed by llvm-defaults

    Advertisement
    Advertisement