libleveldb1_1.17-1_amd64.deb


Advertisement

Description

libleveldb1 - fast key-value storage library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libleveldb1
Package version 1.17
Package release 1
Package architecture amd64
Package type deb
Installed size 411 B
Download size 133.74 KB
Official Mirror ftp.br.debian.org
LevelDB is a fast key-value storage library written at Google that
provides an ordered mapping from string keys to string values.
Features:
* Keys and values are arbitrary byte arrays.
* Data is stored sorted by key.
* Callers can provide a custom comparison function to override
the sort order.
* The basic operations are Put(key,value), Get(key), Delete(key).
* Multiple changes can be made in one atomic batch.
* Users can create a transient snapshot to get a consistent view of
data.
* Forward and backward iteration is supported over the data.
* Data is automatically compressed using the Snappy compression
library.
* External activity (file system operations etc.) is relayed through
a virtual interface so users can customize the operating system
interactions.
* Detailed documentation about how to use the library is included with
the source code.
Limitations:
* This is not a SQL database. It does not have a relational data model,
it does not support SQL queries, and it has no support for indexes.
* Only a single process (possibly multi-threaded) can access a
particular database at a time.
* There is no client-server support builtin to the library.
An application that needs such support will have to wrap their own
server around the library.
This package provides the shared library.

Alternatives

Package Version Architecture Repository
libleveldb1_1.17-1_i386.deb 1.17 i386 Debian Main
libleveldb1 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libsnappy1 -
libstdc++6 >= 4.9
multiarch-support -

Download

Type URL
Binary Package libleveldb1_1.17-1_amd64.deb
Source Package leveldb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libleveldb1 deb package:
    # sudo apt-get install libleveldb1

Files

Path
/usr/lib/x86_64-linux-gnu/libleveldb.so.1
/usr/lib/x86_64-linux-gnu/libleveldb.so.1.17
/usr/share/doc/libleveldb1/changelog.Debian.gz
/usr/share/doc/libleveldb1/copyright

Changelog

2014-06-19 - Alessio Treglia <alessio@debian.org>
leveldb (1.17-1) unstable; urgency=low
* New upstream release.
* Fix trivial mistake in 1002-cstdatomic_renaming.patch. (Closes: #741325)
2014-03-10 - Alessio Treglia <alessio@debian.org>
leveldb (1.15.0-2) unstable; urgency=low
* Allow tests to fail on mips only. Thanks to Dmitry Smirnov
for the hint. (Closes: #735515)
2014-01-29 - Alessio Treglia <alessio@debian.org>
leveldb (1.15.0-1) unstable; urgency=low
* New upstream release.
* Update Standards.
* Refresh patches.
* Multiarchify the -DBG runtime.
* Update copyright holders information.
2013-11-07 - Alessio Treglia <alessio@debian.org>
leveldb (1.14.0-3) unstable; urgency=low
[ paul cannon ]
* Ship leveldb-dbg package. (Closes: #728916)
2013-10-16 - Alessio Treglia <alessio@debian.org>
leveldb (1.14.0-2) unstable; urgency=low
* Inject CPPFLAGS into CFLAGS for hardening.
* Don't fail when tests fail (temporary workaround, tests are buggy).
2013-09-20 - Alessio Treglia <alessio@debian.org>
leveldb (1.14.0-1) unstable; urgency=low
* New upstream release.
* Remove 1003-sparc_alignment.patch, fixed upstream.
* Refresh patches.
2013-08-27 - Alessio Treglia <alessio@debian.org>
leveldb (1.13.0-2) unstable; urgency=low
* Fix FTBFS on sparc{,64}.
Thanks to Hilko Bengen for the patch. (Closes: #681946)
2013-08-24 - Alessio Treglia <alessio@debian.org>
leveldb (1.13.0-1) unstable; urgency=low
* New upstream release. (Closes: #720609)
* Refresh patches.
* Update debian/copyright.
2013-06-27 - Alessio Treglia <alessio@debian.org>
leveldb (1.12.0-1) unstable; urgency=low
[ Alessio Treglia ]
* New upstream release.
* Refresh patches.
[ Martin Pitt ]
* debian/tests/build: Fix typo in file name passed to g++,
to make the test actually work.
2013-05-27 - Alessio Treglia <alessio@debian.org>
leveldb (1.10.0-1) unstable; urgency=low
* New upstream release.
* debian/patches/0113-makefile_memenv.patch: Install missing component
"memenv" (Closes: #701075). Thanks to Dmitry Smirnov for the report
and patch.
* Fix VCS fields.
* Refresh patches.

See Also

Package Description
liblexical-failure-perl_0.000006-1_all.deb Perl module for user-selectable lexically-scoped failure signaling
liblexical-persistence-perl_1.022-1_all.deb module for accessing persistent data through lexical variables
liblexical-sealrequirehints-perl_0.007-1+b2_amd64.deb Perl module to prevent the leakage of lexical hints
liblexical-underscore-perl_0.003-1_all.deb access your caller's lexical underscore
liblexical-var-perl_0.009-1+b1_amd64.deb Perl module for using static variables without namespace pollution
liblfc-dev_1.8.7-3.1+b1_amd64.deb LFC development libraries and header files
liblfc-perl_1.8.7-3.1+b1_amd64.deb LCG File Catalog (LFC) perl bindings
liblfc1_1.8.7-3.1+b1_amd64.deb LCG File Catalog (LFC) libraries
liblfunction-dev_1.23+dfsg-3_amd64.deb development files for liblfunction
liblfunction0_1.23+dfsg-3_amd64.deb library for calculating with L-functions
liblhapdf-dev_5.9.1-3+b1_amd64.deb [Physics] Les Houches Accord PDF Interface - development files
liblhapdf0_5.9.1-3+b1_amd64.deb [Physics] Les Houches Accord PDF Interface
liblhasa-dev_0.2.0+git3fe46-1+deb8u1_amd64.deb lzh decompression library - development files
liblhasa0_0.2.0+git3fe46-1+deb8u1_amd64.deb lzh archive decompression library
liblib-abs-perl_0.93-1_all.deb module to make relative path absolute to caller
Advertisement
Advertisement