liblas3_1.8.0-1_amd64.deb


Advertisement

Description

liblas3 - ASPRS LiDAR data translation library - C++ version

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name liblas3
Package version 1.8.0
Package release 1
Package architecture amd64
Package type deb
Installed size 955 B
Download size 261.41 KB
Official Mirror ftp.br.debian.org
libLAS is a C/C++ library for reading and writing ASPRS LAS versions
1.0, 1.1 and 1.2 data. The LAS format is a sequential binary format
used to store data from sensors and as intermediate processing storage
by some LiDAR-related applications. LiDAR (Light Detection and Ranging)
is an optical remote sensing technology that measures properties of
scattered light to find range and/or other information of a distant
target. The prevalent method to determine distance to an object or
surface is to use laser pulses.
This package contains the C++ shared library used by applications.

Alternatives

Package Version Architecture Repository
liblas3_1.8.0-1_i386.deb 1.8.0 i386 Debian Main
liblas3 - - -

Requires

Name Value
libboost-filesystem1.55.0 -
libboost-iostreams1.55.0 -
libboost-program-options1.55.0 -
libboost-system1.55.0 -
libboost-thread1.55.0 -
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libgdal1h >= 1.9.0
libgeotiff2 -
libstdc++6 >= 4.9
libtiff5 >= 4.0.3

Download

Type URL
Binary Package liblas3_1.8.0-1_amd64.deb
Source Package liblas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblas3 deb package:
    # sudo apt-get install liblas3

Files

Path
/usr/lib/liblas.so.2.3.0
/usr/lib/liblas.so.3
/usr/share/doc/liblas3/AUTHORS
/usr/share/doc/liblas3/README.txt
/usr/share/doc/liblas3/changelog.Debian.gz
/usr/share/doc/liblas3/copyright
/usr/share/lintian/overrides/liblas3

Changelog

2014-08-21 - Ross Gammon <rossgammon@mail.dk>
liblas (1.8.0-1) unstable; urgency=medium
* Move to unstable
2014-08-03 - Bas Couwenberg <sebastic@xs4all.nl>
liblas (1.8.0-1~exp1) experimental; urgency=medium
* New upstream release.
* Drop patches applied upstream:
- boost
- soversion
- separator-typo
* Drop patches backported from upstream:
- 0001-remove-old-LAStools-utilities-that-don-t-belong-in-liblas.patch
- update_gdal_geotiff.patch
* Update fix_library_search patch for SONAME bump.
* Update package names for SONAME bump.
* Add build dependencies for boost_iostreams & boost_filesystem.
* Fix executable-not-elf-or-script for python examples.
* Add patch to fix 'accommodate' typo.
* Strip RPATH from binaries.
2014-08-01 - Ross Gammon <rossgammon@mail.dk>
liblas (1.7.0+dfsg-6) unstable; urgency=medium
[ Bas Couwenberg ]
* Add build dependency on liblaszip-dev for compression support.
* Use dh_install --list-install.
* Also include lasblock & ts2las programs in liblas-bin.
* Add patch from upstream to remove old LAStools utilities.
(closes: #749403)
[ Ross Gammon ]
* Ignore quilt dir
* Update to build against latest gdal (1.11.0)
* Revert inclusion of liblaszip until it passes the new queue
* Add myself to uploaders
2014-03-06 - Bas Couwenberg <sebastic@xs4all.nl>
liblas (1.7.0+dfsg-5) unstable; urgency=low
* Add myself to Uploaders.
* Also remove generated man pages on clean.
* Add gbp.conf to use prinstine-tar by default.
2014-02-21 - Bas Couwenberg <sebastic@xs4all.nl>
liblas (1.7.0+dfsg-4) unstable; urgency=low
* Move python dependencies from Build-Depends-Indep to Build-Depends.
2014-02-08 - Bas Couwenberg <sebastic@xs4all.nl>
liblas (1.7.0+dfsg-3) unstable; urgency=low
* Team upload.
* Update debian watch file with sepwatch changes,
and handle more common mistakes.
* Refresh boost patch.
* Also build python extension, replaces separate source package.
(closes: #735516)
* Remove obsolete liblas1.install.
* Add patch to fix the library version and SONAME.
* Add lintian overrides for no symbols file,
symbols are problematic for C++ libraries.
* Enable verbose build logs.
* Add patch from python-liblas to fix the library search path.
* Use pybuild instead of python_distutils buildsystem.
Thanks Graham Inggs for the patch.
* Change libtiff build dependency to libtiff-dev only.
(closes: #736129)
* Update liblas-dev dependency on libgdal-dev to match the build dependency.
* Drop shlibs:Depends for -dev packages.
* Add manpages for liblas-bin & liblas-dev.
(closes: #645820)
* Install python examples.
2014-01-05 - Francesco Paolo Lovergine <frankie@debian.org>
liblas (1.7.0+dfsg-2) unstable; urgency=medium
* Fixed missing linking of system boost component.
(closes: #733282)
2013-12-27 - Francesco Paolo Lovergine <frankie@debian.org>
liblas (1.7.0+dfsg-1) unstable; urgency=medium
* Merged change accepted upstream to substitute the non-free SHA1
implementation with a MIT/X11 implementation as provided by 
http://tamale.net/sha1
(closes: #730754)
* Revised debian/copyright to reflect changes and missing licenses.
(closes: #730755)
* Policy bumped to 3.9.5, no changes required.
* Moved to new libgdal-dev b-d.
* Moved to canonical Vcs-* fields.

See Also

Package Description
liblash-compat-1debian0_1+dfsg0-5_amd64.deb LASH compatibility library
liblash-compat-dev_1+dfsg0-5_all.deb LASH compatibility library (development files)
liblasi-dev_1.1.0-1.1_amd64.deb development files and documentation for the LASi library
liblasi0_1.1.0-1.1_amd64.deb creation of PostScript documents containing Unicode symbols
liblasso-perl_2.4.1-1_amd64.deb Library for Liberty Alliance and SAML protocols - Perl bindings
liblasso3-dev_2.4.1-1_amd64.deb Library for Liberty Alliance and SAML protocols - development kit
liblasso3_2.4.1-1_amd64.deb Library for Liberty Alliance and SAML protocols - runtime library
liblastfm-dev_1.0.8-2_amd64.deb Last.fm web services library - development files
liblastfm-fingerprint1_1.0.8-2_amd64.deb Last.fm fingerprinting library
liblastfm-java_0.1.0-2_all.deb last.fm API bindings for Java
liblastfm-ocaml-dev_0.3.0-3+b2_amd64.deb OCaml interface to audioscrobbler and lastfm radios
liblastfm1_1.0.8-2_amd64.deb Last.fm web services library
liblatex-decode-perl_0.03-2_all.deb Perl module to convert LaTeX input to Unicode
liblatex-driver-perl_0.200.4-1_all.deb driver module that encapsulates the details of formatting a LaTeX document
liblatex-encode-perl_0.091.6-1_all.deb Perl module to encode characters for LaTeX formatting
Advertisement
Advertisement