liblapack3gf_3.5.0-4_all.deb


Advertisement

Description

liblapack3gf - Transitional package for liblapack3

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name liblapack3gf
Package version 3.5.0
Package release 4
Package architecture all
Package type deb
Installed size 45 B
Download size 12.16 KB
Official Mirror ftp.br.debian.org
LAPACK version 3.X is a comprehensive FORTRAN library that does
linear algebra operations including matrix inversions, least
squared solutions to linear sets of equations, eigenvector
analysis, singular value decomposition, etc. It is a very
comprehensive and reputable package that has found extensive
use in the scientific community.

Alternatives

Package Version Architecture Repository
liblapack3gf_3.5.0-4_all.deb 3.5.0 all Debian Main
liblapack3gf - - -

Requires

Name Value
liblapack3 -

Download

Type URL
Binary Package liblapack3gf_3.5.0-4_all.deb
Source Package lapack

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblapack3gf deb package:
    # sudo apt-get install liblapack3gf

Files

Path
/usr/share/doc/liblapack3gf/changelog.Debian.gz
/usr/share/doc/liblapack3gf/copyright
/usr/share/lintian/overrides/liblapack3gf

Changelog

2014-10-15 - Sébastien Villemot <sebastien@debian.org>
lapack (3.5.0-4) unstable; urgency=medium
[ Alastair McKinstry ]
* Add lapack-netlib.pc support with update-alternatives.
[ Sébastien Villemot ]
* Bump Standards-Version to 3.9.6, no changes needed.
2014-08-07 - Sébastien Villemot <sebastien@debian.org>
lapack (3.5.0-3) unstable; urgency=medium
[ Sébastien Villemot ]
* New patches from upstream and OpenBLAS to fix bugs:
- cgesvd-zgesvd-stack-corruption.patch
- zlanhf-clanhf-norm.patch
- zstemr-n2.patch
* Remove Sylvestre Ledru from Uploaders. Thanks Sylvestre for your work!
* ia64_ignore_testfailures.patch: drop patch, ia64 is now gone.
* Drop obsolete code in maintainer scripts to deal with the transition
liblapack.so.3gf => liblapack.so.3.
[ Martin Pitt ]
* gcc is not enough for the xerbla-c test as we also need libc6-dev and
others. Just upgrade the dependency to build-essential. (Closes: #740174)
2013-11-23 - Sébastien Villemot <sebastien@debian.org>
lapack (3.5.0-2) unstable; urgency=low
* Do not compile the testsuite with -frecursive. Otherwise some test
binaries allocate too much space on the stack, leading to crashes on
mips{,el}.
2013-11-21 - Sébastien Villemot <sebastien@debian.org>
lapack (3.5.0-1) unstable; urgency=low
* New upstream release.
* Upstream tarball is now DFSG-compatible, adapt the repackaging code.
* Remove recursive.patch. Replace it by the -frecursive flag to gfortran, as
recommended by upstream for fixing #693269.
* debian/copyright: document the license of lapacke.
* Bump Standards-Version to 3.9.5, no changes needed.
* Ship lapacke PDF in liblapack-doc.
* doxygen-exclude-binary-objects.patch: new patch, makes Doxygen skip binary
objects.
* liblapack-doc: go back to Doxygen-generated jquery.js, instead of the
version shipped in the libjs-jquery package. Otherwise the HTML
documentation is unusable.
2013-09-21 - Sébastien Villemot <sebastien@debian.org>
lapack (3.4.2+dfsg-4) unstable; urgency=low
* ia64_ignore_testfailures.patch: now ignore all test failures on ia64.
2013-09-21 - Sébastien Villemot <sebastien@debian.org>
lapack (3.4.2+dfsg-3) unstable; urgency=low
* Remove -funroll-all-loops from build flags. It may diminish
performance, and creates segfaults on ia64.
* ia64_ignore_testfailures.patch: new patch. Ignore two test failures on
ia64.
2013-09-14 - Sébastien Villemot <sebastien@debian.org>
lapack (3.4.2+dfsg-2) unstable; urgency=low
[ Sébastien Villemot ]
* Bump to debhelper compat level 9
* Simplification and improvement of debian/rules:
+ use dh
+ remove hack to workaround timeouts in testsuite
+ ship testsuite summary generated by LAPACK build system instead of
generating our own
+ do not run testsuite if DEB_BUILD_OPTIONS contains "nocheck"
(Closes: #718948)
+ ensure that flags from dpkg-buildflags are injected everywhere
* Install static library in liblapacke-dev
* Remove remnants of old system for notifying testsuite errors at
installation of the library
* Switch VCS to Git
* liblapack-dev now alternatively depends on libblas.so (Closes: #695825)
* liblapack-dev now provides liblapack.so (instead of liblapack-3.so), for
consistency with libblas-dev
* Do not ship a copy of jquery.js; instead link to the version from the Debian
package
* Fix debian/watch
[ Julian Taylor ]
* strip -Bsymbolic-functions from LDFLAGS. -Bsymbolic-functions breaks
xerbla_ error handling overrides as internal calls to it will not go
over the plt anymore. With bfd linker --dynamic-list could be used
instead but it doesn't seem work with gold linker. (Closes: #722252)

See Also

Package Description
liblapacke-dev_3.5.0-4_amd64.deb Library of linear algebra routines 3 - Headers
liblapacke_3.5.0-4_amd64.deb Library of linear algebra routines 3 - C lib shared version
liblas-bin_1.8.0-1_amd64.deb ASPRS LiDAR data translation toolset
liblas-c-dev_1.8.0-1_amd64.deb ASPRS LiDAR data translation library - C development files
liblas-c3_1.8.0-1_amd64.deb ASPRS LiDAR data translation library - C version
liblas-dev_1.8.0-1_amd64.deb ASPRS LiDAR data translation library - C++ development files
liblas3_1.8.0-1_amd64.deb ASPRS LiDAR data translation library - C++ version
liblash-compat-1debian0_1+dfsg0-5_amd64.deb LASH compatibility library
liblash-compat-dev_1+dfsg0-5_all.deb LASH compatibility library (development files)
liblasi-dev_1.1.0-1.1_amd64.deb development files and documentation for the LASi library
liblasi0_1.1.0-1.1_amd64.deb creation of PostScript documents containing Unicode symbols
liblasso-perl_2.4.1-1_amd64.deb Library for Liberty Alliance and SAML protocols - Perl bindings
liblasso3-dev_2.4.1-1_amd64.deb Library for Liberty Alliance and SAML protocols - development kit
liblasso3_2.4.1-1_amd64.deb Library for Liberty Alliance and SAML protocols - runtime library
liblastfm-dev_1.0.8-2_amd64.deb Last.fm web services library - development files
Advertisement
Advertisement