libkrosscore4_4.14.2-5+deb8u2_amd64.deb


Advertisement

Description

libkrosscore4 - Kross Core Library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package filename libkrosscore4_4.14.2-5+deb8u2_amd64.deb
Package name libkrosscore4
Package version 4.14.2
Package release 5+deb8u2
Package architecture amd64
Package type deb
Category implemented-in::c++ libs role::shared-lib
Homepage http://kross.dipe.org
License -
Maintainer Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Download size 79.44 KB
Installed size 272.00 KB
Kross is a scripting bridge for the KDE Development Platform used to embed
scripting functionality into an application. Kross provides an abstract API to
provide scripting functionality in a interpreter-independent way. The
application that uses Kross should not need to know anything about the
scripting language being used.
The core of Kross provides the framework to deal transparently with
interpreter-backends and offers abstract functionality to deal with scripts.
This package is part of the KDE Development Platform libraries module.

Alternatives

Package Version Architecture Repository
libkrosscore4_4.14.2-5+deb8u2_i386.deb 4.14.2 i386 Debian Main
libkrosscore4 - - -

Requires

Name Value
libc6 >= 2.14
libkdecore5 = 4:4.14.2-5+deb8u2
libkdeui5 = 4:4.14.2-5+deb8u2
libqt4-script >= 4:4.8.0
libqt4-xml >= 4:4.8.0
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libstdc++6 >= 4.1.1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libkrosscore4_4.14.2-5+deb8u2_amd64.deb
Source Package kde4libs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkrosscore4 deb package:
    # sudo apt-get install libkrosscore4

Files

Path
/usr/lib/libkrosscore.so.4
/usr/lib/libkrosscore.so.4.14.2
/usr/share/doc/libkrosscore4/NEWS.Debian.gz
/usr/share/doc/libkrosscore4/changelog.Debian.gz
/usr/share/doc/libkrosscore4/copyright

Changelog

2017-05-11 - Salvatore Bonaccorso <carnil@debian.org>
kde4libs (4:4.14.2-5+deb8u2) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* Sanitize URLs before passing them to FindProxyForURL (CVE-2017-6410)
(Closes: #856890)
* Verify that whoever is calling us is actually who he says he is
(CVE-2017-8422)
2016-08-06 - Salvatore Bonaccorso <carnil@debian.org>
kde4libs (4:4.14.2-5+deb8u1) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* CVE-2016-6232: Extraction of tar files possible to arbitrary system
locations (Closes: #832620)
2015-01-19 - Sandro KnauƟ <bugs@sandroknauss.de>
kde4libs (4:4.14.2-5) unstable; urgency=medium
* Team upload.
* Add debian/patches/KRecursiveFilterProxyModel-Fixed-the-model.diff
(Closes: #775114)
2014-12-01 - Scott Kitterman <scott@kitterman.com>
kde4libs (4:4.14.2-4) unstable; urgency=medium
* Team upload.
* Add debian/patches/allow_cancel_ssl.diff (cherry-picked from 4.14.3) to
make it possible for cancelling certificate acceptance succeed (Closes:
#771744)
- Note: This completes the fixes for this issue.  See #769852 for
kdepimlibs and #750995 for kdepim-runtime for the rest
2014-10-24 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.2-3) unstable; urgency=medium
* Manually fix symbols files.
* Bump Standards-Version to 3.9.6, no changes needed
2014-10-23 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.2-2) unstable; urgency=medium
* Update symbols files from buildds logs (4:4.14.2-1).
2014-10-20 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.2-1) unstable; urgency=medium
* New upstream release (4.14.2).
* Update symbols files from buildds logs (4:4.14.1-1).
* Remove upstream applied patch: skip_kmountpointtest_if_no_mtab
* Remove upstream patch: upstream-copyjob.cpp.diff
* Update symbols files.
2014-09-16 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.1-1) unstable; urgency=medium
* New upstream release (4.14.1).
* New patch: skip_kmountpointtest_if_no_mtab
* New upstream patch: upstream-copyjob.cpp.diff
* Update symbols files from buildd logs (4:4.14.0-1).
2014-08-20 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.14.0-1) unstable; urgency=medium
* New upstream release.
* Update symbols files with the 4:4.13.3 build logs.
* Remove upstream patches.
* Refresh patches.
* Update symbols files.
2014-07-25 - Maximiliano Curia <maxy@debian.org>
kde4libs (4:4.13.3-2) unstable; urgency=medium
* Update symbols with the buildds logs.
* New upstream patch: upstream_use-dbus-system-bus-name-instead-of-
pid.patch (Closes: #755814) Fixes: CVE-2014-5033

See Also

Package Description
libkrossui4_4.14.2-5+deb8u2_amd64.deb Kross UI Library
libkryo-java-doc_2.20-3_all.deb object graph serialization framework for Java - doc
libkryo-java_2.20-3_all.deb object graph serialization framework for Java
libksane-data_4.14.0-1_all.deb scanner library (data files)
libksane-dev_4.14.0-1_amd64.deb scanner library development headers
libksane0_4.14.0-1_amd64.deb scanner library (runtime)
libksba-dev_1.3.2-1+deb8u1_amd64.deb X.509 and CMS support library - development files
libksba8_1.3.2-1+deb8u1_amd64.deb X.509 and CMS support library
libkscreen-dev_1.0.5-1_amd64.deb library for screen management - development files
libkscreen1_1.0.5-1_amd64.deb library for screen management - shared library
libkscreensaver5_4.11.13-2_amd64.deb library of the KDE Screensaver system
libksgrd4_4.11.13-2_amd64.deb library for ksysguard
libksieve4_4.14.1-1+deb8u1_amd64.deb Sieve, the mail filtering language, library
libksieveui4_4.14.1-1+deb8u1_amd64.deb Sieve, the mail filtering language, GUI library
libksignalplotter4_4.11.13-2_amd64.deb KSignalPlotter widget
Advertisement
Advertisement