libjson-static-camlp4-dev_0.9.8-1+b6_amd64.deb


Advertisement

Description

libjson-static-camlp4-dev - JSON validator and converter for OCaml

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libjson-static-camlp4-dev
Package version: 0.9.8
Package release: 1+b6
Package architecture: amd64
Package type: deb
Installed size: 122 B
Download size: 17.27 KB
Official Mirror: ftp.br.debian.org
json-static is a tool for converting parsed JSON data with an unchecked structure into specialized OCaml types and vice-versa. By reading a type definition, the preprocessor inserts code that converts between OCaml types and untyped JSON data. Type definitions are written in a syntax which is very close to regular OCaml type definitions.

    Download

    Source package: json-static

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libjson-static-camlp4-dev deb package:
      # sudo apt-get install libjson-static-camlp4-dev

    Files

    • /usr/lib/ocaml/json-static/META
    • /usr/lib/ocaml/json-static/pa_json_static.cmi
    • /usr/lib/ocaml/json-static/pa_json_static.cmo
    • /usr/share/doc/libjson-static-camlp4-dev/README.gz
    • /usr/share/doc/libjson-static-camlp4-dev/changelog.Debian.amd64.gz
    • /usr/share/doc/libjson-static-camlp4-dev/changelog.Debian.gz
    • /usr/share/doc/libjson-static-camlp4-dev/changelog.gz
    • /usr/share/doc/libjson-static-camlp4-dev/copyright
    • /usr/share/doc/libjson-static-camlp4-dev/examples/yahoo.ml
    • /var/lib/ocaml/lintian/libjson-static-camlp4-dev.info
    • /var/lib/ocaml/md5sums/libjson-static-camlp4-dev.md5sums

    Changelog

    2009-09-23 - Romain Beauxis <toots@rastageeks.org> json-static (0.9.8-1) unstable; urgency=low * New upstream release. * Bumped standards version to 3.8.3 * Changed section to ocaml * Changed ocaml.mk cdbs support include to /usr/share/cdbs/1/rules/ocaml.mk

    2009-03-07 - Romain Beauxis <toots@rastageeks.org> json-static (0.9.6-2) unstable; urgency=low * New upload to build against ocaml 3.11. * Updated packaging: + Added build-dep on dh-ocaml. + Bumped compat to 7. + Using new variable to install targets.

    2008-08-02 - Romain Beauxis <toots@rastageeks.org> json-static (0.9.6-1) unstable; urgency=low * Initial release and upload to unstable Closes: #493109

    Advertisement
    Advertisement