libjs-json_0~20121008-2_all.deb


Advertisement

Description

libjs-json - JSON encoders/decoders implemented in JavaScript

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libjs-json
Package version 0~20121008
Package release 2
Package architecture all
Package type deb
Installed size 134 B
Download size 24.49 KB
Official Mirror ftp.br.debian.org
JSON is a light-weight, language independent, data interchange format.
See http://www.JSON.org/
The files in this collection implement JSON encoders/decoders in
JavaScript.
JSON became a built-in feature of JavaScript when the ECMAScript
Programming Language Standard - Fifth Edition was adopted by the ECMA
General Assembly in December 2009. Most of the files in this collection
are for applications that are expected to run in obsolete web browsers.

Alternatives

Package Version Architecture Repository
libjs-json_0~20121008-2_all.deb 0~20121008 all Debian Main
libjs-json - - -

Download

Type URL
Binary Package libjs-json_0~20121008-2_all.deb
Source Package json-js

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjs-json deb package:
    # sudo apt-get install libjs-json

Files

Path
/usr/share/doc/libjs-json/README
/usr/share/doc/libjs-json/buildinfo_all.gz
/usr/share/doc/libjs-json/changelog.Debian.gz
/usr/share/doc/libjs-json/copyright
/usr/share/javascript/json/cycle.js
/usr/share/javascript/json/cycle.min.js
/usr/share/javascript/json/json.js
/usr/share/javascript/json/json.min.js
/usr/share/javascript/json/json2.js
/usr/share/javascript/json/json2.min.js
/usr/share/javascript/json/json_parse.js
/usr/share/javascript/json/json_parse.min.js
/usr/share/javascript/json/json_parse_state.js
/usr/share/javascript/json/json_parse_state.min.js

Changelog

2012-11-14 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20121008-2) unstable; urgency=low
* Fix fixate get-orig-source target to snapshot (not follow tip of VCS).
2012-11-14 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20121008-1) unstable; urgency=low
* New snapshot of upstream VCS.
[ Jonas Smedegaard ]
* Update watch and rules files to use archive subdir at github.com.
* Bump dephelper compatibility level to 8.
* Build-depend on devscripts, to always check copyright during build.
* Update copyright file:
+ Fix use pseudo-comment section to obey silly restrictions of
copyright format 1.0.
2012-06-22 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20120621-1) unstable; urgency=low
* New snapshot of upstream VCS.
* Directly use github.com URL (not githubredir.debian.net redirctor)
when fetching upstream source.
2012-03-25 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20120322-1) unstable; urgency=low
* New snapshot of upstream VCS.
* Bump standards-version to 3.9.3.
* Use anonscm.debian.org URL in Vcs-Browser field.
* Bump debhelper compatibility level to 7.
* Update copyright file:
+ Bump format to 1.0.
+ Shorten and quote licenses in comment.
2011-12-25 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20111021-1) unstable; urgency=low
* Rerelease using pristine git tarball.
* Update watch file to use more flexible regex.
* Use CDBS snippet upstream-tarball for get-orig-source target and
more.
2011-12-23 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20111020-1) unstable; urgency=low
* New snapshot of upstream VCS.
[ Jonas Smedegaard ]
* Drop local-options file: defaults since dpkg-source 1.16.1.
* Relax to build-depend unversioned on debhelper: Needed version
satisfied even in oldstable.
2011-04-22 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20110315-1) unstable; urgency=low
* New snapshot of upstream VCS.
[ Jonas Smedegaard ]
* Package now team-maintained:
+ Set Debian Javascript Maintainers as maintainer.
+ Set myself as uploader.
* Bump policy compliance to standards-version 3.9.2.
* Adjust copyright file:
+ Fix use initial wildcard Files section (not list wildcard
copyright/licensing in header section).
* Bump copyright file format to draft 174 of DEP-5.
* Use uglifyjs (not yui-compressor). Update build-dependencies
accordingly.
2010-12-30 - Jonas Smedegaard <dr@jones.dk>
json-js (0~20101208-1) unstable; urgency=low
* Initial release.
Closes: Bug#610259.

See Also

Package Description
libjs-jsrender_1.0~pre21-1_all.deb JavaScript template rendering system
libjs-jssip_0.4.0.20140212.1-3_all.deb JavaScript implementation of a WebRTC SIP video phone
libjs-jstorage_0.3.1-1_all.deb store data locally with JavaScript
libjs-languages4translatewiki_0.1.3-1_all.deb Javascript globalization and localization for browser use
libjs-leaflet-markercluster_0.4.0~dfsg-1_all.deb Provides Marker Clustering functionality for Leaflet
libjs-leaflet_0.7.3~dfsg-1_all.deb JavaScript library for mobile-friendly interactive maps
libjs-less_1.4.2-1_all.deb the LESS CSS meta-language - Javascript library
libjs-lodash_2.4.1+dfsg-3_all.deb Lo-dash is a Javascript utility library
libjs-lru-cache_2.3.1-1_all.deb Javascript least-recently-used cache object
libjs-marked_0.3.2+dfsg-1_all.deb Full-featured markdown parser and compiler
libjs-mathjax-doc_2.4+20140903-1_all.deb JavaScript display engine for LaTeX and MathML (documentation)
libjs-mathjax_2.4-2_all.deb JavaScript display engine for LaTeX and MathML
libjs-mediaelement_2.15.1+dfsg-1_all.deb HTML5 <audio> or <video> player with Flash and Silverlight shims
libjs-mocha_1.20.1-1_all.deb simple, flexible, fun test framework - JavaScript library
libjs-mochikit_1.4.2-4_all.deb JavaScript library inspired by Python
Advertisement
Advertisement