libjffi-java_1.0.2-11_all.deb


Advertisement

Description

libjffi-java - Java Foreign Function Interface

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libjffi-java
Package version: 1.0.2
Package release: 11
Package architecture: all
Package type: deb
Installed size: 152 B
Download size: 80.06 KB
Official Mirror: ftp.br.debian.org
JFFI is a wrapper for libffi, the foreign function interface library. A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language. Java-based codings helper classes for Joni and JRuby

Alternatives

    Download

    Source package: jffi

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libjffi-java deb package:
      # sudo apt-get install libjffi-java

    Files

    • /usr/share/doc/libjffi-java/changelog.Debian.gz
    • /usr/share/doc/libjffi-java/copyright
    • /usr/share/java/jffi-1.0.2.jar
    • /usr/share/java/jffi.jar
    • /usr/share/maven-repo/org/jruby/extras/jffi/1.0.2/jffi-1.0.2.jar
    • /usr/share/maven-repo/org/jruby/extras/jffi/1.0.2/jffi-1.0.2.pom
    • /usr/share/maven-repo/org/jruby/extras/jffi/debian/jffi-debian.jar
    • /usr/share/maven-repo/org/jruby/extras/jffi/debian/jffi-debian.pom

    Changelog

    2013-06-15 - Jakub Adam <jakub.adam@ktknet.cz> jffi (1.0.2-11) unstable; urgency=low * Re-enable OSGi metadata generation. - Request from Ubuntu only applies to their 'main' components, this package is in 'universe'.

    2013-06-10 - tony mancill <tmancill@debian.org> jffi (1.0.2-10) unstable; urgency=low * Team upload. [ Jakub Adam ] * Add OSGi metadata into jffi.jar. (currently disabled - see below) * Add Jakub Adam to Uploaders. * Bump Standards-Version to 3.9.4. [ tony mancill ] * Comment-out call to bnd as per request on debian-java: - http://lists.debian.org/debian-java/2013/02/msg00057.html * Remove non UTF-8 in debian changelog. (Closes: #711890) * Acknowledge NMU - thank you to Matthias Klose. - Closes: #646594, #707797, #701301 * Address lintian warning regarding BSD license.

    2013-05-12 - Matthias Klose <doko@debian.org> jffi (1.0.2-9.1) unstable; urgency=low * Non maintainer upload. * Remove Torsten Werner from uploaders. * Don't hard-code dependency on libffi runtime library. Closes: #646593, #707797. * Fix build failure with GCC 4.8. Closes: #701301.

    2012-05-30 - tony mancill <tmancill@debian.org> jffi (1.0.2-9) unstable; urgency=low * Team upload. * Patch d/control build-dep on default-jdk. (Closes: #675180) - Thanks to James Page. * Bump Standards-Version to 3.9.3 (no changes). * d/copyright: update for DEP5 and to address lintian warnings. * d/control: update Vcs-Git URL.

    2012-05-04 - Matthias Klose <doko@debian.org> jffi (1.0.2-8.1) unstable; urgency=low * Non maintainer upload. * Fix build failure with GCC 4.7. Closes: #667215.

    2011-09-17 - Torsten Werner <twerner@debian.org> jffi (1.0.2-8) unstable; urgency=low * Add version restriction to Depends: libjffi-jni. * Add a patch to load jffi-native.jar from system directory.

    2010-09-16 - Torsten Werner <twerner@debian.org> jffi (1.0.2-7) experimental; urgency=low * Change Build-Depends: openjdk-6-jdk. (Closes: #594023)

    2010-08-05 - Torsten Werner <twerner@debian.org> jffi (1.0.2-6) unstable; urgency=low * Do not add -m32 or -m64 to CC and LD in libtest, too.

    2010-08-05 - Torsten Werner <twerner@debian.org> jffi (1.0.2-5) unstable; urgency=low * Do not add -m32 or -m64 to CC and LD.

    2010-08-05 - Torsten Werner <twerner@debian.org> jffi (1.0.2-4) unstable; urgency=low * Move all Build-Depends-Indep to Build-Depends. (Closes: #591641)

    Advertisement
    Advertisement