libjenkins-winstone-java_2.8-1_all.deb


Advertisement

Description

libjenkins-winstone-java - Jenkins branch of Winstone servlet container

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libjenkins-winstone-java
Package version 2.8
Package release 1
Package architecture all
Package type deb
Installed size 1.51 KB
Download size 1.33 MB
Official Mirror ftp.br.debian.org
Winstone is a servlet container that was written out of a desire to provide
servlet functionality without the bloat that full J2EE compliance introduces.
This package contains the Jenkins branch of this project

Alternatives

Package Version Architecture Repository
libjenkins-winstone-java_2.8-1_all.deb 2.8 all Debian Main
libjenkins-winstone-java - - -

Download

Type URL
Binary Package libjenkins-winstone-java_2.8-1_all.deb
Source Package jenkins-winstone

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjenkins-winstone-java deb package:
    # sudo apt-get install libjenkins-winstone-java

Files

Path
/usr/share/doc/libjenkins-winstone-java/changelog.Debian.gz
/usr/share/doc/libjenkins-winstone-java/copyright
/usr/share/java/jenkins-winstone-2.8.jar
/usr/share/java/jenkins-winstone.jar
/usr/share/maven-repo/org/jenkins-ci/winstone/2.8/winstone-2.8.jar
/usr/share/maven-repo/org/jenkins-ci/winstone/2.8/winstone-2.8.pom
/usr/share/maven-repo/org/jenkins-ci/winstone/debian/winstone-debian.jar
/usr/share/maven-repo/org/jenkins-ci/winstone/debian/winstone-debian.pom

Changelog

2014-10-21 - Emmanuel Bourg <ebourg@apache.org>
jenkins-winstone (2.8-1) unstable; urgency=medium
* Team upload.
* New upstream release
- Refreshed java8-compatibility.patch
* Standards-Version updated to 3.9.6 (no changes)
2014-09-15 - Emmanuel Bourg <ebourg@apache.org>
jenkins-winstone (2.3-2) unstable; urgency=medium
* Team upload.
* Rebuilt with jetty8/ 8.1.16-1 to fix the wrong version of the Servlet API
embedded in the winstone jar
2014-09-05 - Emmanuel Bourg <ebourg@apache.org>
jenkins-winstone (2.3-1) unstable; urgency=medium
* Team upload.
* New upstream release
- Added build dependencies on libjetty8-java, libjetty8-extra-java
and libmaven-shade-plugin-java
- Removed specification-resources.patch since the JEE spec files now come
with Jetty. Removed the related notes in README.source and d/copyright.
- Refreshed java8-compatibility.patch
- Disabled the SPDY connector
- Disabled the tests (requires org.kohsuke:ajp-client)
* Use XZ compression for the upstream tarball
2014-04-16 - Emmanuel Bourg <ebourg@apache.org>
jenkins-winstone (0.9.10-jenkins-47+dfsg-2) unstable; urgency=medium
* Team upload.
* Do not create a self signed certificate every time the HTTPS connector
is started without a proper certificate. This fixes the compatibility
with Java 8 since the sun.security.x509.CertAndKeyGen class has been
moved to the sun.security.tools.keytool package.
* debian/control:
- Build depend on default-jdk instead of openjdk-7-jdk
- Use canonical URLs for the Vcs-* fields
- Standards-Version updated to 3.9.5 (no changes)
* Switch to debhelper level 9
2013-08-12 - James Page <jamespage@debian.org>
jenkins-winstone (0.9.10-jenkins-47+dfsg-1) unstable; urgency=low
* New upstream release. 
* d/control: Update my email address.
2013-05-16 - James Page <james.page@ubuntu.com>
jenkins-winstone (0.9.10-jenkins-42+dfsg-1) unstable; urgency=low
* Upload to unstable. 
2013-02-17 - James Page <james.page@ubuntu.com>
jenkins-winstone (0.9.10-jenkins-42+dfsg-1~exp1) experimental; urgency=low
* New upstream release:
- d/control,maven.rules: Bump junit -> junit4.
2013-01-09 - James Page <james.page@ubuntu.com>
jenkins-winstone (0.9.10-jenkins-41+dfsg-1~exp1) experimental; urgency=low
* New upstream release:
- d/p/java7-compat.patch: Dropped - no longer required.
- d/control,rules: Ensure package is built with Java 7.
* Tidied lintian warnings.
2012-06-21 - James Page <james.page@ubuntu.com>
jenkins-winstone (0.9.10-jenkins-37+dfsg-1) unstable; urgency=low
* New upstream release:
- d/patches/java-1.6.patch: Dropped - upstream is now Java 6 compatible.
- d/control: Add new dependency on libmaven-enforcer-plugin-java.
* Fix FTBFS with openjdk-7 (LP: #888947):
- d/patches/java7-compat.patch: Add stub methods and allow compilation
with Java 6+.
2012-04-26 - James Page <james.page@ubuntu.com>
jenkins-winstone (0.9.10-jenkins-35+dfsg-1) unstable; urgency=low
* New upstream release.
* Bumped Standards-Version to 3.9.3:
- d/copyright: Switched Format to reference release version of DEP-5.
* Added missing patch headers.

See Also

Package Description
libjenkins-xstream-java-doc_1.4.7-jenkins-1-2_all.deb Documentation for libjenkins-xstream-java
libjenkins-xstream-java_1.4.7-jenkins-1-2_all.deb Java library to serialize objects to XML and back again
libjerasure-dev_2.0.0-2_amd64.deb forward error correction erasure channel library - development files
libjerasure2_2.0.0-2_amd64.deb forward error correction erasure channel library - shared library
libjericho-html-java-doc_3.1-2_all.deb libjericho-html-java documentation
libjericho-html-java_3.1-2_all.deb Java based library for HTML Parsing
libjets3t-java-doc_0.8.1+dfsg-1_all.deb documentation for libjets3t-java
libjets3t-java_0.8.1+dfsg-1_all.deb Java interface to Amazon S3 and CloudFront services
libjettison-java_1.2-3_all.deb collection of StAX parsers and writers for JSON
libjetty-extra-java_6.1.26-4_all.deb Java servlet engine and webserver -- extra libraries
libjetty-extra_6.1.26-4_amd64.deb Java servlet engine and webserver -- extra libraries
libjetty-java-doc_6.1.26-4_all.deb Javadoc for the Jetty API
libjetty-java_6.1.26-4_all.deb Java servlet engine and webserver -- core libraries
libjetty8-extra-java_8.1.16-4_all.deb Java servlet engine and webserver -- extra libraries
libjetty8-java-doc_8.1.16-4_all.deb Javadoc for the Jetty API
Advertisement
Advertisement