libjdom1-java - lightweight and fast library using XML

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libjdom1-java
Package version: 1.1.3
Package release: 1
Package architecture: all
Package type: deb
Installed size: 211 B
Download size: 146.91 KB
Official Mirror:
JDOM is, quite simply, a Java representation of an XML document. JDOM provides a way to represent that document for easy and efficient reading, manipulation, and writing. It has a straightforward API, is lightweight and fast, and is optimized for the Java programmer. It's an alternative to DOM and SAX, although it integrates well with both DOM and SAX.




    Source package: libjdom1-java

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libjdom1-java deb package:
      # sudo apt-get install libjdom1-java


    • /usr/share/doc/libjdom1-java/changelog.Debian.gz
    • /usr/share/doc/libjdom1-java/copyright
    • /usr/share/java/jdom1-1.1.3.jar
    • /usr/share/java/jdom1.jar
    • /usr/share/maven-repo/org/jdom/jdom/1.1.3/jdom-1.1.3.jar
    • /usr/share/maven-repo/org/jdom/jdom/1.1.3/jdom-1.1.3.pom
    • /usr/share/maven-repo/org/jdom/jdom/debian/jdom-debian.jar
    • /usr/share/maven-repo/org/jdom/jdom/debian/jdom-debian.pom


    2013-07-29 - Emmanuel Bourg <> libjdom1-java (1.1.3-1) unstable; urgency=low [ Emmanuel Bourg ] * New upstream release: - Updated the Maven pom - Dropped the +dfsg qualifier since no non-free feature was removed - Updated debian/ for the new source layout - Removed the unused lintian overrides * Removed the javadoc jar from the documentation package * debian/control: - Updated Standards-Version to 3.9.4 (no changes) - Use canonical URLs in the Vcs-* fields - Removed java-virtual-machine from the suggested dependencies * debian/copyright: Merged the duplicate Copyright fields [ tony mancill ] * Correct typo in package description. (Closes: #703155) - Thanks to Pascal De Vuyst for the bug report.

    2011-11-20 - Damien Raude-Morvan <> libjdom1-java (1.1.2+dfsg-2) unstable; urgency=low [ Jakub Adam ] * Fix OSGi metadata after last upload [ Damien Raude-Morvan ] * Add Depends on libjaxen-java for libjdom1-java.

    2011-11-02 - Damien Raude-Morvan <> libjdom1-java (1.1.2+dfsg-1) unstable; urgency=low * New upstream release! - d/watch: Update to github. - d/README.source,d/ Updated. - d/control: Add Build-Deps on libregexp-java for contrib. * d/control: Add missing Build-Deps on libxerces2-java. * Enable unit testing: - d/control: Add Build-Deps on junit and ant-optional. - d/ Set junit.jar property.

    2011-10-17 - Jakub Adam <> libjdom1-java (1.1.1+dfsg-5) unstable; urgency=low [Jakub Adam] * Add OSGi metadata to jar manifest [tony mancill] * Update Vcs-Svn link in debian/control * Fix lintian warnings regarding DEP5 formatting in debian/copyright

    2011-08-07 - Damien Raude-Morvan <> libjdom1-java (1.1.1+dfsg-4) unstable; urgency=low * Really upload to unstable.

    2011-08-07 - Damien Raude-Morvan <> libjdom1-java (1.1.1+dfsg-3) experimental; urgency=low * Upload to unstable. * Bump Standards-Version to 3.9.2 (no changes needed). * Remove Java runtime Depends. * Add lintian-override for libjdom1-java-doc: codeless-jar. * Fix debian/watch to use dversionmangle.

    2010-12-05 - Ludovic Claude <> libjdom1-java (1.1.1+dfsg-2) experimental; urgency=low [Ludovic Claude] * Bump Standards-Version to 3.9.1 (no changes needed) * Use source format 3.0 (quilt) * Add --has-package-version to the pom * Replace dh_auto-install with dh $@ --buildsystem=ant --with maven_repo_helper * Install the javadoc jar in the Maven repository [Damien Raude-Morvan] * Remove Arnaud Vandyck from Uploaders

    2009-11-08 - Damien Raude-Morvan <> libjdom1-java (1.1.1+dfsg-1) unstable; urgency=low * New upstream version. - Update debian/pom.xml * New libjdom1-java-doc package: - Split API Javadoc from bytecode (Closes: #506366) - Install API Javadoc to /usr/share/doc/libjdom1-java/api/ * Add myself to Uploaders * Build-Depends on default-jdk instead of default-jdk-builddep because we don't build a native GCJ package. * Use Debhelper 7: - Refactor debian/rules file (Closes: #538020) - Define classpath in debian/ * Bump Standards-Version to 3.8.3 (no changes needed)

    2009-08-09 - Torsten Werner <> libjdom1-java (1.1+dfsg-3) unstable; urgency=low * Upload to unstable.

    2009-05-16 - Ludovic Claude <> libjdom1-java (1.1+dfsg-2) experimental; urgency=low * Add watch file * Change section to java, bump up Standards-Version to 3.8.1 * Add the Maven POM to the package, * Add a Build-Depends-Indep dependency on maven-repo-helper * Use mh_installpom and mh_installjar to install the POM and the jar to the Maven repository