libjasypt-java - java library for simple high-level encryption

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libjasypt-java
Package version: 1.8
Package release: 2
Package architecture: all
Package type: deb
Installed size: 242 B
Download size: 146.26 KB
Official Mirror:
Jasypt is a java library which allows the developer to add basic encryption capabilities to projects. It provides : * High-security, standards-based encryption techniques, both for unidirectional and bidirectional encryption. * Transparent integration with Hibernate. * Suitable for integration into Spring-based applications and also transparently integrable with Spring Security. * Integrated capabilities for encrypting the configuration of applications (i.e. datasources). * Specific features for high-performance encryption in multi-processor/multi-core systems. * Open API for use with any JCE provider.



    Source package: jasypt

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libjasypt-java deb package:
      # sudo apt-get install libjasypt-java


    • /usr/share/doc/libjasypt-java/changelog.Debian.gz
    • /usr/share/doc/libjasypt-java/changelog.gz
    • /usr/share/doc/libjasypt-java/copyright
    • /usr/share/java/jasypt-1.8.jar
    • /usr/share/java/jasypt.jar
    • /usr/share/maven-repo/org/jasypt/jasypt/1.8/jasypt-1.8.jar
    • /usr/share/maven-repo/org/jasypt/jasypt/1.8/jasypt-1.8.pom
    • /usr/share/maven-repo/org/jasypt/jasypt/debian/jasypt-debian.jar
    • /usr/share/maven-repo/org/jasypt/jasypt/debian/jasypt-debian.pom


    2014-09-09 - Emmanuel Bourg <> jasypt (1.8-2) unstable; urgency=medium * Team upload. * debian/control: - Depend on libservlet3.1-java instead of libservlet2.5-java - Suggest the optional Maven dependencies instead of recommending them - Standards-Version updated to 3.9.5 (no changes) - Use canonical URLs for the Vcs-* fields * Switch to debhelper level 9

    2011-09-22 - Damien Raude-Morvan <> jasypt (1.8-1) unstable; urgency=low * New upstream version. * Wrap and sort Build-Depends and Depends. * d/copyright: Use versioned URL for DEP-5.

    2011-06-19 - Damien Raude-Morvan <> jasypt (1.7.1-1) unstable; urgency=low * Initial release (Closes: #631013).